PDA

View Full Version : FM: Brotherhood of the Falcon - Cannot find 3rd doused torch



Vanguard
2nd Oct 2003, 01:15
I'm in the mission where you get to an old seminary that is now taken over by armored haunts and vampires. To open the door to get to the sanctuary requires frobbing 3 doused torches. I found 2 of them; one is behind rubble in a corner room on the 2nd floor, and the other was in the 2nd floor hallway across from the stationary vampire. I've even offed all the AIs to let me thoroughly search but haven't found the 3rd doused torch yet. The framerate is horrible. It was okay at the beginning but at some point it got very jerky (and upping the game file's priority in Task Manager didn't even help). Eventually I have to give up scrounging around because I get nauseous from all the jerkiness. I can hear more vampires behind a solid wall on the 2nd floor and one metal door is not frobbable. So where's that 3rd torch?

Nightwalker
2nd Oct 2003, 03:49
I think the other one is downstairs, in the office.

Vanguard
3rd Oct 2003, 23:22
Thanks for the hint. That worked. I had been in there several times before but didn't get the doused torch base to illuminate to show it is frobbable, and contrast is so minimal that it is almost impossible to see until it lights up. In a technical thread, I'm discussing how to get the game to play more smoothly. However, something occurs partway into this FM where at about 1-second intervals there is a jerk. A restart of the mission has no jerk but eventually something gets triggered that causes it. It's like in other FMs where a trap was left running and sucked up CPU cycles on every iteration of the trap. This made me sick from the jerkiness so I couldn't play too long. Even upping the priority of the running Thief processes didn't help. It also made panning around to look also jerky so it is possible that I happened to keep missing the torch as I was looking around for the walls for a doused torch. Again, thanks for the hint. I have now completed the mission.

Peter_Smith
4th Oct 2003, 00:55
I had exactly the same experience with the jerky motion, although it did not make me sick. I also had the game slow down and crash on me whenever I was looking at running water, expecially with fish. That was a real problem in the first mission where it was necessary to swim in the water. Falcon was well designed and basically fun to play, but these defects made it an extreme pain in the butt. Too bad. :( It would be nice if these things could be looked at and corrected.

Nightwalker
4th Oct 2003, 03:15
It could be that Christine and the betatesters never encountered this problem. I played them all and they ran beautifully. No crashes or slowdowns.

MadBull#34
4th Oct 2003, 08:42
Same here. Since I was one of the betatesters I know for sure, that noone had this problem during the tests.

Peter_Smith
4th Oct 2003, 12:51
Nightwalker and MadBull,

I know that Nightwalker and I use the same video card (Geforce 4 Ti 4200), so that can't be it. Could you all be using Windows 98? I know Vanguard and I are using Windows 2000, so maybe that is the common difference. It is funny, though, that most FM's run fine on my system. If so, maybe I need a Windows 98 machine for Thief alone....

ChristineS
4th Oct 2003, 13:22
I'm not sure, what system MadBull uses, but I know that Hrothgar played it with windows 2000 - he told me, he had problems with thief (fms and dromed) until he installed the new detonator drivers.

The strange thing is, that noone during the betatests and after the release in the German forums has any problems (it was released in Germany some weeks earlier). I won't have released Night Falcon in English, if there were any problems. I'm using windows me, and I'm sorry, but I just don't know how to fix a problem, that I never had :(

Nightwalker
4th Oct 2003, 14:48
I use XP Pro. I don't think you can be expected to fix something when you can't duplicate it, Christine. There must be some common denominator between the machines of the people who are experiencing this problem, as Peter suggested, as most people don't seem to be running into it.

MadBull#34
4th Oct 2003, 14:58
I also use Win2k and my graphik-card is GF4 4600 Ti. Strange. :confused:

Peter_Smith
4th Oct 2003, 16:28
Very strange indeed. And frustrating. I wish we could find a common cause. Well, Christine and beta testers, you are clearly absolved of any guilt.:D Sorry about the complaining. Maybe Vanguard and I both need to rebuild our systems. Who knows?

I could do a fresh download from Jason's site and test it out. I got it through Bit Torrent, and the download itself gave me a lot of grief / restarts, too. It could be corrupt, I suppose, but I thought that file corruption would not be possible if the ZIP was declared valid (good check sum and all that).

MadBull#34
4th Oct 2003, 17:41
That's right. A zip-file, which is damaged or with an incorrect length is not able to get opened. To go for sure, you can check the size in Bytes on Jasons page. Maybe it's the RAM. Who knows. I've got 768MB. What about you?

ChristineS
4th Oct 2003, 18:04
I only have 256 Ram and it works fine :confused:

Peter_Smith
5th Oct 2003, 06:55
Good news. I checked out a few things, and I am pretty sure my crashes were caused by a bad download.

I've got 512 MB memory. More than enough for any Thief mission. Also, I just updated to the latest Nvidia drivers and it made no difference in the poor performance of the last mission. Checked a bunch of Direct-3D settings, and they made no difference. My Audigy sound drivers are up to date.

The total number of bytes (175947424) in the ZIP checked with Jason's site.

Running out of options, short of a system rebuild, I was thinking it might be a corrupt ZIP file in spite of the good checksum, so I downloaded the file again. The problem with the crashing near water and fish disappeared! I can think of no explanation for that other than a bad ZIP file.

It cannot be the fact that I installed the OM in Darkloader before installing the new ZIP file. I did that same thing with the old ZIP file, and the fish still crashed it.

The last mission is still hard on the frame rate. I think many people have had that problem, so Vanguard and I are not unique there. When I run, there is a stuttering or lunging motion. But it is not as bad now as it was before.

I also noticed that the longer you play this mission pack, the worse the stuttering problem becomes. Quitting and restarting Thief2 fixed that. Apparently Thief or the new video drivers have a memory leak. I had never seen that effect so obviously before tonight. I have played continuously for hours on some other missions and never had to restart Thief. Who knows. Maybe that is the new video drivers. There is always something. :)

Peter_Smith
5th Oct 2003, 07:01
As to how I could have a bad download and a correct checksum, I think that is possible. I am guessing that all it takes is one bit somewhere in the file changed from 1 to 0 and a second bit somewhere else changed from 0 to 1. One bit, say in a fish model, is enough to cause a fatal error.

ChristineS
5th Oct 2003, 15:14
I'm glad that the water and fishes are now ok :)

But the strange things are the slowdowns... I'm not good at technical things, but there are some differences, that makes me wondering. Tell me, if it's stupid:

- The German Version of Night Falcon runs fine, I have never heared about slowdowns, strange...

- The only difference are the books and the voices. The voices for the hammerites and the vampires. I have taken the English voices from Dromed de luxe. (These sounds are from the English Version of Thief Gold). For the german Version, I have taken the sounds from my Thief Gold (I only have it in German). Is it possible, that one of these soundfiles can make the slowdowns? Maybe one isn't ok (like your download with the fishes?), not every comment will be played always, so only a few player hit it? Maybe the problem is something with the soundcards?

Peter_Smith
5th Oct 2003, 22:12
Christine,

Your comment is not stupid at all. As a matter of fact, sound can cause serious slowdown and crashing of a mission. It is possible that the water sound was doing that to me before. Since I downloaded the mission's ZIP file twice, and the second version still has the slowdown, I am thinking it cannot be a corrupt download but maybe some contents or properties of a file or even a sound card issue.

I have a Soundblaster Audigy, first version, with latest drivers. I know there have been issues with that card. I cannot say if this is repsponsible, but you might ask to see if this is a common thread.

I have observed with other sound cards, some time ago, that sometimes sounds can reverberate creating significant slowdown. An example is the fireball room in Bonehoard, T1 original mission. If you get enough zombie parts around there, expecially in the corridors just outside the door, the body parts can create an unstable high frequency sound resonance that is activated by the fireballs (the fireball impacts shift the body parts, initiating the noise). The sound resonance of the body parts echoing against one another can bring the computer down. It is stopped only if you run far from the resonating area, save the game there, and reload it. Then you can separate the body parts, throwing some over the edge to the floor below, and the problem will stop. :)

It is possible that there is some sound resonance somwhere in the mission, perhaps even beyond the player's hearing, that is stealing the CPU cycles.

I don't know how to correct this in Dromed. I am not a dromedder. But from the physics standpoint, the way is to put damping into the system so that the sounds decay soon after they are made and do not reverberate for long. Maybe there is something that can be done with textures or brushes that control the amount of decay of the sound. If you can deaden the passages to prevent lots of echos, that may do the trick. I do notice that the vampire's (mage's) voices seem to have a lot of echo in them. Or maybe the things they throw, on spashing against the wall, could do it. Or, maybe you need to stop sounds when the player is so far away that he can no longer hear them. One way to test this is to remove sources of sound and see if that fixes it.

Vanguard
6th Oct 2003, 03:01
I just did a re-download of the FM and it did play much better. However, I wasn't about to waste time going through the first missions when it was just the last mission that caused problems. So I hit Shift+Ctrl+Alt+End to abort each mission until I got to the last one. Thank God for the sword/dagger that darkens you since I had no money at the loadout screen to buy water or gas arrows to douse torches. The once-per-second stutter did not reappear. The gameplay was still somewhat jerky but no worse than in Shipping and Receiving. Any hard disk activity would still cause a lot of jerk but upping the priority level on thief.exe and thief.icd helped some with that (but doesn't eliminate it). I didn't try putting them in real-time mode; I seem to recall I tried that once and the game hung which then hung the operating system and required hitting the reset button on the case.

theBlackman
21st Oct 2003, 07:41
Having much fun with Night of the Falcon, but...

Have skipped most of the thread to make sure I don't get any hints.

Am through with Marek and moving on into town. My complaint at the moment is that the ROPEARROWS work only half the time.

There are two balconies so far that seem reachable, one is. But even though I can use Broadheads and put an arrow into every wood part of either balcony, any Ropearrow that is a fraction of an inch above the floor level does not become a rope arrow. It just acts like a Broadhead.

I have checked this about 50 times and used the telescope vision to make sure. Arrows in the balustrade or posts do not even let down a short rope to meet the floor level.

The balcony by Mareks can be climbed to although it is not necessary.

The one next to the cathedral cannot be reached from any angle. I put a rope arrow into every piece of wood there, and I mean every piece. The only place the rope deploys is from the angled support brackets under the stone balcony floor. There is no rope deployment from any other piece of wood that the arrow hits.

Nightwalker
21st Oct 2003, 12:08
Yes, I noticed the same thing. I think it's better to make balconys that aren't meant to be accessed out of something rope arrows won't stick into at all. Cuts down on frustration and confusion.

theBlackman
23rd Oct 2003, 19:16
Another minor bug and into the depths of dispair:
In the Wellhofer prison, when you enter the pendelum room: If you get past the pendelum to the rear wall, 5 out of 6 times you are unable to return to the door. I must have restarted from a save at least 8 times before I managed to get into and out of the rear portion of the room.

When you pickup the bodies, and the lone purse, the arc of the swing will lock you in the rear part of the room. And if you walk right up to the pendelum, it will not kill you.

At the moment I am in search of the magic gem.
I am playing hide and seek with the bat. He nailed me for about 2 HP right at the entrance. I ducked back into the stairwell and tried again.

Some well placed H20 and so far, I have the sceptor, most of the loot in the eastern and western portions, including the chests directly opposite the door and the F/arrow in the room with the two caskets. Am working my way through the far west corridor.

The center west opposite the F/arrow chamber is next on the list. Have not tried to "kill" the bat or the spectres, and hope I don't come to that. From the trail of smoke they leave in passing, I fear that I am ill-equiped to do so, although I have about 20 H20, some Holy water, the fountain upstairs, and about 11 flash bombs.

What in the hell is the Flaming oil vial, and the Gaseous vial for? So far have found no information that clues me in.

MadBull#34
23rd Oct 2003, 19:25
Maybe they are just for using. Hehehe, just drop them and see, what happens.

theBlackman
23rd Oct 2003, 20:56
I don't experiment with the unknown until AFTER I complete a mission. I don't need surprises. LOL When finished, I can pick up a Save and experiment but not while in a mission dealing with unknown goodies.

I have commited suicide too many times in earlier days of play. :D

My mother drowned all her STUPID kids. :)