View Full Version : Load screen freezes

Willard the Fierce Knight
1st Sep 2003, 18:15
I have the original Thief from the platinum collection. It worked okay for a while, but now whenever I hit "load game" (from the main menu) the computer locks up (freezes on the title screen and the keyboard doesn't respond). I have tried reinstalling the game, but it didn't work.
Help is appreciated.
Again, to clarify, I hit load game from the title screen. I can't get into the load game screen.

EDIT: I have Windows 98, a Trident Blade 3D card (8 MB), and 64 MB of RAM. Like I said, it ran great for about a month, then it just started doing this.

1st Sep 2003, 19:01
What is your system: Opsys, Vcard etc.

Start computer. Hit F8 and boot into SAFE MODE. Check the setup in the My Computer Device manager for faults.

Grey Mouser
4th Sep 2003, 23:04
Himm, I think Trident Cyber-Blade is similar to the on-baord Intel 810 video chip, which Thief hates. On-board graphics chips are great for some things and not-so-great for others, 3D games being on of the things they are not-so-great at.

Try running Thief in Software mode to see if it is indeed a video related problem.

In Thief go to Options>Video and select Hardware OFF, then try to start it up.

Willard the Fierce Knight
10th Sep 2003, 13:37
Ok, I tried running it with hardware off, and that didn't work. Haven't checked the My Computer thing yet; will do that today.
Could it be a flaw with the CD? My warranty's still good (I got it on July 4).

10th Sep 2003, 18:48
In a DOS shell (within Win98), run the "mem /c" command. Check how much free memory you have (and see where you are eating up the most).

What version of DirectX is installed? If present, run diagx.exe to find out.

It is possible the saved game is corrupt. Choose a prior save or restart that mission. You can restart the game and use Ctrl-Alt-Shift-End to abort the current mission and move onto the next, and repeat until you get to the start of the mission for which you were trying to load the saved game.

11th Sep 2003, 05:07
Originally posted by Vanguard
What version of DirectX is installed? If present, run diagx.exe to find out. I think that program is "dxdiag.exe".