View Full Version : SE Account and SE Forum Account - what's the difference?

14th Jun 2013, 18:42
where are we able to locate our own square enix id on this site. There is no where specific where i can find it at. its terrible

14th Jun 2013, 23:13
Sorry, total noob to these forums. I'm a bit confused, are there two different accounts that need to be set up for game use here or just the one.

I've been trying to understand the difference between the current account I am logged into now to post here, and the "square enix account" that the email I recieved (apparently from London even though I'm US, but whois says is a legit site of square-enix) is saying I need to set up. Do I need to set up that second account as I'm being told the email is already in use but my password doesn't work. Or do I merely put the game key into the "add games" section here on the profile for this site?

15th Jun 2013, 02:26
It should be a 4 letter, 4 number code that was emailed to you after registering.

The problem is, that even with that code and your password it won't let you log in, It seems the site is locked out.

I've used my email, username, SE ID, and numerious passwords and resets and it still says I'm wrong.

16th Jun 2013, 03:38
Contact [SQUARE ENIX Account Customer Service] support.na.square-enix.com/contacttop.ph... (http://support.na.square-enix.com/contacttop.php?id=496&la=1)

22nd Aug 2013, 15:48
any help with finding me mine square enix id and were can i find it?

22nd Aug 2013, 17:05
Same issue here. so annoying.

22nd Aug 2013, 19:57
i had this exact same problem, however i solved it neither your email address nor you NICKNAME on your account will work. I hope you dont delete your emails, because what i did is searched my entire emails using the search bar and boom i found when i made my account and its in these emails that give you your ID. OH and btw, your nickname is what your name is posting in this forums, ID is totally different and imo its stupid you cannot log in using your email, SPREAD THIS WORD.
Hopefully this helps

23rd Aug 2013, 15:26
Sort of coming off of Lex's round about method. All you need to do in order to find directly is sign into the account management section of the website.


This url will lead you directly to the login page. You can sign in with your email for this particular page. Once you sign in, the first page it shows you will list both your account ID, as well as whether or not the account is registered or not. That account ID will be the ID you need to sign in.

26th Aug 2013, 12:47
OK I don't know my ID. I can't retrieve it because support thinks the email I'm using is not registered on SE. So what gives?

26th Aug 2013, 13:29
Just posting to see what my username is. Sry for Spam...

30th Aug 2013, 17:18
I made this account a long time ago, and usually use my email to log in when necessary. I don't remember the square enix ID, and would rather not have to create a new account. I tried the account management service, I keep getting told that I'm using the wrong password (I'm already logged in everywhere else) I try to reach customer support through chat/phone/email to retrieve the lost ID, but all of those require me to imput my ID. Is creating a new account the only option?

31st Aug 2013, 15:16
Is this the real website of se????

4th Sep 2013, 09:09
i am having the same problem. but when they asked me to put my ID in in the email support i just typed "i dont know" and it let me continue through but still no reply email so i guess they are pretty busy :(

5th Sep 2013, 01:12
How can I get my password for my SquareEnix ID? I just received my ID through email but not my password. It said it didn't put it in the same email for safety but it didn't say it would send it in a separate email either...please help me.

8th Sep 2013, 04:46
whats my S-E ID? FF xiv wont accept my email address and the last time i used this site was back before enix merged and i didnt even know i even had this account. where do i see, find, create my id? my friend said he had to make a new account because he had the same problem..