View Full Version : Unexpected Jumpy Graphic Fix

25th Jul 2003, 04:29
S'up peepz

I posted this under "Save Error" but I finally found out what the problem was. In messing with setting trying to fix the save problem I found an audio setting which fixed my jumpy graphic. The fix I fould is in the lower part of the message under EDIT.
I am also adding my system spects below the EDIT section. I have an older computer so if the fixed worked for me I would think it would also work for those with systems newer than mine.

OK up till now I have been willing to deal with the bugs. The jumpy graphics, the running in circles on stairs, the auto aim sticking and being unable to turn around to move away from a beastie but now I am getting fed up. I am at the Bio Sphere. I finally got to the top of the room where the valves are and hit escape to save my game and the game crashed giving me the following error:

Build Jul 2 2003 17:02:05

The Following Error has occured

Generic Game Error

ASSERTION: 'sgSaving == TRUE' at C:\projects\tomb raider\Game\core\Savegame.c(94)

Now everytime I try to save I get that error. Anyone have any idea what might be causing it?


OK I seem to have found the problem. Because of the jumpy graphic on some levels like The Hall Of Seasons I had been turning off the audio. In other post here I had read that it's the audio that causes the jumpiness in the graphics and when I started turning the audio off it ran really smooth. When I got to the Bio Sphere I found it to be the worse I had encountered so I turned off the audio. After several hours of messing with thing I tried turning the audio back on and found that I was again able to save with no problem but the graphic were intolerable. I began to mess with the audio and found if I used compatibility mode(No hardware acceleration) in the game audio settings that the graphics ran perfectly and I was still able to use the audio. I hope this info might be of some use to others. One thing I would add is that I have an old Rockwell audio/modem card so I’m not sure how much use this will be to those with newer boards.

Operating System Microsoft Windows XP Professional
OS Service Pack Service Pack 1

CPU Type Intel Celeron-A, 533 MHz (8 x 66)
Motherboard Name Asus HAWK
Motherboard Chipset Intel Whitney i810
System Memory 190 MB (SDRAM)
BIOS Type Phoenix (05/08/01)
Communication Port Communications Port (COM1)
Communication Port Communications Port (COM2)
Communication Port Printer Port (LPT1)

Video Adapter NVIDIA GeForce4 MX 440 (64 MB)
3D Accelerator Intel i752
3D Accelerator nVIDIA GeForce4 MX 440
Monitor HP D5259A Pavilion M70 (000001)

Audio Adapter Rockwell Master Riptide Audio Device

Floppy Drive Floppy disk drive
Disk Drive Maxtor 92041U4 (20 GB, 5400 RPM, Ultra-ATA/66)
Disk Drive WDC WD1000BB-00CAA1
Optical Drive HP CD-Writer+ 8000 (4x/2x/24x CD-RW)
Optical Drive MAT****A DVD-ROM SR-8585 (8x/40x DVD-ROM)

C: (NTFS) 95385 MB (31294 MB free)
F: (FAT32) 8988 MB (1566 MB free)
G: (FAT32) 10532 MB (7041 MB free)

Keyboard Easy Internet Keyboard
Mouse Logitech-compatible Mouse PS/2

Network Adapter SMC EZ Card 10/100 (SMC1255TX) (
Modem Generic SoftK56