PDA

View Full Version : Angel of Darkness: Sound problem...



rdoroana
4th Jul 2003, 15:24
It all started with the voices ingame being fast forwarded (much like Mafia did if Hardware Accelaration was on). So being the smart guy I am I went to the DirectX Diagnostic tools and turned it off. So the voices work now but unfortenatly there is an irritating sound in some areas now. The sound is like the game is frozen and there is this repeating "trr" in the back. It is SO irritating. Anyone know how to fix this?
Thanks in advance!

lukep01
4th Jul 2003, 15:28
get a new soundcard mate, i had a problem with Mafia where the sound went crackly, i got an Audigy 2 with EAX and it fixd the problem. Don't know if it will work for AOD though.

rdoroana
4th Jul 2003, 15:40
I can't get a new sound card.
I'm using a laptop. (And don't say laptops suck for games cause this one runs games perfectly and without slowdowns)
Anyway I can tweak the settings so I don't have this problem?

Harley Quinn
4th Jul 2003, 17:53
Lowering the sample rate of your soundcard has been known to cure problems like this ;)

rdoroana
4th Jul 2003, 18:02
Forgive my stupidity but how do you do that?

rdoroana
4th Jul 2003, 18:28
*rdoroana bows before Harley Quinn*
THANK YOU, THANK YOU, THANK YOU! :D

I found out how to do it and it works 100% fine!

Thanks man, you really helped me out! :D

RebeL_fARmeR
4th Jul 2003, 21:15
How do I lower the sample rate of my soundcard? I'm having the same kind of problem and it's driving me squiffy!

SMS (Save My Sanity)

rdoroana
4th Jul 2003, 21:22
1) Calm down. This will probably (I said probably) solve your problem.
2) Go to Start, Control Panel.
3) Go to the sound options and then Audio.
4) Where you select the driver, select the advanced options.
5) Select the second tab and but both sliders all the way down.
6) Play the game and see if it works.

And I'm sorry if you can't find something, my PC is portuguese and I don't know the exact names in english.

RebeL_fARmeR
4th Jul 2003, 22:44
You know what, rdoroana? I came online just now solely to say "thanks a lot" to you! All my sound problems are over, well, there's the odd glitch here and there but overall it's working.

TOP MAN!!! And, of course, all my thanks to Harley Quinn for bringing up the idea in the 1st place.

rdoroana
4th Jul 2003, 22:46
Thanks.
And Harley Quinn is the one who should have a 2 times bigger thanks for his help. :D

RebeL_fARmeR
5th Jul 2003, 20:50
Thanks x2 is Harley's direction!!!

Harley Quinn
10th Jul 2003, 20:37
You post one little detail and you get a thousand thanks:D Thankyou by the way ( and now comes the plug :D ) You will find me in one of 2 places most of the time either the Imesh forum (not just about downloading on p2p) and http://com3.akheva.com/bpeertopeer (http://) If you decide to visit either feel free to mention me in your post and boost my ego even more :D :D
This forum is huge and quite difficult to keep track of but never the less a friendly place.

tomb_raiding
15th Jul 2003, 23:00
Infact u only need to lower the 1st one :)

Ground Zero
17th Jul 2003, 15:12
Thanks a lot rdoroana and Harley Quinn,

I noticed the Trrrr sounds before the hangs of the game and I tried all the other compatibility settings with no effect (P4, R9700pro, winXP and SB Live player 5.1 with Creative CD drivers)
before y tried your solution.

Now, what compatibility settings in TR config panel to be used with?

shicola
17th Jul 2003, 22:57
I adjusted the hardware acceleration to stop the 'chipmunk chatter' (very undignified) but am now getting the Trrrr. so maybe you do have to adjust both on some systems. I will let you know if adjusting both solves my problem.

arth1
20th Jul 2003, 15:01
Originally posted by tomb_raiding
Infact u only need to lower the 1st one :)

Not on my card -- all DirectSound accelleration has to be disabled. This, unfortunately, breaks a lot of other game sounds that sounds fine if you play the game in Alvin Chipmunk (tm) mode.

Out of curiosity, and for the possibility of aiding the developers nailing this bug, I wonder what's common to the sound cards that TRAOD doesn't handle correctly? Mine is a M-Audio Delta Audiophile 2496, which runs natively in 96kHz (the Soundblasters are 48kHz natively -- even the 96kHz cards), but doesn't have playback rate control or pitch control, i.e. it requires that sounds are either in the correct sampling rate to start with, or are fed through the drivers or directsound's sample rate conversion.
The card works with all other applications and games I've ever thrown at it.
Could it be theat TRAOD depends on the hardware rate control feature without checking for it?
Or that it doesn't work correctly with cards that are 96kHz natively?

hda
23rd Jul 2003, 23:14
Originally posted by tomb_raiding
Infact u only need to lower the 1st one
yeah... it worked with me. but i have on-board audio :(

cheers

Acro_d
28th Jul 2003, 21:20
Thanks, this fix has solved a problem on my kids' computer. The opening FMVs (Eidos logo, opening movie etc) were locking up, and even though the game was still playable we had to hit ESC to get past each start screen. Lowering the Audio hardware accelaration tab just one notch has cured this. This is in Win98 on an FIC KA11 MB (via chipset) with onboard sound.

Stuee
23rd Aug 2003, 21:22
Thanks for that tip arth1 .
I've got the same card as you (Audiophile 2496), and while I know it's not a gaming card as such (I bought it to enhance my DAW) it is supposed to support Directsound fully. And considering M-Audio are famous for making great drivers, I place the blame with Core Design.
Also, why didn't they fix this in one of the patches? I've seen quite a few complaints about this (quite simple) flaw.

Anyway, didn't mean to whinge - just wanted to say thanks... IT WORKS! Although it is a royal pain in the arse to have to dxdiag before and after playing TRAOD - as you said, it's the only game or application that has displayed these symptoms.

Lenef
11th Nov 2003, 19:45
Reducing the hardware acceleration is fine for Lara's voice, but create a lot of grumpy sounds, humm, unbearable sounds with the game. So I stopped playing TRAOD. I've paid for it and stop playing because they do not take care of that flaw. So if there's a genius outhere able to fix chimpmunk lara without scrapping the FXsounds, I'll be the happiest man.

Louis

giggs_22
21st Nov 2003, 10:37
I have an AC97 sound card on-board and I had the same problem.
I did what the other said and I got those grumpy sounds too.
I put both sliders (hardware acceleration and sample rate) left.
Try moving only the first.
Put the first to None and the other to Best.
Worked with me!!!

P.S:Thanks guys for the solution

Zeph
26th Nov 2003, 20:21
I have a Sis 7018 and have problem the same. The problem starts when I changed Windows 98SE for Windows XP SP1. With version 49 in cutscenes the sound and music were perfect but with the 52 the music is acute... I tried of all q had mentioned in this topic but it walks functioned...

TheSleeper101
6th Feb 2004, 00:19
Originally posted by Harley Quinn
Lowering the sample rate of your soundcard has been known to cure problems like this ;)
how do you do that?? Wait, is that the same thing as lowering the audio advanced thing to basic or none? because i tried that and it still didn't work! LoL

Pacificator
26th Jan 2005, 01:39
Everything was all right till i reached Sanitarium level. :(
Now when I open the last door I get 'GAME ERROR STRUCTURED EXCEPTION HANDLE' error, tried basic acceleration on sound playback and it didnt work, i tried no acceleration it didnt work either, i went to dxdiag and tried basic acceleration on sound 1, sound 2 and sound 3 it didnt work either.
Can somebody help me Please?.

moonstone123
5th Sep 2005, 03:05
there is a solution to the sound problem u are having. i will state a couple. u could get a new sound card (already said i know) , or u might have a doomaru virus (that can only be fixed by morpheus), or, u might be running out of ram (try putting some files u have (a lot) in folders, and storring them inside folders.) i have that problem when my computer program files (i'm a computer programmer in trainning) get too big.if that doesn't work, take ur computer into a place like compu smart. if all of the above don't work, bear through it man. :D :)

moonstone123

moonstone123
5th Sep 2005, 03:08
there is a solution to the sound problem u are having. i will state a couple. u could get a new sound card (already said i know) , or u might have a doomaru virus (that can only be fixed by morpheus), or, u might be running out of ram (try putting some files u have (a lot) in folders, and storring them inside folders.) i have that problem when my computer program files (i'm a computer programmer in trainning) get too big.if that doesn't work, take ur computer into a place like compu smart. if all of the above don't work, bear through it man. :D :)

moonstone123

i must read the whole thread first!!!!!

duhhhh....
sorry :eek: