View Full Version : Thief II Demo Problem

5th Jun 2003, 16:08
I am having trouble with Thief II..
I just recently found the demo and by the descriptions I can see that this is a wonderful game..
so I downloaded the demo..installed it correctly, put all settings to place and when I had watched the "mission intro" (that's what I think it is) I just got a black screen with a cursor I could move..
I had no picture whatsoever..
when I pressed escape, I went back to Windows..
any suggestions?
my PC specs:
Pentium II 400 MHz
384 MB SDRam
16 MB Ati Rage 128 graphics card

Grey Mouser
5th Jun 2003, 22:28
Hi ziili...

First guess is that you should update your video card driver, but before doing that take a look at your current DirectX info.

Go to Start>Run>type dxdiag>Click OK>Save all Information>Save In>Desktop>Save...exit the tool and find the the file Dxdiag.txt on your desktop and Open it with Notepad...

You can just cut and paste the whole thing into your forum reply if you like, but the pertinent information looks like this, from the system I am typeing at:

System Information
Time of this report: 6/5/2003, 15:21:58
Machine name: SCALPEL
Operating System: Microsoft Windows 2000 Professional (5.0, Build 2195) Service Pack 3
Language: English (Regional Setting: English)
System Manufacturer: Hewlett-Packard
System Model: HP Brio
BIOS: PhoenixBIOS 4.0 Release 6.0
Processor: Intel Celeron, MMX, ~465MHz
Memory: 254MB RAM
Page File: 140MB used, 476MB available
Primary File System: NTFS
DirectX Version: DirectX 8.1 (
DX Setup Parameters: Not found
DxDiag Version: 5.01.2600.0881 32bit Unicode

Display Devices
Card name: 3dfx Interactive, Inc. Voodoo Series Driver
Manufacturer: 3dfx Interactive, Inc.
Chip type: 3dfx Voodoo 3
DAC type: 3dfx Internal DAC
Device ID: Enum\PCI\VEN_121A&DEV_0005&SUBSYS_0036121A&REV_01
Display Memory: 16.0 MB
Current Mode: 1024 x 768 (16 bit) (75Hz)
Monitor: Dell D1025TM
Monitor Max Res: 1600,1200
Driver Name: 3dfxvs.dll
Driver Version: 5.00.2195.0232 (English)
DDI Version: 7
Driver Attributes: Final Retail
Driver Date/Size: 11/2/2000 14:00:02, 545264 bytes
Driver Signed: Yes
WHQL Date Stamp: 6/1/2000
Mini VDD: 3dfxvsm.sys
Mini VDD Date: 11/2/2000 14:00:40, 169840 bytes
Device Identifier: {D7B71CFA-4345-11CF-4271-A528AEC2C835}
Vendor ID: 0x121A
Device ID: 0x0005
SubSys ID: 0x0036121A
Revision ID: 0x0001
Registry: OK
DDraw Status: Enabled
D3D Status: Enabled
AGP Status: Not Available

Sound Devices
Description: Aureal Audio
Device ID:
Manufacturer ID: 1
Product ID: 100
Type: WDM
Driver Name: adm8820.sys
Driver Version: 5.10.1500.0049 (English)
Driver Attributes: Final Retail
Driver Signed: No
Date and Size: 3/14/2000 11:20:52, 735848 bytes
Other Files:
Driver Provider:
HW Accel Level: Full
Registry: OK
Sound Test Result:

Go ahead and post back with your DirectX info and it might point to the problem.

9th Jun 2003, 14:01
System Information
Time of this report: 6/9/2003, 16:51:14
Machine name: TAGATUBA
Operating System: Windows 2000 Professional (5.0, Build 2195) Service Pack 3
Language: English (Regional Setting: Estonian)
System Manufacturer: n/a
System Model: n/a
BIOS: Award Modular BIOS v4.51PG
Processor: Intel Pentium II, MMX, ~400MHz
Memory: 352MB RAM
Page File: 237MB used, 617MB available
Windows Dir: C:\WINNT
DirectX Version: DirectX 9.0 (4.09.0000.0900)
DX Setup Parameters: Not found
DxDiag Version: 5.03.0000.0900 32bit Unicode

DxDiag Notes
DirectX Files Tab: No problems found.
Display Tab 1: No problems found.
Sound Tab 1: No problems found.
Music Tab: No problems found.
Input Tab: No problems found.
Network Tab: No problems found.

DirectX Debug Levels
Direct3D: 0/4 (n/a)
DirectDraw: 0/4 (retail)
DirectInput: 0/5 (n/a)
DirectMusic: 0/5 (n/a)
DirectPlay: 0/9 (retail)
DirectSound: 0/5 (retail)
DirectShow: 0/6 (retail)

Display Devices
Card name: Magnum/Xpert128/X99/Xpert2000
Manufacturer: ATI Technologies Inc.
Chip type: Rage128 GL (AGP)
DAC type: Internal DAC (350Mhz)
Device Key: Enum\PCI\VEN_1002&DEV_5246&SUBSYS_00081002&REV_00
Display Memory: 16.0 MB
Current Mode: 1152 x 864 (32 bit) (85Hz)
Monitor: Default Monitor
Monitor Max Res:
Driver Name: ati2dvaa.dll
Driver Version: 5.13.0001.3217 (English)
DDI Version: 8
Driver Attributes: Final Retail
Driver Date/Size: 5/31/2001 15:50:12, 295167 bytes
WHQL Logo'd: Yes
WHQL Date Stamp: 6/1/2000
VDD: n/a
Mini VDD: ati2mtaa.sys
Mini VDD Date: 5/31/2001 15:49:46, 310913 bytes
Device Identifier: {D7B71EE2-1106-11CF-237F-0920A2C2C835}
Vendor ID: 0x1002
Device ID: 0x5246
SubSys ID: 0x00081002
Revision ID: 0x0000
Revision ID: 0x0000
Video Accel: ModeMPEG2_C ModeMPEG2_D
Deinterlace Caps: n/a
Registry: OK
DDraw Status: Enabled
D3D Status: Enabled
AGP Status: Enabled
DDraw Test Result: Not run
D3D7 Test Result: Not run
D3D8 Test Result: Not run
D3D9 Test Result: Not run

Sound Devices
Description: ESS AudioDrive
Default Sound Playback: Yes
Default Voice Playback: Yes
Hardware ID: PCI\VEN_125D&DEV_1969&SUBSYS_8888125D&REV_01
Manufacturer ID: 1
Product ID: 100
Type: WDM
Driver Name: solo.sys
Driver Version: 5.12.0001.3047 (English)
Driver Attributes: Final Retail
WHQL Logo'd: Yes
Date and Size: 7/31/2000 13:41:34, 73281 bytes
Other Files:
Driver Provider: ESS Technology, Inc.
HW Accel Level: Full
Cap Flags: 0xF5F
Min/Max Sample Rate: 5000, 48000
Static/Strm HW Mix Bufs: 1, 0
Static/Strm HW 3D Bufs: 0, 0
HW Memory: 0
Voice Management: No
EAX(tm) 2.0 Listen/Src: No, No
I3DL2(tm) Listen/Src: No, No
Sensaura(tm) ZoomFX(tm): No
Registry: OK
Sound Test Result: Not run

9th Jun 2003, 14:47
Go to www.ati.com and check that you have the latest released version of the driver for your video card (not a beta version). I am assuming that you have a video card and not an ATI video chipset on the motherboard. However, because of your system specs, I also suspect that you have a PCI video card instead of an AGP video card. If it is an AGP video card, check your BIOS settings that the AGP aperture is 32 or 64 MB.

Are you playing the game [demo] at a different resolution than you have for the Windows desktop? If so, have you actually checked that your monitor is setup to display correctly at the game's resolution. For example, maybe you have the Windows desktop at 800x600x256 for video resolution but you are trying to play the game at 1024x786 or higher resolution but you have never bothered to actually set your monitor at that higher resolution to ensure positioning and sync are correct to display the desktop. Right-click on the desktop and select Properties, click Settings, and set the Windows desktop to the same resolution that you have the game configured. Then try running the game. I believe the menus always display at a low resolution, probably 640x480x256, while the game can be at that or a higher resolution. Also, I believe, Thief requires 256-color depth, so your video card has to support that color depth at the resolution you select.

Check if the game is configured for hardware acceleration for its video setting.

Looks like you have the latest DirectX version. But did you install the Indeo video codecs? The install for it is on the Thief CD but demo might not come with them. www.ligos.com used to provide them for a free download but charge for the Windows XP version (which they developed after buying the codecs from Intel). However, they have now bundled the Windows XP codecs in with all the others and want to charge something like $20 USD for the bundled download. I have the install package for the Indeo codecs which I can e-mail to you; it is 1.97MB big so your mailbox has to accept something that big.

It is also possible that you need to update your audio drivers. Although the problem exhibited is with video, audio drivers can affect video behavior. Don't know what you have for a sound card; I don't remember who was ESS Tech. but I have seen it before.

10th Jun 2003, 08:24
My windows desktop resolution is 1152x864..
and I think I tried to play the demo with 800x600 or sth..
it definetely was NOT higher than my Windows resolution
and now I can't even try it because I deleted the demo and now I'm playing Thief I ;)
when I complete it, I will try to mess with the THief II demo again :)
thank you guys for your help :)

11th Jul 2003, 00:32
Hey, just saw your post. A friend (at college) and I had the same ATI Rage 128 Pro card and System Shock II (DromEd v2.3, after Thief Gold's v1.37 and before Thief II's v1.18) ran on mine but not on his. So I installed DirectX v8.1 and that didn't do anything (his system's drivers were sorely out of date so I was hoping, anyway...), but I went to ATI and got the newest drivers for the card and that fixed it. Since Thief II is an indirect progression from the System Shock II version of DromEd, it may well fix your problem. Good luck!

[edit: if you have old drivers (say, the ones that Dell kindly gave me :mad:), your card won't be able to display above 1152x864. With the updated drivers, I'm getting 1280x1024 when I couldn't before (so did my friend after I updated his drivers).]