View Full Version : wierd lighting prob + objective woes

1st Jun 2003, 21:35
ok let me begin by saying i searched for an answer and it seems no one has had this problem. hmm... ok i am running windows xp amd athlon 2000 256mb ram 60 gig harddrive. the video card is intergrated(ill be getting a new video card for it sometime in the future) sound card works, at the start it sounded funny but i fixed that. anyway i installed t2, then patched it. i didnt install dromed or patch it. i proceeded to play calendras legacy. first problem- the weird lighting. all doors/windows have a problem. when i look at them or the wall they are in the lighting goes from normal to light bright(like in dromed) but only for that wall. i went ahead and played up to a winters eve.

second problem, the loot objective is screwed up. i finally had to quit the mission. checked the stats screen, it said there was only 5300 or so loot available, when the required was 5500. i knew there was a problem then. i thought it was just calendras legacy, but its not. i played melians method. same thing. played original missions, same thing. no loot objective works for any mission. and the awful lighting problem persists. has anyone had this problem(these two problems seem to be related, i thought maybe i was missing something like convict.osm or gen but they are all intact). the game runs fine and smooth no problems what so ever except for that wierd lighting screw up and the loot objective is screwed. anyone ever had this problem? anyone have an idea what could be wrong. didnt recieve any errors during patching t2. i today installed dromed and patched it too, thinking that would help to no avail.

to give an idea what the lighting looks like, most dromeders will know how quick lighting looks....it is almost as if in game mode quicklighting and raycast/objcast are having issues with each other around the doors/windows. its driving me up the wall:(

edit: i uninstalled thief, and reinstalled. version 1.07 has the same problem. tried running it under differnent compatibility modes and the ones that worked all had the same problem. it must be either my video or sound cards........?

3rd Jun 2003, 15:16
still no fix. it seems to have something to do with the door and window openings, the game/levels run fine its just that i get a weird bug with the lighting around doors and windows(doorways with objects connecting them) and of course the loot screwup. could my convict.osm be screwed up?

4th Jun 2003, 00:00
I believe that the lighting problem has to do with your graphics settings and not within Thief as I've had the problem several times in the past.

Go to Control Panel > Display Settings and change a couple of settings (mipmaps, textures, anisotropy, etc) and run Thief. If it doesn't fix it, reset to the original settings, change a couple more, and try Thief again. Repeat until the problem is fixed.

4th Jun 2003, 15:07
You also might want to PM Hit Deity over on TTLG (he's probably on here too). He seems to know alot about video card issues.

4th Jun 2003, 21:43
i hope that fixes the jerky lighting around doors. but what about the loot objective? it seems odd that the objective would be screwed up in the original missions.

i hope to get this fixed. i will try what leatherman has suggested with tinkering with the display, and if i cant get it i will ask hit deity per you suggestions! thanks for helping, i want to continue work on my fms. i wanted at first to build on the new computer, but it might also be a wise thing to build on the old slow one to keep me honest on the polys, and thus making sure everyone could run the levels. this video glitch is really annoying though, i mean the levels are running superb to the old computer, its just that jerky lighting that happens around doors/windows and the objectives not ticking off for loot. the loot one has me puzzled, i may have to ask on the editors guild and see if anyone can come up with a possiblitly for that one.

8th Jun 2003, 15:23
update: the loot objective seems to be working now. still have the display problem. ive tried just about every option i can find and its all the same.....:confused: i havent updated any video drivers i went to the s3 graphics website and i cant figure out what i need to d/l ugh