View Full Version : Thief2 Game Freeze

22nd May 2003, 00:21
I just bought the Thief series Platinum pack, and have been unable to run either TDP or T2. The games install fine, videos play just fine, but when I try to play, I get anywhere from 5 seconds to a minute into the game and then it just freezes. A manual restart is required (reset button).

Below are my system specs:

Windows XP Home SP-1
80 GB WD Hard Drive
NVidia GeForce2 GTS 64 MB AGP Video Card
Intel P4 3.06 Gig CPU
Asus MB
Soundblaster Live! Platinum

Latest drivers for all devices, DirectX 9 installed

Installation on both products was "Full". Hardware Sound Acceleration changes had no effect. Display/Resolution changes had no effect.

I first installed normally, then uninstalled and reinstalled using the "d:\setup.exe -lgntforce" command. Results were exactly the same.

Am I just going to have to give up on playing these great legacy games????

Thanks for any help!


22nd May 2003, 00:47
Many have had success with the CONFIGURATION menu in XP. Select the EXE file and then PROPERTIES. On the menu that comes up select the Configuration page and scroll the bar to W98 and set it up there.

Good luck.

I am running all three TDP-GOLD-TMA on XP with no problems at all. However, I had them already installed (FULL) on W98SE and "upgraded" to XP Serv. pack-1.

No problems at all.

22nd May 2003, 01:58
Hope that works for you, Degasai - let us know if it doesn't, 'cos I seem to recall someone else with a similar problem who found a solution.

Just wanted to point out though: this is how a help request *should* be done, folks! All the system specs and loads of info about the problem and the install. Nice work, Degasai!


22nd May 2003, 13:46
I tried that, and as a result, couldn't enter the missions. AVI's play fine, I get the start-up screens (where you choose to start a new game, load a game, or go into options), but when I choose "Continue" from the objectives screen, I get a black monitor and the game freezes.

I'm going to play around with my GeForce settings to see if I can help the problem. Any other ideas?

Thanks for the replies:)

Progress report:

No changes in Geforce settings had any effect. Turning off AA, fog table, etc. did nothing to solve the problem. I next went into dxdiag and tried disabling AGP acceleration, Direct 3D and DirectDraw. All this did was irretrievably corrupt the display in the actual missions to some horrible 256 color thing. Turning all the acceleration back on and uninstalling/reinstalling the program fixed this. However, the game still freezes.

I've tried all of the compatibility modes. Trying to run in Win95 or 98 merely gets me a black screen when trying to load saves or enter missions. Running in XP or NT 4.0 mode lets me into the game with good graphics, but the game then freezes after 5 seconds to 5 minutes of play, making a hard reset of my system necessary.

A couple of items I may have left out: my T2 version is 1.18. My Nvidia driver version is My SB Live driver version is 5.1.2603.0

Man, I just can't think of anything else to do here :confused:

22nd May 2003, 17:39
Originally posted by Degasai
My Nvidia driver version is Can you play any other games without crashes?

At any rate, try the latest official drivers: Detonator 44.03 (http://www.nvidia.com/view.asp?IO=winxp-2k_44.03).

Those 40.72 drivers were Beta drivers.

22nd May 2003, 18:05
I'll give those a try. I'm starting to suspect it's a video issue. I uninstalled T2 and reinstalled TDP. I could get the program to run, but only by running in SW video mode. And even then, some of the ambient sounds were missing.

If the new Det's don't work, I'm afraid I'm going to have to return this Platinum release, dangit. I suppose I should build a legacy system to play some of these great old games. I've still got both Win 95 and Win 98 around here somewhere.

I don't even know if it's possible for the developers/publishers to patch the games to work with XP. If it is, I hope they do so!

Thanks again...


22nd May 2003, 21:50
The 44.03 Detonator drivers made no difference. Problem remains the same. Thanks for the tip on the new drivers, tho :) Oh, and just so you know: the 40.72 drivers are WHQL certified, the 44.03's are not.

theBlackman: you said you have the games running OK on your XP box. One question: which version of DirectX are you running?

I'm grasping at straws here:p I wonder if the Eidos phone help in the readme is still active? Maybe they have some ideas...

22nd May 2003, 21:59
Originally posted by Degasai
The 44.03 Detonator drivers made no difference. Problem remains the same. Thanks for the tip on the new drivers, tho :) Oh, and just so you know: the 40.72 drivers are WHQL certified, the 44.03's are not.

theBlackman: you said you have the games running OK on your XP box. One question: which version of DirectX are you running?

I'm grasping at straws here:p I wonder if the Eidos phone help in the readme is still active? Maybe they have some ideas...

9X Although they ran with 8.1, both in Win98SE and XP. Question? Do you have the games fully installed, and is the problem just that they don't run?

I'm just double checking to make certain I understand what you are saying.

Also RUN DXDIAG and see what turns up there. It has been said that they will run in 2000 configuration.

Also turn off anti-aliasing, and use "Application controlled" in your card setup.
May 22, 2003 01:55 PM TTLG Forums

The Mike
New Member

Registered: May 2003
Thx alot for your help. Turned out the problem was with the newest drivers I installed for my Geforce card (coincidentally, I installed them at the same time I installed DirectX 9.0). Well, if anyone else is having this problem, the solution is to turn off "enable texture sharpening" and set antialiasing to "application controlled". To be honest I'm not sure which one was causing the problem (possibly both) but with the newest drivers their both easy to turn on and off. Thx alot for your help, DXDIAG is a cool program I didn't even know existed . Huh, you learn something new every day.

23rd May 2003, 03:01
Yeah, I've tried every combo of AA setting. Right now it's set at Application Controlled. Still no luck. dxdiag reports all is just peachy. I've tried setting sound acceleration at all points, including disabled. I've tried disabling different aspects of Direct3d. I've tried every setting under every category in Display/Geforce properties, including Image Quality Levels and Mipmap Levels.

I've tried ALL the compatibility settings. Win 95 and 98 just Black-Screen me, and NT/XP lock up during gameplay.

I just reinstalled the latest (May 2003) Creative SB Live drivers. Didn't make any difference.

It's puzzling, inasmuch as I can run all kinds of other legacy games on this system (Deus Ex, Elite Force, Hitman, Alice, TLJ, Warcraft II, Starcraft, Diablo, etc.) with little or no tweaking. The only difference is, those games have all been supported with patches in the last year. Thief series has not. Last patch was almost 3 years ago.

The only way I can see to get this game running on my system is to format and install Win 98, and try to find DirectX 7 somewhere, as well as some 3 year old drivers for my video and sound cards.

Well, I guess you can't expect a company to support a game forever. My only question is: if they are not supporting it, why would they continue to release "Gold" and "Platinum" versions to a public that has been bent over and forced to run XP?

Never mind...dumb question. My tolerance level has been exceeded. The store gets this "Platinum" version back.

For those who are having problems: They really mean it when they say on the box "WinXP not supported". You might get lucky like some of the people who have posted. On the other hand, you might be spending 20 bucks for coasters.

A final thanks to those who have tried to help me.

23rd May 2003, 04:30
At one time, a long time ago, if I moved my mouse during the movies then the movie aborted (and I think the mission didn't play). So I had to leave my mouse untouched and let the movie play through so the mission would start. Although I updated my mouse drivers (and also tried using the Windows supplied "Std PS/2" mouse driver), it turned out to be an audio driver problem.

I have the Soundblaster Live (but before they added the 5.1 digital dolby support). Mine is 3 years old and before they bundled it in different packages with postfix names like Gamer. There were drivers at times that Creative provided that really screwed up when playing Thief. At one time, they had their Live!Wire drivers, then they discontinued providing them online for download and you could only get them via ordering a CD, and now they have the drivers online again but the Live!Wire driver family is defunct.

Be careful about Creative's SB Live drivers. There used to be a set of SB Live non-5.1 digital dobly drivers and a different set for SB Live 5.1 digital dolby support. I actually bounced between these sets to find which one worked; at some versions, the 5.1 drivers worked, then they didn't work for the next version so I had to stick with the prior version, then the non-5.1 drivers got updated and they worked better. So for awhile, you had to try different versions of their non-5.1 and 5.1 drivers to see which worked. I think now Creative distributes a package or suite of drivers with both non-5.1 and 5.1 drivers, and the install program detects the card to determine which to install.

Although the defect was exhibited as a video problem, for me, it was because of audio drivers.

23rd May 2003, 14:03
Creative has always been a pet peeve of mine. As a die-hard gamer, and an engineer, I have always believed that simple solutions work best (the KISS principle). Starting about 3 years ago, Creative began packaging all kinds of non-essential junk with their basic Windows drivers. Things like Keytar, etc.

The problem with this is that you can't just go to Creative's site and download the Windows drivers. You have to download and install the entire package.

They've gotten just a bit better now, as you can choose whether to download some of the components. However, the minimum download remains at 24 MB and still installs: Device Controls, EAX Control Panel, Keyboard, SoundFont, Speaker set-up, Mixer, Diagnostics, Restore Utility, Surround Mixer, and User's Guide.

When I first started gaming, all you had to do was go out and get a small driver file. The actual driver code required to get SB cards working properly with games is still very small, and yet we are forced to deal with all this unecessary junk.

When I built this system, I went out looking for a good, high-quality non-Creative sound card. Turtle Beach used to make an excellent card. Unfortunately, the competition has either gone out of business, been bought by Creative, or is trying to compete with them by bundling their drivers with an equal amount of unneeded crap.

In much the same way, Windows has become anything but gamer-friendly. The move to DirectX, and then into XP, IMHO, have been the biggest disasters ever to hit the gaming community. In the end, it has been, and will will continue to be, the biggest contributor to the eventual move away from the PC by game developers. There have been much better options made available (Linux, OpenGL, etc.), but the MS corporate machine has buried them.

Any time you design a system (whether it's a Sound Card or an OS) that tries to be all things to all people, you are going to wind up with something that does many things poorly, rather than one thing well. It's a prime example of the definition of "compromise": a solution that angers everyone equally.

Game Developers have shown remarkable adaptability in designing engines and code that work within Mr. Gates' monstrosities, and they are to be commended for their efforts. As long as they continue to make those efforts, I will do my best to support them. PC games, when they work properly, are still head and shoulders above even the best of the console systems.

/rant off


23rd May 2003, 14:17
Thanks for the reply.

Yes, I did the full install with both games. I'll detail what is happening:

The install works fine. The intro movies in both titles play normally. I can bring up the "New Game/Load Game/Options..." screens just fine. However, when I choose to load a game or start a game, and enter the game itself, that's when the problems start.

As I said, running in 98/95 compatibility modes, going into the game world just immediately takes me into a black screen (with sound). Task Manager shows the program as "Not Responding".

In XP/NT mode, I can enter the game world and things look and work fine for a bit. Then it just locks up (with sound). I'm still looking at the game world, but can't move or interact with it. Frozen, IOW. Once again, taskman reports "Not Responding".

Sound SW mode does nothing to cure this problem. T2 doesn't allow you to turn off video HW acceleration, but Thief does. When I do this, I can stay in the game, but the game world itself looks horrible (like 16 color DOS or some such).

So, it seems to me that this is a Video/Display problem. I've made all the changes that can be made in all combinations possible and still can't get these programs to work correctly.

It's possible that a new video card might do the trick, but I'm still waiting for a clear winner to emerge between the GeForce FX and the ATI 9800 before I lay out 400 bucks ;)

As I said above, I'm giving up. I'll just wait and buy Thief 3 (once they come out with the inevitable patch, LOL).

23rd May 2003, 18:43
Presumably when you said that this is an AGP video card that it really is a daughtercard in an AGP slot and not an onboard video chipset which steals its memory from slower system RAM and you have to configure how much it steals in BIOS.

Have you checked your BIOS for its video settings?

<u>AGP aperture</u>
Should be 64MB to 256MB, especially since you have 3GB of RAM. Don't set it below 64MB. From what little I've read, and unless the application is specifically coded to make use of a larger memory frame, increasing the aperture over 64 MB usually doesn't help much if at all. On Windows 9x, increasing the AGP aperture can actually cause problems (http://support.microsoft.com/default.aspx?scid=kb;[LN];253912) when you have a lot of system RAM.

<u>Video BIOS shadowing</u>
"Copies video BIOS into [system] RAM" (which runs faster than reading from ROM). Toggle it to see if it helps. Some video cards don't like to have their BIOS remapped.

<u>Video BIOS Cacheable</u>
"Lets you cache video RAM C000" (this is the default address for video card BIOS). This is ROM memory at this address which is slower than RAM; i.e., there is no physical RAM memory at this address, and this address reads from the slower ROM on the video card. <i>I can't figure out what is the difference between this setting and shadowing. Both seem to reflect the same feature, yet my BIOS has both settings and my default settings are video BIOS shadowing sneabled and video BIOS cacheable disabled. Go figure.</i> The BIOS is copied somewhere into RAM and addresses at C000-CFFF are mapped to the addresses in RAM where the BIOS got copied.

<u>Video RAM Cacheable</u>
Maps the video card's memory pages at A000 and B000 into system RAM, but nowadays video memory is much faster than system RAM, so enabling this would probably slow you down.

There are also overclocking settings in some BIOS'es, like AGP driving value (for GeForce2 cards, I believe the recommended hex value is EA, or 234, which is probably the default). AGP fast write probably only works for 4X cards. See http://hardwarehell.com/articles/videobios.htm for some info on various video settings.

27th May 2003, 21:00
Actually, since I already have a copy of Win98SE, I'm thinking of partitioning my 80 gig HD and installing it on the second partition.

I have to do some research on it, tho, since I've never worked with either NT or XP before on partitioning and such.

Once I have 98 installed, I should be able to go back and run these legacy games without going through all this headache.


20th Jan 2004, 03:54
I seem to be having the same problem with my Theif 2, however I am sometimes able to alt tab around enough to see that an error message occurs that says something to the effect of "your video card does not support texturing". I have Directx9 installed, running a GeForceFX 5900 ultra, and all my other games work fine.

Latest drivers for everything, everything is patched up. I am also running winxp, I have tried running in the different compatibility modes, and tried the install switch.

I think it's just a matter of having to run DirectX 7 perhaps? Anyone else have any ideas on this?

20th Jan 2004, 15:47
Originally posted by Liquidz2k
Latest drivers for everything, everything is patched up.
That's your problem. The 53.03 drivers introduced this error. You can try removing the ; in front of safe_texture_manager in one of the cfg files(can't remember which), this won't work for Thief 1/G. You could also go back a version or two for your Geforce 5900 and the problem should be fixed.

22nd Jan 2004, 04:59
I already tried that, it had no effect the game still crashes after a couple seconds.

13th Jun 2004, 16:56
I'm having the same problem as Degasai has. The game loads and after 10 - 30 seconds freezes. I need to restart. All other games I have work fine.
My videocard is Sapphire 9800 Pro with latest drivers.