View Full Version : Thief I and II on XP: videos issue + v1.33 for II

19th May 2003, 16:05
Had this been mentioned in the past, excuse me, I am totally new to the forum.

I had the following issue with Thief I and II when I installed them on my new pc (a AMD Athlon 2000+, 256 MB RAM, 80GB HD, Nvidia geforce 4 MX 440 and XP professional-service pack 1).

After installing it everything was alright. I started the intro of both games to check whether they were functioning (they were), played a bit (they were ok), and in general had no problem whatsoever.

I continued installing programmes and games on my disc. Next time I tried to play either Thief I or II, none of the videos were showing. The game went straight to the main menu screen, and when opting for a mission, the game goes straight to the gaming part of it without showing its video. The gaming part performs ok and there are no problems on it whatsoever. The videos can be viewed from XP by any relevant programme like media player or quick time.

The thing is, it is very annoying exiting the game after finishing a mission just to find out what the next one is about, entering the game again and so on and so forth.

I changed the games' configuration in order for XP to see them as either Win 95 or 98 and there was no result. I even uninstalled and reinstalled both games, but still there was no result. The games refuse to show any of its videos-introductions.

Any ideas about how to proceed? Probably somehing was tampered with when I installed other games-programmes, but I have no clue what and why it lead to _that_ result.

Thanks in advance for all suggestions,


PS. As a side note, when I installed version 1.33 of TII, it concluded by saying that the game did not install itself properly since a file from the original version was missing. It obvisouly did not play at all. However, when I reverted to the previous version, the game played 'normally' (with the video issue mentioned earlier). I already checked and my version was the one possible to upgrade (1.08 or 1.07, don't remember at the moment), so I don't know where that came from. Again, all help appreciated.

19th May 2003, 17:15
G'day Antonius

The solution to the video problem is to re-install the Indeo video codecs. They should be on the CD of the game, and hopefully someone will drop by who knows the actual filename! There are lots of installers for other software that break these, for some reason, but the reinstall fixes the problem and is pretty simple.

The update/patch problem is trickier. Did you have these games before, or are they from the newly released pack? It could be that if it's a newer version it's either already patched or incompatible with that particular patch... Not sure about this one, but the other thing you could try, I guess, is doing a 'Full' install of the game, rather than the default one (if you have the HDD space, it's worth it for the speed, and necessary if you plan to play Fan Missions later).

Hope this is helpful, and all the best with it,


19th May 2003, 17:41
Good evening Bravus, and thank you for your answer.

Being a totally casual gamer without particular computer knowledge, I admit I have no idea what the Indeo viedo codecs are and how I can install them. Although I browsed through the cd contents I could not locate anything with that name or a similar description. By your description I presume though that they are not game-only files, since I already unistalled and reinstalled the games themselves and unfortunately I saw no improvement.

The versions of the games I have are the 'sold out software' editions. Thief I has the 'sov.2.2' indication and Thief II the 'sov2.4' indication, without me being able to tell what exactly this indication means. Will try the full install though and see what happens, you might be right with your estimation.

If anybody knows precisely what Bravus referred to when talking about the Indeo video codecs, please help!

Again, Bravus, thank you very much for your help!


19th May 2003, 17:52
Hi again Antonius

OK, I did a bit more digging: the filename for the codecs (codecs are 'compression/decompression' software, um, thingies, that allow the compressed video to run) is 'iv5play.exe' and it's on one of the Thief 2 CDs. It's also downloadable from here:


if you can't find it on the CD.

Let us know how the full install then patch works out, but I suspect those versions might not be compatible with the patch. It really doesn't make a huge difference in Thief 2 if I recall correctly.

See ya,


19th May 2003, 18:12
I notice you are from Belgium. If you use the UK PREMIERE edition, then you need a special patch:
I have patched Thief 2 from version 1.07 to version 1.18. Now, whenever I try to run Thief 2, I get a "Cannot find CD-Rom" error message, even if the CD is in the drive! What can I do?
This is a known problem with some versions of Thief 2 (namely the UK Premier Collection version). The copy protection on the CD was changed and is faulty, so Thief 2 will no longer work when patched. To fix this, you have to remove the copy protection.

Download this patch T2PremierPatch107-118.exe instead, it's a different version of the patch (larger than the normal patch file) which solves the fault copyprotection problem, as provided by Sold Out, the distributors of the Thief 2 version with the patch problem. Try http://www.thief-thecircle.com or here: www.keepofmetalandgold.com for this patch.

Then apply this "FIX" and see what that does.

Technical Questions

How do I install Thief on Windows 2000 or Windows XP?

Go to Start, then Run, then type d:\setup.exe -lgntforce, where d:\ is your CDrom/DVDrom drive. (note: That's -lgntforce, with a lowercase "L"... easily confused with an uppercase "i" depending on fonts... If you're unsure, copy and paste it from this window.)
This problem arises because Win2K and WinXP are based on the NT kernel, which had DirectX support which was flaky at best. Thief needs DirectX to run, so, when the installer sees the NT kernel, it assumes that the game isn't going to be able to run and quits the installation. The -lgntforce switch tells the installer to ignore the NT kernel and install anyway.

My ingame movies (briefings and cutscenes) aren't playing anymore, how do I fix it?

You have to reinstall the indeo video codecs. You will find them on Thief: TDP's disc, and on disc 1 of Thief Gold. If you have Thief 2, you can find them on CD2 (the file is iv5play.exe); or you can download them from here (link will open in a new window).
This problem often arises because of conflicts with some other programs such as Realplayer or Windows Media Player, the video codecs become corrupted and no longer work.
There is an incompatibility between the Indeo codecs and Windows XP. If you wish to view the ingame movies and have Windows XP you must install the codecs every time you play Thief.

Scrooge's Permanent Movie Fix

1) Locate (use "Search") the file named "regsvr32.exe". It is located in the Windows SYSTEM directory (if w95x/ME) or SYSTEM32 (if 2K/XP), copy it in your thief installation.

2) Create a "text document" named "RegIndeo.bat" and copy/paste the following text:

"regsvr32.exe /s LGVID.AX" (without quotes)

3) Save it (The file extension must be .bat)

Simply double-click on the file when your movies don't play.

Note: due to the "registration" process, it is not needed to repeat the operation in all your installed Thief/Gold/II, simply use one of them. The "registration" process will fix the problems in all installed Thief games present.

I've re-installed the codecs, but the first cutscene still freezes at a certain point and only the sound continues.

This is a reported bug in some European versions of Thief 2. There's a fan-made patch available at the Circle,
download it here and follow the instructions in the Read Me file. That should sort things out.

How do I repair a broken Thief installation?

Browse the Thief CD and doubleclick directly on the setup.exe file.
Broken installation typically happens when the setup program crashes halfway, or when there was an attempt to uninstall the game by deleting the Thief folder manually. In both cases, some registry keys were left behind, so the interface (the one that pops up automatically when you insert the CD) will assume the game is installed and will not let you install it again. Running the setup program directly bypasses the interface and lets you install.

Thief is saying it cannot play, because I do not have enough space, even if I have a lot of free disk space: how do I fix this?

Add another 40MB or so of data to your harddisk, it will solve the problem.

This problem happens because of the way Thief checks for free disk space. Since the part that does the checking is left over from when the drive size limit was 2GB, it only sees the first 2GB with any free space on it; when this problem happens, the 2GB it sees has less than 35MB on it. Adding data to the harddisk will get around this.

Here is a link to a http://www.cottet.org/forum/ French Thief site.

19th May 2003, 20:09
Hello and thanks for the asnwers again.

I defragged my HD just to clean an already messy disc up..
Reinstalled Thief I-> was working fully.
Installed patch 1.33
Tried to run Thief I v1.33-> no videos.
Installed codecs as suggested-> was working (in addition, I tried exiting and reentering the game many times in order to see if I need to install the codecs each time I exit it, and the answer is thankfully negative, the game runs smoothly).

Haven't tried with TII yet, but will try it immediately.

Blackman, your comment about a different edition is right on the spot. I bought my copy of both games during a sale in London, therefore it probably is the UK Premier Collection version. Will immediately try the patches you suggested.

As soon as I check the results of installing TII, I will post again (so that others that encounter the same problem might solve it easily).

Thank you both Bravus and Blackman,


19th May 2003, 20:28
Installed Thief II and is working. No problem whatsoever.

Haven't patched yet, I was trying to determine which version I finally have but neither the read me file nor the manual in pdf gave any hint on it apart from the notice v2.4 I already mentioned.

Maybe I will not upgrade Thief II after all, although I do not know whether the improvements introduced by the patch are absolutely necessary.

Again, thanks a lot for your help because I was getting a bit annoyed since many of my games face problems in an XP environment. At least ThiefI and II are now functional!

Off to the Commandos forum to ask a technical question on C1!

Take care,