View Full Version : T2 - Disk space error

13th May 2003, 17:12
I am NOT a happy camper today. I ran into the well-known, but never personally encountered " You don't have enough disk space to run T2" error.

I read the "fix" listed at the TTLG Gen. forum, which was to add some MORE stuff to your HD to fix it, so I did, and it ran, until I rebooted it. Then I got the same error again!

So, I installed a card game and it ran okay for the rest of the day. Today, when I tried to play it, I got the same error again.

I know it's nothing to do with the actual disk space available, because we have a big drive with lots of space on it. I can't keep adding things everyday just to play Thief, though. I'm running out of stuff to add in. Is there another way to deal with this error? I'm in the middle of a T2 betatest and it's causing me serious problems, so any help would be very much appreciated!

14th May 2003, 02:09
maybe you could try just making a bla blah text file then deleting it and doing it like that or whatever you added just delete then add the same thing over, instead of using up all your space. i really dont know how to fix something like that. it seems more like some sort of phsyical memory error instead of hard drive space. have you freed up your system resources...you probably have but just a suggestion in case you havent...

14th May 2003, 02:18
Hi Nightwalker

The problem is with having a drive over 2 GB in size. The best solution is to create a partition on your hard drive smaller than that, and install Thief 2 in there, and you should have no further problems. So you would divide your large hard drive into, say C: at 38 GB and D: at 1.8 GB or whatever, and install Thief 2 in D:

Do you have software like Partition Magic to do that without data loss? Otherwise making a new partition without losing data is a pretty difficult proposition, although it's possible.

Apart from that, I can't think of a permanent solution... But I hope this is helpful. It might even be worth your while to pick up a partitioning program just for this reason.

See ya,


14th May 2003, 03:08
Thanks, bravus. Unfortunately I don't have a program like that. If the problem continues, maybe I'll have to buy one. I'm curious though, why it didn't happen with Win98? We had it on a 30GB drive and I never ran into that problem. Is this something that only occurs with XP?

14th May 2003, 03:33
I am running TMA on a large HDD with no problem. Look at your PM and try what you find.

It is easy to do, and easy to un-do if it does not correct the problem.

14th May 2003, 04:01
Heh, are you gonna share with us all, theBlackman, or is it (a) illegal, (b) immoral or (c) fattening? ;)

I'm not sure why it happens sometimes and not others, Nightwalker. I had it happen under Win98 on an 8 GB drive, after working fine for ages before. I think it's something about a particular degree of fullness. A good defrag might do something as well, or tBM might have you covered.


14th May 2003, 05:06
She and you I presume already have it (TMA) installed. Your soon to appear PM will tell you how to avoid the problem, and give you an added bonus. :D

14th May 2003, 12:47
The drive is all neat and tidy, so defragging won't help, I'm afraid. I'll try what Dusty suggested if the problem crops up again and see if it fixes it. Thanks, guys. :)