View Full Version : Hmm, I may have posted this before but I cannot find it...

30th Apr 2003, 08:08
Okay, here's the problem:

I've gotten my whole solid world built. I am now airbrushing rooms. I am still roombrushing rooms as I go along.

1. Every element of the outside world is airbrushed - some of the brushes are generic and huge right now because my world is far from finished.

2. I have three of five buildings carved out on the inside with a few windows, and they are all completely roombrushed.

3. Ever since I built the solid world that exists above my sewers, I have been having Pathfinding problems. The sewer by itself Pathfinds perfectly, but above it will not. Now when I Pathfind, it says "calculating cells," and nothing ever happens. It used to crash after 10-15 minutes, but it doesn't crash anymore.

4. I've portalized, optimized, built room database, fix_rooms, run bsp_optimize, and walked around ingame with no problem. (those are not in order)

5. Just recently, when I go ingame - any view after about 40 feet is clipped and pink.

6. There are no areabrushes right now.

Last but not least, I tried to Pathfind more than half an hour ago - and it never went past "calculating cells" for that whole time. Can anyone help me? Sorry so long-winded, but I wanted to answer the most common questions first. Thanks :)

30th Apr 2003, 17:00
Sounds like you've got a problem area, so you'll either have to try and identify it or do the area brush filter trick: Area brush around where you want ai to be able to go, optimise, pathfind, then re-optimise the entire mission (ie. with no area brush selection 'on'). It's a pain and slows down building cause you have to optimise twice every time you want to do pathfinding..
It really depends on how far into your mission you are, if you're near the end you can do that trick but otherwise i'd try and identify the problem area and simplify it.
Pathfinding won't ever complete if it doesn't get past 'calculating cells'..(its not like objcast lighting where it is still happily calculating away even though it appears to be dead.)

I think i remember Belboz once wrote about sewer entrances, something about the way he'd done them was causing pathfinding to crash, but i can't remember the details or which thread it was.

Try searching ttlg editors guild (current and archive) for pathfinding problems..

30th Apr 2003, 18:55
3) Are you sure all of your brushes are snapped? If you've loaded any multibrushes, they will have to be snapped one they've been positioned.

5) Is the view pink at 40 feet wherever you are, or do you mean 40 feet from the starting point?
The only time I've ever seen anything so camp in game mode is when using the show_bad_rooms command. The edges of room brushes will be pink where they do not intersect with another roombrush. Usually, a roombrush be slightly bigger than the airbrush it's around, so the edge is obscured by the solid.

30th Apr 2003, 22:35
This is the first time I've used show_bad_rooms. That must be why everything is pink in front of me. I'm not going from starting point but rather Persistant Player Position. I'll do those searches like you suggested. I'm not anywhere near the end, I'm more near the beginning of building.

You said that with show_bad_rooms, roombrushes that don't intersect are pink around the edges. I also have something like show_player_room on. For me wherever it is basically dark, or beyond a hallway, well, basically about 30-40 feet from any point where I am standing ingame - everthing but the 30 foot patch I'm standing in - is pink.

Could this lead me to an answer of why pathfinding is a problem?

Also, when I use "show all" for Roombrushes, it seems that everything connects. The sewer connects to the streets just fine in every place (maybe, hmm...) I'll check that out actually, I only looked at it from a distance. (It was purty, though) Thanks, RSoul.

1st May 2003, 08:48
I must of got ahead of myself :(

Note to self: always check monolog.

I found that I had a lot of vertex cells - too many cells - can't do quality - something-or-other. Ah, who cares, it's errors I've seen in TTLG and its down. So I'm off to search the Dromed Database after working on final projects all night, I'm on painkillers, I'm loopy, and I've never felt better :D

3rd May 2003, 22:15
3. ever since you built the solid world....

whoa wait a min. you didnt start with a huge solid brush then airbruses again did you? basically you dont have to make one giant solidbrush, dromed space is already solid. maybe im misreading what you said.

4th May 2003, 00:01
Nopers, I began with airbrushes for the sewer. Then I went up about 10 feet or more and made carved out the inside of one of the building with just airbrushes. Then I made airbrushes for outside, connecting large airbrushes above there for the sky. I carved the lower world with airbrushes, then added solid for stories of the building - changed the timing on the first building so all airbrushes would still exist. Then after having the outer part of the world (buildings and walls) carved, I began carving out the interior with airbrushes.

The only reason I explained it so thoroughly is because I thought maybe I did the process wrong in some other way, though. Tis possible.

6th May 2003, 00:32
I think I know the problem. It is essentially the area between the lift and the first floor of my building. The link just goes up from the lift and go to the right, and the link from the roombrush of the lift to the lift itself cuts itself in half. I think part of my problem is that I didn't understand the grid sizes until I was helped out by Schwaa's graphic. I had already created my world by then - and have rooms that are like 100 by 98. That's way too big. I need to reduce my world. The fact alone that it takes FOREVER just to get from one airbrush to another is enough for me to reduce. My danged mouse broke last night, though, and I'm broke --so it's all keyboard for this month. WAAAAA:(

6th May 2003, 01:25
damn no mouse?? the horror. you must be a student to not be able to afford a mouse? i would send you mine but its in pretty bad shape haha...in fact my whole computer is about to blow. good thing im getting a new one in two weeks :D

i now understand how you are building your level. i thought you meant you made one huge solid block and then started carving from it. at least you're building....im waiting on my new computer before i continue working on my fms. im *trying* to play calendras leg. i had played 5 hrs into murkbell before i decided to restart that level and do things a little differently. and of course theres the news that the cheap site has fallen :( so im curious to see what we're going to have to do to continue the thief missions archive.

7th May 2003, 00:14
I'm poorer than I was as an Undergrad, that's for sure. My mummy bought me a nice Logitech Optical Mouse with Trackwheel (which is new and fandangled to someone like me who is always behind the times technologically speaking - heck, I don't have a DVD Player :) ) I was so happy I almost cried (I had to actually walk to the Computer Lab last night to type Finals papers - the horror!) Now I can work on the Dept.'s webpage. I love my mummy, she does sweet things for me unexpectedly like that. I'm so blessed.

Now I can work on my level again! Yippee! And I have a two week break from school and work to boot! Yippee!:D

11th May 2003, 01:04
I had to trash it, and now I know the problem. I first carved out all the ground level of my world, then added solid for stories. Everything pathfinds, and if I may say so myself - it looks tons better.

The problem had to do with my skybox - I could pathfind without it, but not with it. So I deleted everything, started from scratch, and added skybox sooner and it's fine. I tried to roombrush the whole skybox - but that's when the problem occurs, so much for being lazy. ;)