View Full Version : Problem installing Thief -- Error reading CD

27th Apr 2003, 05:14
Being the techie guy I am, my friend asked me to help identify why he's having a problem installing Thief on his two computer systems (both desktop systems).

When inserting the CD's into the drive, Windows 98SE reports that there is an error reading the CD (typical blue screen).

1. Checking for bad CD-ROM drivers... Command prompt reports in a data read error when attempt to cd to the cd drive. So does using the oakcdrom.sys & mscdex.exe drivers when rebooting in a DOS mode. Drivers for the CD-ROM itself are up to date (as of 1999, it's the drivers loaded by Windows 98SE upon discovery).

2. Checking for a bad CD itself... Placed the CD into my laptop works fine. Able to finally RTM as found on the CD pointing me to #3

3. The CD-ROM driver on the Win98SE systems are not in DOS/16-bit mode as listed in the manual (goto System -> Performance).

4. Check BIOS settings... Changed the PIO mode from Auto to 0 (fixed a NT OS krnlmp problem with another system regarding a read on a Win2k install). No go.

5. CD is good. Did a share from my Win2k laptop to his system. In case anyone needs to know....

a. Share a CD ROM on the computer
b. Add the user to the Win2k system so they can access resources over the workgroup
c. Attempt to install
i. Ewps, VWIN32 errors. Disable nvidia desktop
ii. Ewps, REDIST errors and cd errors. Fix instead of accessing via \\server\cdrom by using net use z: \\server\cdrom first
d. Install full works fine
e. Update the install.cfg to change from Z: -> C:
f. BUWAHAHAHA. Still looks for the CD.

6. Checked the Web. And found this site amongst others. Its not an old crappy CD ROM. Primary one on his system (and he only has one CD driver) is a Creative 5233E, 52x CD-ROM drive (firmware v2.02 from what I remember).

So.... Not a bad CD. CD drivers are up to date. It's a newer CD-ROM drive. He has returned the CD twice and has had the same problem twice (the pain and heartache involved in returning open game packages these days are so horrible).

Gimme some ideas as to why it doesn't work?

Is it the copy protection scheme implemented?

Is there a fix to install besides installing it over the network?

Should he go with the No-CD crack in order to play the game? (and doesn't this violate the typical EULA? :) )

Patrick Mrowczynski

PS. Thief Platinum edition w/ Thief TDP and Metal Age

27th Apr 2003, 06:12
What is the CPU? What is the MOBO? Does he have other devices IE ZIP drives?

Use the LITEON CD DISC and install the drivers. If you are using a
START RUN SFC. Check the My Comp. PROPERTIES see if the drive is listed. Manually assign the drive the OPSYS is looking for.

Check the MOBO disc (if you have one) and install the CHIPSET drivers if needed.

Via for example uses a 4 in 1 Vendor ID and Miniport assignment program.

Check the CABLES for the installation. Put the HDD as PRIMARY MASTER and the CD on as PRIMARY SLAVE, or alone on SECONDARY as master.

Does the CD fire up at all with other programs?

27th Apr 2003, 15:27
You did not mention *which* Thief. TDP, TG, or T2? I can get TG to play without the CD after editing the install.cfg file. The contents of mine are:
<blockquote><small>cd_path D:\GAMES\Thief\ThiefG\CD_image\
install_path d:\games\thief\thiefg
language english
resname_base D:\Games\Thief\ThiefG\crfs+D:\GAMES\Thief\ThiefG\CD_image\thief
load_path d:\games\thief\thiefg+D:\GAMES\Thief\ThiefG\CD_image\thief
script_module_path d:\games\thief\thiefg+D:\GAMES\Thief\ThiefG\CD_image\thief
movie_path d:\games\thief\thiefg\movies+D:\GAMES\Thief\ThiefG\CD_image\thief\movies</small></blockquote> However, I never got T2 to run without looking for its CD #2. Editing the .cfg file did not stop it from wanting to check the CD. The no-CD cracks may or may not work. They won't work for mine. They were developed for specific versions of the game and expect specific bytes at specific addresses within the code which they they replace. Since the bytes don't match in my copy at the addresses that they check, these no-CD cracks will abort. So I'm still left with having to leave T2's CD #2 in the CD-ROM drive.

I might've suggested that the user's CD-ROM drive was out of alignment but you mention that the read error for the same CD occurs on 2 different computers (which are presumably using 2 separate CD-ROM drives). But what is still common is the user in that they probably used the same style in connecting and configuring hardware and in installing common software, doing tweaks to both systems, etc. For example, is this user loading the CD-ROM driver in config.sys and loading mscdex.exe in autoexec.bat but trying to use the CD-ROM drive support in Windows? Those are real-mode drivers and can interfere with the Windows drivers. Comment out the driver in config.sys and mscdex in autoexec.bat and let Windows use its own CD-ROM driver. Those real-mode drivers should not be getting loaded before loading Windows unless they provide support that Windows does not. Instead they should be in the dosstart.bat file to provide DOS-mode support when you restart in DOS mode (i.e., unload Windows and revert to DOS, which is not the same as rebooting into DOS mode).

These sound like older machines but you didn't tell us anything about them (CPU, RAM, chipset, video, audio, hard drives and free space, etc.). On older machines, their IDE controller cannot handle a mix of different PIO and DMA modes for connected drives. The slowest mode got used for all drives attached to the same IDE channel; if you attach a UDMA-100 hard drive and a CD-ROM drive (of which all are UDMA-33 max), you only get UDMA-33 on that IDE channel. Separate the hard drives and CD-ROM drives onto separate IDE channels. Also make sure that you are not using cable select; configure them as master and slaves (some drives require a setting that makes them a standalone device on the IDE channel rather than setting them as master when they are the only drive on the cable).

Because the commonality of these 2 computers is the same user that configured the hardware and/or software for them, it seems more likely that they did some tweak, caught a virus from a floppy used on each, or installed some software on both - as they are now doing when trying to install multiple copies of Thief on separate computers which probably violates the EULA (and I suspect this user is probably violating LOTS of software licenses by installing on multiple machines). I'm not sure it really is a hardware problem but rather is a configuration or conflict problem. Try using msconfig.exe to disable all startup programs and then see if the game installs or if you can even just use xcopy to copy all the files and directories off the CD onto a temp directory on your hard drive (i.e., check that you can read everything from the CD). Do not use the autorun feature to startup the install program; instead, just execute the setup.exe program from the Start->Run menu. If you can't figure out how to resolve this users problem under their current setup, and if you have a copy of PartitionMagic and enough free disk space, create another primary partition, make it active (so you boot to it), and boot from a bootable floppy with CD-ROM drive driver in config.sys and mscdex.exe in autoexec.bat to install a new and isolated copy of Windows 98 and test the game install under that clean copy of Windows 98.

27th Apr 2003, 15:57
Originally posted by Vanguard
However, I never got T2 to run without looking for its CD #2. Editing the .cfg file did not stop it from wanting to check the CD. The no-CD cracks may or may not work. They won't work for mine. They were developed for specific versions of the game and expect specific bytes at specific addresses within the code which they they replace. Since the bytes don't match in my copy at the addresses that they check, these no-CD cracks will abort. So I'm still left with having to leave T2's CD #2 in the CD-ROM drive.

Following Thorin's premier patching instructions in conjuntion with editing the .cfg files will allow you to play without the cd. In other words find unsafedisc and use it.

7th May 2003, 01:29
Not currently at his house (he lives about 120 miles away) and I don't have winvnc installed :)

Problem only occurs with Thief (platinum edition containing The Dark Project and the other one which gets shipped) and not ANY other program. There are no exclamation marks in the device manager and everything is operating fine for all applications and programs.

Not using the VIA chipset on the primary computer (Phoenix brand bios) and all motherboard functions and resources seem right and work.

Even after modifying the cfg, it still searches for a local CD in order to a) play music or b) copy protection. I'm not personally familiar with why but I'm only assuming its one or two of these reasons. Thanks for the update on the no-cd cracks not working if it's a multiple CD game. Just gives more incentive to figure out why this doesn't work.

Config.sys and autoexec.bat are both blanked out (apart from the standard TEMP and certain other EV's). Tried to addin the mscdex and dos based cdrom drivers cuz that used to be a valid trick to isolating window driver problems versus dos based. But we're totally Window based drivers now, full 32bit mode.

Using the HD on one IDE channel (0) and the CDROM on the second (1). Both are selected as jumpers (never had any luck personally with cabel select except on compaq computers) so I always go for a jumper selected. No other devices on the IDE chain/cable and both are toggled as master.

Heh, unfortunately different people configured these. He bought the second (newer) one 1-2 years ago and I built the older one about 2-3 years ago. Ran through the lastest trend micro online scan and that comes back clean -- been using NAV which has stopped many of the older viruses.

Again, the problem isn't starting the game, the problem is getting past the data read problem. Double clicking on the CDROM icon in my computer just results in no-data errors. Pop in another CD, works fine, put back thief, same data error.

EULA? Lol. Don't you have to be able to see the EULA on the CD before you can agree? Can't read the CD, can't read the EULA, can't be in violation.

Burned a copy of the game (using Nero 5.x on my laptop which has a CDR, he doesn't) and the CDR works fine in my laptop but the same problem occurs on his computers. So the CD seems to be fine, but the computers have problems with Thief and copies.


8th May 2003, 00:13
Found the copy I burned in my backpack and also tried it on my desktop at home. The autorun setup screen pops up fine without any problem. Didn't install, but was nice to know that the copy works reads fine also (he keeps the originals) in other computers but sad to see that it doesn't work in his :(

8th May 2003, 05:08
My first reaction is that it is bad hardware, his CD-ROM drive. I would swap another drive in and see if it works.

27th May 2003, 02:21
Bingo Peter!

Looks like the CD-ROM was on its way out. First it was thief, and then it was publisher, leading up to Win98 and finally Windows 2000 CD's. Never had one go bad in my life (apart from the times they hit the ground) and it's really funny noticing how they degrade -- problems reading certain CD's until it can't read any CD's.

Thanks guys!