View Full Version : no multiplayer gaming with hardware router?

13th Apr 2003, 13:53
I own the full german version of Praetorians and have a DSL-connection.
Me and my brother we share the connection with both our pc's, so we have a hardware router (from Netgear).

Unfortunately, multiplayer gaming in Praetorians won't work.
The router blocks all ports like a normal software-firewall (.eg. Zonealarm) would do, and one could forward the ports to enable them.

I have tried to forward the ports that were mentioned in the firewall thread

but it still doesn't work. Praetorians doesn't even recognize that I am connected to the internet (e.g. when i disable the router and click to multiplayer there comes the message "TCP/IP connection with IP xxx.xxx.xxx.xx", with the router enabled it's just "TCP/IP connection").

Hope s.o. can help me.

13th Apr 2003, 15:11
what happens when u load gamespy arcade and try to run a game?

13th Apr 2003, 15:58
I haven't installed Gamespy. But have a friend who also has a hardware router and tried it with Gamespy. Didn't work either.

23rd May 2003, 03:32
Ok, ok, the netcode is the problem, im through a wireless ADSL connection, I also have 2 pcs on my network and i use Nextnet acces point (wireless) connected to the hub like it must be for the internet service.
I suppose that my isp is using a router, They gave me an internal (virtual) IP something like:127. x. x. x. etc. This is for the ISP network I told them about the problems i have, and they gave me 2 static IPs for me , everytime i turn on every computer They always use the same IP (one is different to the other of course). Now im using static ips.

I opened the ports, disabled zonealarm, and disabled the XP built in Firewall. I have the administrators right, etc.

I can play single player, campaigns, skirmish, etc.
I can connect to game spy, i can join lobbies, but
I cant connect to any game on the internet.
I tried IP game, both hosting and joining didnt work.
I have the last patch 1.04

The only way i can play its on my network with my virtual IPS 127. x. x. x. , It finds the game and i can join, but if i try to join from the external IPS 200. x. x. x. it doesnt connect.

What happens with the developers? didnt they test the game before putting out?
A decent game (like this seems to be) should be able to connect from different net configurations, call them Proxy, NAT, Internet connection share, Routers, etc.
This is the only game i cant play online its a shame, Eidos or Pyro do something for us we are not a few. Some of us have stopped playing Age of Mythology to play Praetorians, but what can we do?
I think keep playing AOM or recieve a solution for this problem. We wasted some money for this game so we do deserve a solution or they should give us back our money.
I bought this game thinking it would be a very nice experience online, bah!!! It doesnt work.

23rd May 2003, 14:32
I think Pyro should release a patch to fix this problem because
it's beginning to irritate me. Now when I want to play praetorians
online I have to play it on my dads pc. But when he's using it, I can only play skirmish on my own pc, which is too easy and not as fun as online battles with friends...

23rd May 2003, 15:16
join the club, i got the same problem :(
I hate it, i want to play!

23rd May 2003, 15:33
Me$$iah, I think your problem is different than mine, in this case you dad´s computer can join games. In this case you have to check out the software that you are using to share your connection to open the requiered ports for playing the game.
Are you using NAT, Proxy, Internet connection Sharing?
Yeah I know it irritates everyone, and i Poin it out, a good game can be playable on different internet connections, or if the developers know how to solve it, they should have a technical support page to guide us.

23rd May 2003, 17:23
we should all send a email and make them crazy :p

24th May 2003, 08:40
Originally posted by Jasproid
join the club, i got the same problem :(
I hate it, i want to play!

But on the thread linked to above you say

"I now opened both and it's workings
Thx very much, now i'm ready for the real game"

So whats changed to make it suddenly not work?

24th May 2003, 10:59
i don't know :(
i could play the demo but after the patch the full game doesn't work anymore (online)

24th May 2003, 11:02
thats really strange, as things like ports needed open etc etc aint changed at all..

Have you gone thru and checked your port settings again? i am guessing u done all that tho :(

24th May 2003, 11:04
yes, i've done that, it's al the same.... :(
i will try and reinstall the game today, maybe that works