View Full Version : Hello

27th Mar 2003, 23:29
I've been working on this for a couple of days, I used both DromedCentral tuts, and have used search on both forums. I have used what everyone says and I don't understand what the deal is here. Okay:

I'm using custom schemas for the first time.

I copied a song from a cd to my HD. I named the song Elfinasong. I saved it in WMP as a .wma, then saved it as a .wav and then as a .mp3 (I don't know which one actually works). I transferred the .wav and .mp3 to snd/custom in my Thief2 dir. I opened the schema folder in my Thief2 dir. I created the one that is given in the "Custom Sound Schemas" tut. It worked when I played the schema, but not when I connected it to my victrola. I figured I'd fix that last minor detail later. So I wrote over the schema I had created with the information that related to elfinasong.

//This is a comment
schema elfinasong
archetype MY_AMB
volume -500

Then I linked a SoundTrap with a SoundDescription to elfinasong. I frob the victrola, and nothing happens. I go to Play the ambient in dromed itself, it won't even play. Can anyone help?

My second problem is that I have a Mech Security camera head, but when I first approach it, only the upper part of the head shows, and when the rest does show - the eye doesn't light up - and the parts that do light up change from yellow to green to red to yellow again. Any ideas?

28th Mar 2003, 01:03
//This is a comment
schema <b>elfinasong</b> this is the name you use, obviously the same as below so it should be OK.
archetype MY_AMB
volume -500
<b>Elfinasong </b> Exact name of wav file

Thief only reads Wav's. the reason you can use MP3's now is that Darkloader 4.0 will convert them to wavs. So use wavs to test, put MP3's in your zip file.

I forgot to mention to use DL 4.0 with L4D (DOH), you should probably note that in the text file too.

Is the Victrola CD linked to the soundtrap? and does it have StdButton script on it?

Did you close Dromed, reopen, buildroom database (I know you HAVE to do this for ambient sounds)

Did you save the schema file in the Thief/schema folder. With the rest of the schemas from the Dromed folder on Thief instal CD?

Last but not least, did you
build room database, save gamesys, save miss?

28th Mar 2003, 05:45
What's that?

No, I do not have an StdButton on the script. I have Victrola, TweqOnOff. It lights up like it can be frobbed. I don't know if it is being frobbed, but I hear no sounds when I do frob it. The Victrola is CD'd to the soundtrap.

I closed Dromed, created the schema, reloaded Dromed, reloaded schemas, saved gamesys, opened mis file, reload schema, save gamesys, closed Dromed. Opened Dromed, opened mis, portalize, build room and AI database, and then compute pathfinding. (With saves inbetween each). The schema is in Thief2/schema/ (with all the schemas there as well, including the update) and the sound file is in Thief2/snd/custom. Do I need to place the sound file in Thief2/snd/english/custom?? The schema shows up in the Amb_My archetype just fine. Before I would get error messages when linking the sound trap to the file because it never existed, but now it links with the appropriate name and an object number.

Maybe I'm being a bit too complex with it? Could that be the problem? Maybe its the stdbutton thing, I'll try that. I don't know, but I will not be able to fully rest until I fix it. Ah, it's an obsession!:eek: LOL

28th Mar 2003, 09:26
Yeah, you should only have to save the gamesys and miss once after reloading schemas. Unless you change and reload schemas again.

L4D= Left for Dead, the mission I just released that I used your voice for :D

I bet its the StdButton becuase you are trying to use it lke a button to turn on the sound trap. TweqonOff is for Tweqs, things like model changes, rotations, ect...

28th Mar 2003, 17:27
Of course that's what L4D meant, if I'd thought about it a bit more I would have gotten it. :o

I added StdButton, got rid of TweqOnOff. Nothing. I still can't even use Play Schema to hear it. It's wav. I know the file plays fine, because I can play it on WMP. I just don't understand what i could be doing wrong.

28th Mar 2003, 18:34
Hmmm.... sometimes schemas can be tricky. When I was adding voices the L4D :D, I had a few times where they would or would't work. They just ended up working and I'm not sure what I was doing wrong. They're weird because there's not as much of a solid connection like just adding links that you can trace.

If elfinasong is the name of the schema then it should be typed in the SoundDescription link. Not My_Amb if you are doing it like that.
You might have My_Amb in the hiearchy so it will link, but you don't have a sound associated with it.

You should have StdButton on the recordplayer, Frob Info= In world, CD linked to a Sound Trap. The Sound trap should be SoundDesription linked to the Sound hiearchy # (-####).

//This is a comment
schema <b>elfinasong</b> This can be anyname, but is the opne you'll use. It references the actual wav file name below.

<b>archetype MY_AMB</b> This is archaic, As far as I know it doesn't really have any meaning. I didn't bother with it at all (I did rename it, but I didn't use it anywhere so I'm not sure the purpose of it)

volume -500
Elfinasong</b> Exact name of WAV, Caps included.

Other than that I can't think of anything that would cause probs, maybe somebody else will answer. Good Luck.

P.S. it doesn't matter what folder the wav file is in as long as its in <b>Snd</b>, it could be in that or a sub folder below it, or three subfolders below and the name of the folder doesn't matter, if the schema is working right Thief will find it. The only real reason to use an English named folder is if you plan to have it multi lingual, it just makes it easier for a translator.

28th Mar 2003, 21:27
I'll get right on that. There were a couple of things I didn't have that you had on there. Like for FrobInfo I had Script. I also tried it as None,None,None before but it didn't work. Also, I didn't think about it being case sensitive.

One other question, though, in the Object Heirarchy, it looks like this:

--m01 through the m's

Then elfinasong consists of a tilded link to the soundtrap, and a line of text called Play Params. Since I know not what to do with this, I intuitively checked off Noise and Voice, and added Music and Ambient to the list. Does all that look right to you?

Thank you so much for your help, I am indebted :)

29th Mar 2003, 02:37
You know, I have never messed with the play params, I just looked and in mine the Noise and Speech were unchecked to start with. I never changed it.

Mine has Net Ambient and spatial checked along with the next 5 blanks. Nothing else.

I didn't even put my sounds under <b>My_Amb</b> or any other sub class of my own, I just put them under schema

-Play Speech

29th Mar 2003, 02:41
Maybe that's the prob, then - I'm off! Yay *hug to Schwaa*

30th Mar 2003, 21:45
:D :D :D

It works it works!!!!!
It wasn't anything I was doing - it was Windows Media Player. Converting doesn't work like that. I just found out today that Nero came with a Wav Editor! I popped my sound in there, converted it to 16 bit, 22050 Hz - and wala! it now works!!! I had been searching through TTLG forum, and found a post after about an hour of searching that led me to do what I did! I am so happy! One more Dromed mountain climbed! Tanks, Shwaa:D