View Full Version : Praetorians CTD bug

15th Mar 2003, 04:08

I just bought Praetorians but it is unplayable. The menus load just fine, but everytime I try to load a mission, it crashes to the desktop. Same problem with skirmish and campaign missions. Interestingly, it plays the video (in Crossing the Arar) before crashing.

Also interestingly, the demo works fine.

I had a long conversation with tech support, basically telling me I needed to find up to date drivers for my sound card. Now my sound card was a POS, so I decided it was time to put down some money on a decent card. Bought a Soundblaster Audigy, downloaded all the latest drivers, and still had the same problem.

System Specs:

AMD Athlon XP 1700
256Mb RAM
GeForce II MX 64Mb
DirectX 8.2
Soundblaster Audigy

PLEASE help. I loved the demo, and I have been following this game for a year. I want to play it!

15th Mar 2003, 04:20
Intel and you would have no problems.....
In the future stay away from this stuff.

Athlon AMD has heat issues....


Update to DX 9.0.
Update Nvidia driver to 41.09.
Turn off all apps.
No virus checks.
Do you use windows XP?

I have an old 500 celeron with 256mb of memory and 64mb pci
vodoo 5500 and this game works great..w98v2

My other machine is XP p41900 1.5g memory 128 nvidia 4200 and I never have problems.....

15th Mar 2003, 12:58
I highly doubt it's because I'm using an AMD processor.

I have Nvidia

Already turned off all apps

No virus checkers

Yes Windows XP (Knew I forgot something, it was late last night)

DirectX 9 is going to be my last resort heh. Last time I tried to upgrade DirectX (from 7 to 8) it trashed my entire system irrepairably (different computer than this one)

15th Mar 2003, 15:16
Just use XP's system restore feature, so you can revert if something goes wrong with DX9.

16th Mar 2003, 13:07
Hey I fixed it!

I had kinda given up on it until tech help opened back up on Monday, and was working on another problem I had, with my virus scan.

After visiting their online-live chat help dealy 8 times, we finally stumbled onto the idea that when I uninstalled the ONLINE version (I was running the retail box one now) some components got missed, and were totally screwing with the retail.

Once I manually wiped every trace of it off my computer (2 hours digging in my registry) and reinstalled the program, it worked perfectly.

Then in the morning I checked PRaetorians, and that worked too!

It also fixed a strange problem I had with MSIE not accepting cookies even though I set my settings to accept all cookies.

Weird :)

16th Mar 2003, 14:26
Glad it worked. Now go and play this great game. Read the manual and buy the strategy guide. Have fun.....