View Full Version : Mission is finished, but won't play very long in DarkLoader.

12th Mar 2003, 04:53
If you turn to the right at any time during gameplay, it crashes back to DarkLoader. Is this a complexity issue? I had no errors, and I did a Full Mission Processing. Everything is zipped fine. Plus, I can do anything as long as I don't look to the right part of the mission. I went through two whole buildings before it crashed - when I look out a window at the last buildings. Anyway, I will fiddle with it, and view it with stats on. Anyone has any suggestions, I would be grateful.:)

12th Mar 2003, 06:22
It really sounds like you have a bad object, time to go back into Drom :(

Not thru Darkloader though, you'll have to repackk everything new.

Check this area in Dromed and it should crash if this is the prob. Figure out which object(s) are just about to come into view and delete it, replace it, try again.

Good Luck

12th Mar 2003, 17:57
At first, I thought it was a roof I had done (pretty sloppy, but nice for a first roof), so I deleted the roof. It wasn't the roof:(

It is some of my AI reskinnings. The Mech ones work great, and some of the nobles do, too. But two of my nobles have caused DarkLoader to crash. But, my FM is ready for beta-testing!!! Yay!
Everything seems to run peachy keen, thank you schwaa for the suggestion - you were right on target.

12th Mar 2003, 20:45
Right on, glad you figured it out.

What was wrong with the skins? wrong format?

12th Mar 2003, 21:49
I really don't know. I just deleted the problem ones and placed the generic ones instead. What's odd is I did the exact same thing with every reskinning, and I can't see how almost all but maybe four work. I basically just painted over the skin to make it a different color - a lazy, unexperienced, (and maybe not too smart) thing to do. Anyway, by doing so, I somehow stuck to the pallette or something, because I never had to make one. Anyway, out of 9 AI, it is definite that three of them won't work (and those all are either noble or servant reskins). They all have mesh and shape added, and they're not placed out of the world, they don't have custom schemas. So, I don't know. What I do know is that if I attempt to clone them I end up with a blue wedge, and it is titled Object #... So, obviously, for some reason, those certain meshes are not being recognized. I also have .cal and .bin files for them all. I didn't make .e files for them - should I?

That was a mouthful:rolleyes:

13th Mar 2003, 03:40
No, just .bin and .cal. If you have those you should be fine (you won't get those if something is wrong). Send me one of the skins and I'll see if I can find something.

13th Mar 2003, 08:29
All my other skins went kapoot right after I posted that it seems. It seems that changing the gamesys did affect them, it just took about a week for all of them to wear away or something. I don't know, but Dromed is having fun playing with me right now. I had my mission zipped, done, and was rejoiceful. So I played it...and it plays good, but two of my objectives won't check off (they're both to do with rooms) and sometimes old things I got rid of pop back up in their old places. Am I going insane? *sigh* Well, at least it's almost completely playable. Thanks for the offer, I'll get those zipped and sent as soon as possible.

14th Mar 2003, 03:03
Well the skins could be something like bit depth, if you saved as 16 bit or something they won't work, has to be 8 bit.

The probs you're having with fixed things undoing might be (I know it sounds silly, but I've done it a hundred times and I'm REALLY careful now) that you loaded your FM in Darkloader to play it. Closed Darkloader WITHOUT reinstalling Original T2 FIRST.

So when you opened and worked on the mission, and possibly saved the mission and gamesys, the loaded original thief or another FM. Then opened Drom again and started work. The file and gamesys you cahnges got repacked by Darkloader, and the old ones put back into your file.

The gamesys and possibly missions that you are working on have the same name? I'm sure the gamesys does, but never work on your mission with the name miss##.mis. Save it as "after testfix01.mis" or something, then Darkloader won't touch it.

but if it packs up your gamesys after you saved and unloads the one it saved BEFORE you made changes it can really screw you up :(-

14th Mar 2003, 08:45
I don't know how much longer I can take this! (dramatic pose)
LOL! My mission was more finished before I zipped it. Ack Ack Ack. Now I'm basically taking what I can get.:(

....but it won't see me cry!;)

17th Mar 2003, 01:22
Some weeks ago I had the same phenomenon that my FM would crash because of a custom AI. The cause was the property Renderer->Mesh Textures which contained filenames of .gifs that weren't existent for the custom AI model. When I deleted the names, everything worked fine again. Perhaps you're having this problem as well?