View Full Version : mecsub02 skin

22nd Feb 2003, 15:08
I have changed the skin for mechsub02 but the right arm and xbow are unchanged. I've used winrar to try and find the arm but no luck. Anyone have any ideas where it might be?

22nd Feb 2003, 22:20
As well as editing, DivSol02.gif, you also have to edit DivSol03.gif.

I've no idea why.

If you want to see which .gif files an object or mesh uses, look at it's model name property, under Shape, in DromEd. Then look for a .bin file of that model name in either obj.crf (objects) or mesh.crf (AI).
crfs are just renamed zip files, which Winrar should be able to open.

When you've found the .bin file, click on View. Amongst all the gobbledeegook on the screen, you should be able to find the name(s) of the .gif files that are needed.

For mecsol02, you can see that there are two .gifs.

23rd Feb 2003, 00:04
WOW, that was it. Go figure. Thanks.

23rd Feb 2003, 08:09
I'm reskinning AI's for my level, and some work and some don't (sometimes). Like my priest and priestess, servant, and noble skins works for the most part. But when it comes to Mechs, it will work, and then I'll have my last one made and they will all suddenly revert back to the original skin.

Okay, I read tuts and advice on this subject. Some said to make sure that you add Model - Shape - whatever the bin is. When I do this, the AI immediately becomes an extremely short disfigured thing. This happens with all of them. So I have to delete the shape. Also, I have to save on the original custom AI the Mesh Textures without the .gif, but then when I create the AI, I have to add Mesh Textures (again!) with the .gif (or they won't work). Then I have to add the Model-shape to the original custom AI's, then portalize. Then I have to delete the Model - Shape, and then delete the AI. Then I recreate the same AI, and it works perfect! (except the Mech guys). What is going on???

It seems that I can't win whatsoever - and the mission is so close to being finished!!! (thrashing around in great agony)

23rd Feb 2003, 14:30
Models are squished when there is no .cal file.
Here's a run down on Dromed stuff. If this is all things you already know please forgive me.

1) If you are playing Darkloader FMs on the same drive as Dromed then make sure you select "Original T2" and click on "install Only" whenever you leave playing FMs.

2) When you play youre FM in Dromed all the folders you have such as "Fam" "Mesh" ect are given priority over the ones that came with T2. If they're in the same place as where you put T2.

3)If your skins are made properly and they work once and then later they don't then I suspect that it's a folder issue.

4)As far as shape, just select the creature in object hiarchy and click on Edit, it's properties-shape- Model-name and note how it's named there and you can use that.

23rd Feb 2003, 22:04
I didn't know any of those things, I'm a newbie to custom stuff in general. I have tutorials, and I followed them - but to no avail in some cases. You mentioned if they worked once and then not after that it could be a folder issue. That sounds close to my situation. They worked for about 3 portalizations (sometimes less) and then they all turned back to their original skins. The others don't seem to have that problem. And I don't have cal files for any of them, I think. I tried using Bright, but it didn't seem to work at all. I used my Windows Hex Editor and that's where I found good results, until this.

Thanks so much for your time and help, everyone :) :)

26th Feb 2003, 22:17
I copied the original cal files and renamed them, then I took all my custom meshes and placed them in a folder in the appropriate Thief2 directory. It works beautifully! Thanks!