View Full Version : Gold Plaque text issue, please help!

21st Feb 2003, 21:59
Okay, I don't know what the deal is - but maybe Dromed is getting me back for all those times it worked so perfectly last year. It was drawing me in for the kill. Anyway, in my FM I use plenty of the Gold Plaques to designate what certain areas are. They have never worked properly!!! :mad: Except once this week, and never again since or before then.

What usually happens is maybe one plaque will read properly and the all the rest will remain blank. Or (as is usual) all of them will remain blank! Here's how I create them:

1. I create the Plaque from the Decoration hierarchy and place it
2. I do NOT put any art, since it is unnecessary (you know, parch, etc...)
3. I put the string of what the text will be in the text field
4. After I create the ones I need for that session, I exit Dromed, create the strings in notepad (always making sure to save them like "pardon.str" - with quotes).
5. Then I open Dromed later or the next day, and get nothing. Now this week, for once, every single one was working! But now, none of them are.

So, any ideas?? Also, how do I get books to read like plaques instead of opening up?? Any help would be so appreciated.


21st Feb 2003, 22:59
For your 2nd question: Make a plaque and give it a book's shape and stuff. You can go as far as adding the Metaproperty for soft stuff and not metal if you'd like.

21st Feb 2003, 23:49
Thank you, Daventry :)

22nd Feb 2003, 00:01
Originally posted by Caradavin1
3. I put the string of what the text will be in the text field

Do you mean you type in the name of the str file, but without the extension?

Eg, if the file was called pardon.str, in the book property you should put pardon

I just followed your method exactly and it worked, except for #3, which I did as I described above.

Is the str file in the right folder (Thief2\books\english)?

Check your filenames and book propeties and make sure the spelling is correct.

23rd Feb 2003, 08:02
So I took off the .str in the text field, and that didn't help. I checked all the files to ensure that they weren't str.str or .txt - they're not. Still they don't work! Waaaaaaa :confused:

23rd Feb 2003, 18:44
I had similar problems with books & scrolls, none of them worked and I copied Komag's tutorial to the letter. I gave up for a while and when I went back I'd downloaded the Thief Book Wizard and now they all work great. I still don't know why but if you're not doing whatever it was I was not doing maybe that's the way to go?

23rd Feb 2003, 19:34
When you open up the str file it should be like this:

page_0: "text goes here"

Have you typed it in that format?

23rd Feb 2003, 21:31
...yes. I have no problems with regular books, though - only those little gold decorative plaques.

25th Feb 2003, 11:04
Make a new .miss file, and create the plaque and the Text property. If it still doesn't work, put the .miss file and your books folder in a .zip file and e-mail them to me.

25th Feb 2003, 20:23
Okay, I'll try those suggestions out and see what happens. If Book Wizard doesn't work, and if the new .mis doesn't work then I will do that R soul. Thank you.:)

28th Feb 2003, 01:06
Hah hah (not laughing cause you have a prob, just because this prob ate up at least an hour for me last night),

Its probably simple fix,
open your t2 folder and see if there is a <b>strings</b> folder in there. i had one on my comp (storage) and never had a prob, since installing t2 on this machine I never created that folder, hence white words at top of screen never appeared.

You probably had an FM with this folder installed when they worked, loaded an FM without it (DL packed up the folder) and the plaque stopped working.

Even if the strings folder is empty it HAS to be there. Good luck. :)(notice that if you add book>art>plaque WITHOUT the strings folder the plaque art and text come up fine).

28th Feb 2003, 02:34
So I added the strings folder to my t2 directory...and it still does not work. Do I need to delete the plaques I already have and then make new ones? Could that be the problem? I think you are right about why they worked, though (which is wierd, since they won't work now that I have a strings folder). I had just got done exploring some c4 FM's and had forgotten to clean out DarkLoader.

The only other thing I can think of is that my folder is "strings" (no quotes) not "Strings" but I don't see how a capital letter would make a difference. (off to make sure it doesn't)

28th Feb 2003, 07:44
You'll have to close Dromed and reopen to make it account for that folder for sure, you shouldn't have to redo them.

28th Feb 2003, 20:24
May I ask what a strings folder has to do with it?

I just disabled my strings folder, and read a (text only) plaque, and it worked fine. I also tried it with a text and art plaque, and that aslo worked fine.

28th Feb 2003, 20:46
Okay, I'm at wit's end. PM me with where I can send the mis. file with the /books folder, please.

I've already reinstalled Dromed thrice this year (and didn't need to, might I add), and I don't think doing it again will make much of a difference. Now, I did install gaylesaver's scripts and komag's custom menus (and I think that's it),but I can't see how they would affect anything. Schwaa - I did close Dromed and reopen, still no text on plaques.

28th Feb 2003, 23:17
Originally posted by Caradavin1
Now, I did install gaylesaver's scripts...

GayleSaver's scripts will let you do readable plaques on frob without the need for *.str files. Just add an IntrinsicPlaque script to your plaque, and set the Design Note to whatver you want it to display when it gets frobbed. Could be a solution to your problem.

1st Mar 2003, 02:04
I really don't know but it was the only clue i came up with in my forum searches. I never had a prob before when I know that folder was present, then on a new comp I was having the prob, searched and that's all I came up with, looked, no strings folder, added it, no prob anymore.

2nd Mar 2003, 17:39
I got the text working, here's what I did:

Took off the .str in the text field of the plaques in the cemetary
Saved the mission
Closed DromEd
Restarted DromEd and loaded the mission

After I did this, it worked fine.

2nd Mar 2003, 18:06
Do you have the stinrgs directory though?

I think the .str stands for a "strings" filr, so even though the text isn't in the strings file Drom still has to register it.

2nd Mar 2003, 18:31
I did not create a strings directory.

2nd Mar 2003, 18:38
You did?! ohmigod! (*excited*) I believe I've done that before, and it didn't work, but I'll try it again. If it works, I'll bathe your feet in oil. If it doesn't work, then it looks like I may need to reinstall the files that came with Dromed. oooo, I can't wait to see if it works! (*energy is bursting from me in streams*)

3rd Mar 2003, 03:20
But now I know it has something to do with my Dromed files. I'll have to reinstall the files that came with it. Thanks for your help, r soul.:)

3rd Mar 2003, 05:06
You WILL have to include a strings folder with your release so make sure that using the names WITHOUT .str when you have a strings folder still works, it would suck to have to redo them all at release time.
R Soul, did you disable the strings folder with Dromed open, or did you close it, disable and reopen. I'm just curious. I think if you open Drom WITH the strings folder, diable it and check your book it will still work because the open session of Dromed has already accounted for it. If you close and reopen you might get different results.

It would be good to post what you did exactly for future reference, there seems to be a lot of confusion about it.

3rd Mar 2003, 05:27
I have since you suggested it. Today I tried adding books/English and putting the books there. Still didn't work. Looks like reinstalling the files is my only option. Unless the fact that its a .cow file has something to do with it and as a .mis file it works fine.

4th Mar 2003, 00:16
I don't think a cow has anything to do with it. After I got your plaques working, I then saved the miss as a cow, and they still worked.

I've been DromEding for a couple of years at least, and I have never used a cow file. I have never needed to. I always use a miss file and a .gam file. I have never had any problems, plust I'll have to distribute the miss/gam files anyway because cows are useless for playing FMs I've heard.

As far as I know, to create a plaque:

Create the miss file and load the convict and gen scripts.
Create a .str file by opening up Notepad, and typing page_0: "text goes here"
Save the file as "somefilename.str" with qoutes. Save it in Thief2\books\ You can put it in Thief2\books\english\ but it isn't really necessary unless your FM is going to have multi-language support.
Create the plaque, and add the Book > Text property. In the box named Text, enter the name of the .str file, but the .str extension is not necessary, e.g somefilename. Check they're spelt the same, then click on OK.
Save your miss file, then go into game mode and try to read the plaque. If there you don't see anything, return to editor-mode, and close DromEd.
Reopen DromEd, load the miss file, and go into game mode to test the plaque.

The order of those steps doesn't have to be followed exactly, as long as you have a plaque with the book > text property, the Thief2\books folder, and the corresponding .str file, and have closed an restarted DromEd, it should work.

4th Mar 2003, 03:32
I don't know what else to do. I have a strings folder, I have a books folder, all my files are named correctly, all my files are string files, I completely reinstalled all of Dromed about 20 minutes ago (even restarted the computer and tried it), I remade a completely fresh plaque after I remade the str. file, it doesn't say str in the text part of the plaque,...I just don't know. I've done everything right, everything. I don't understand.

I even installed the same c4 FM that caused it to work last time and it still didn't work. I guess as long as you can get it to work, r soul, that there is a good chance that most people will have no problem reading the text. I just won't be able to. Its ironic, too, because I have no problem reading the text in OMs or FMs, just my FM. *walking away from the problem with head down in defeat*

4th Mar 2003, 04:35
I REALLY think you need to use the .str extension AND have the srtings folder (it works for me).

The problem I see is that maybe without the strings folder you can skip the .str extension. BUT, you HAVE to have a strings folder with your mission to tell the mission name and which missions to skip, which to play, loadout, briefing , ect...

So even if you skip the .str thing and it works for now, it most likely WILL bite you back when you go to load up your mission. Check for your strings folder again because mine dissappeared again last time I loaded/unloaded an FM with Darkloader. (it was empty so I think Darkloader placed everything in there, then figured since it was removing evrything that it would remove the empty folder too?)

4th Mar 2003, 06:56
I have a strings folder. And most of my plaques do have string. Only three don't - those are the ones I've been experimenting with. Like I said, nothing seems to be working. I'm not half as despaired as before because I finally could get on TTLG (spontaneous eruption - I love David Bowie!!!!) and found many posts like mine. Coincidentally, many suggestions. I placed an Intface folder in my directory. If that doesn't work, I'll try placing objnames.str in my strings folder. If that doesn't work, I'll zip it all up and play in DarkLoader. If that doesn't work - I'll probably give it up to the Dromed gods. But thank you all of you for spending so much time on trying to help me. I'm beginning to wonder if part of the problem is that I've got XP.:D

Again, thanks guys :cool:

4th Mar 2003, 07:48
Nope, I did it just a few days ago on an XP machine, like I said, but I'll clarify once again.
1-shut down Dromed
2-DOUBLE check and make sure you have T2/Strings folder. (objnames.str is not needed for this)
3-Put you "plaque.str" files into Thief/Books
4-Open Dromed/ mis.
5-Pick plaque>add>prop>book>text = plaque.str (no quotes/YES .str)
6-go in game and it should work, it will also be ready for your strings files to be added whenever.
If you add the strings folder when Drom is OPEN, it will NOT register. You must close and reopen Dromed.

If you don't add the .str you could possibly have probs later.

Good luck, sometimes its best to just start from scratch. :)

4th Mar 2003, 08:26
Words cannot express!!!
Yahoo! Yippee! *bounce* *bounce*

Okay, I tried everything but zipping my file and objnames.str. Then I remembered one of the posts I disregarded on TTLG had said something about the inherit prop. I went into my three plaques without .str and put .str on them. (The others already had .str, so I didn't need to) Then I added EngineFeatures - FrobInfo - Script, and then S-Script - StdBook, don't inherit. WALA! All of them work!!! They won't work with StdPlaque that way, though. But I don't care! *bouncing around like a five-year-old*

Back to normality - does the text always stay for a while? If I frob another plaque, it pops up and replaces the other, but I don't remember the text staying that long before. Oh well, this beggar won't be too much of a chooser right now. Maybe I should sacrifice something to the Dromed gods. Thanks, all! *bounce*

4th Mar 2003, 23:31
Are you using a custom GameSys? (the white wedges in the miss file you sent me suggest that you are)

Maybe you accidentally changed a property on the plaque archetype or something.

5th Mar 2003, 00:11
Its possible, I've spent so many late nights figuring things out that I could have inadvertently deleted a prop or something when I was really tired. It had the prop of StdPlaque,,,False, though - isn't that normal? It also already had the engine ->frobinfo->script as well. For some reason stdplaque just won't work. Oh, I see - maybe I deleted an archetype or changed something about stdplaque? Hmm, I don't know...but I'd better forget about it until I finish the mission or I'll drive myself crazy figuring that out as well. I just wanna finish the mission - its become a huge tumor on my forehead ;) I'll look into it later, though. Good suggestion. Thanks!