View Full Version : Opening video will not play - Need fix

5th Jan 2003, 03:18
I installed Thief 2 for the first time. The in game videos will not play.

If I click on 'Intro' or 'Credits' on the main menu nothing happens. No opening video when I launch the game. No video when I start a mission. However the videos will play perfectly if I view them in Windows Media Player from either the cd or the hard drive folder.

I tried everything on the March 23, 2000 support page article and still no in game videos. Turned off everything except systray and explorer. Reinstalled codecs.

Is there anything else I can try?

Specs: PIII 1GHz, 512 Mb ram, Win98se, DirectX v.8.1, GForce2 Deluxe, SBLive Platinum 5.1

Thanks for any help.


5th Jan 2003, 03:24
Reinstall the game. No need to uninstall. Just reinstall over the old folder.

Rename the SAVES file if you have any saves.

1 reinstall a full install WITH THE INDEO CODECs and all the rest that it asks for except DirectX if you have a version later than DirectX 6 that comes on the disc.


Start-Run-DXDIAG Enter check the video setup in DXDIAG.

5th Jan 2003, 09:53
Hit the Start button, follwed by 'Run' in the box type the following:
regsvr32 "c:\Your\Path\To\Thief\Gold\LGVid.ax"
where the path to your Thief install is correct. This manually registers a second codec.

If you get an error message please post it back here.

5th Jan 2003, 19:33
I'm not sure why DJC's suggestion to register LGVID.AX (Input/Output LG Video Renderer) would work. I just did an Indeo codec install (using Ligos latest install package) and there is no LGVID.AX listed in my registry (i.e., it was not registered by the Indeo codec install). I have both Thief Gold and Thief 2 installed and LGVID.AX is *not* registered on my system (i.e., there is no classID in the registry so applications can find this AX control via the registry). More than likely it is an unregistered ActiveX component or control that just this software utilizes (and assumes that it will be in the install path since it is not registered to be looked up in the registry).

You probably have to [re]install the Indeo codecs. I find that even when they work that after playing several FMs (fan missions) that something breaks and I have to reinstall the Indeo codecs again. Apparently some players on Windows XP have even a worse time: every time they reboot the Indeo codecs stop working for Thief anymore and they have to reinstall them.

Reinstall is painless and does not require a reboot. I remember that one of the Thief games had an iv5.exe file on probably its first CD. That's the Indeo codec install. Intel sold off its Indeo codecs to Ligos and you can get the latest iv5setup.exe codec installation package from:


They have a Windows XP specific version of their Indeo codec package but they want $15 for it. The Windows 98-ME-2K package is still free (they make it look like you have to register but you can just click Submit and leave all the fields blank to continue to the file download page).

The Indeo codecs get screwed up so often that I put the downloaded iv5setup.exe file under D:\Games (under which I install all games) and put a shortcut to it under my Start -> Games group.

You mention that you already reinstalled the codecs. Try the latest package to see if that helps. Also run Windows Media Player (WMP) and make sure under its Formats tab under Options that all media types are selected for it to play. Something like Quicktime or RealOne Player might've stolen the file type associations from WMP. I believe WMP is the server app used to play the game videos. I run WMP to select it to play all formats, then I run Quicktime to let it select its own formats, and I run RealOne Player last and make sure it does NOT usurp the formats for the other players and that it only has its own formats selected or those not covered by the other players. In fact, check if WMP plays the .avi files okay; they are under the MOVIES subdirectory where you installed Thief.

Some players have remarked that the videos would still not play until they uninstalled the RealOne Player; I would suspect that's because some versions of RealPlayer and RealOne Player used to usurp the file type associations without asking (so you had to run the other players to yank back their associations and then run RealPlayer to *unmark* those same associations so RealPlayer wouldn't subsequently steal them again). The folks at Real produced a very rude product, but the last version is more polite. And, at least, with Real you're not nuisanced by a popup everytime you run their player asking you to pay for their pro version of the product, as does the Quicktime player.

5th Jan 2003, 19:51
Yo dude, you go way too deep all the time.

Originally posted by DJC
This manually registers a second codec.

I would find the section on TTLG where it is explained in detail, however the server is down for the moment,

6th Jan 2003, 19:57
Thank you for all of your replys.

Going to Ligos and downloading the latest win98 iv5setup.exe file helped. The in game videos will play but there are other problems.

The videos stop working everytime I boot and I must reinstall them every time prior to launching Thief 2. I run win98se, a supported platform. Should I be having this problem?

Also (when the codec is working), the Intro video does not automatically startup when launching the game. All other games I have ever played always started with a game "intro spash/movie" for which one had to hit the 'esc' key to cancel. Is there another problem here?

At least some good progress has been made here. Thanks.


7th Jan 2003, 02:23
The intro.avi movie plays only the first time you enter the game. It does not replay everytime you replay the game. To check the Indeo codecs are working, the prelude movie (as you load the next mission), abort game (skull & crossbones when you die) movie or mission complete movie should play.

Okay, time for more fishing. Did you install newer video drivers *after* having already installed Thief? The Thief install appears to do some system checking. If you later update the video drivers, DirectX, sound drivers then the "base" Thief got installed on has changed. I have found that after updating my video drivers that problems sometimes cropped up in Thief. A reinstall of Thief *after* all the other updates got it working smooth again. Don't know why, just seemed to work.

I do know that sound drivers can affect video playback (and video drivers can affect sound). See if a Thief reinstall works: copy the Saves subdirectory, uninstall Thief, optionally update your video, sound, Indeo, and Directx, install Thief, and copy back the Saves subdirectory.

If nothing more works, well, you'll have to do what the Windows XP players get stuck with: running the iv5setup.exe install everytime after a reboot before playing Thief. Hey, sometimes you have to give those old cars a kick in the tires to get them going.

10th Jan 2003, 15:31
So Thief 2 will automatically play the Intro avi only one time in the life of the game? So the only way that anyone ever gets to see the Intro avi ever again is to click the 'Intro' button on the main menu?

Hexen II Portal of Praevus was like that come to think of it. But there was no logo in that intro movie.

With a logo or publisher's name at the start of the intro, I always thought they would want the publicity there. After all, all the game publishers have their name run at the launching of their games. So does Eidos with every other game I have by them. When I double click on the Deus Ex desktop icon, the next thing I see is 'EIDOS INTERACTIVE' on the monitor followed by 'ION STORM' on the monitor before the actual game shows up. So I expected the same with Thief 2. I did not expect after double clicking the Thief 2 desktop icon to go directly to the main game menu.


10th Jan 2003, 21:51
In both Thief 1 and 2, the intro movie plays only once. That's why there is an Intro selection on the main menu. I like not having to hit Esc, F1, spacebar, or whatever some particular game wants to get past the same opening intro movie.

Munin the Raven
10th Jan 2003, 23:28
I must agree with Vanguard that having to bypass the introduction every time I want to just jump right into a game gets annoying. "I paid my money for the game and know who designed and produced it, now stop flashing it in my face every time I want to play.";)

I have noticed though, that if I don't play any of the Thief games for a month or so but leave them installed, the introductions play again when fire the programs up, as if it was the first time I'd used them. Has anyone else noticed this? It's happened to me on multiple systems with different OSs and with Thief TDP, Thief Gold, and Thief II.

11th Jan 2003, 22:39
Munin has more will power than I. I couldn't go a month without a little bit of Thief play. Never been abstinent that long.

15th Jan 2003, 20:04
Thanks for the info Vanguard and Munin the Raven. At least I now know that this part is working properly.

Now for the last annoyance. The videos still stop working everytime I reboot and I still must reinstall them every time prior to launching Thief 2. There has been no changes or upgrades. Installing Thief 2 and getting it working has been the only project on this computer. Reinstall the Indeo movie codecs after booting? Unheard of in any other game.

I now have Thief Platinum by the way. I wonder if installing Thief TDP would help any?


16th Jan 2003, 03:54
I have heard of this problem, but I think it is very rare. Lots of strange things may occur with PC's. I wouldn't necessarily blame Thief. I hope you can fix it. I would definitely try installing another version....

Grey Mouser
17th Jan 2003, 23:46
Originally posted by traveler
Reinstall the Indeo movie codecs after booting? Unheard of in any other game.

I now have Thief Platinum by the way. I wonder if installing Thief TDP would help any?


I have never seen this happen to Thief except when attempting to play under Windows XP. You did say you were using Win 98SE, right? Never happens on the 35 or so test units I have tested Thief on...except under XP. Even my Win 2000 machine keeps the movies flowing.

Munin - I have never noticed that the movies "reset" after a month, and the intro plays again...I may have to check that out and see if I can confirm your findings.