View Full Version : Desperately need help - dead AI

16th Dec 2002, 04:28
Hi everyone;
I've been working on a mission for Komag's contest lately - I got all the building done, and all non-living objects placed...but, now that I try to add AI, they will not move! :( I re-loaded convict and gen, re-installed dromed, restarted my computer, etc., etc., all to no avail!
Please help me, I really want to get this mission done, and it needs AI!


16th Dec 2002, 04:38
Try a note to APACHE his link is at the bottom of nearly every post of his.

He is always ready for a little one on one advice. Start here:


Good luck

16th Dec 2002, 05:01
Thanks TBM, I'll try that! :) I had an ICQ #, but my computer's os was re-written, which un-installed a bunch of programs, including ICQ, so I forget my #. :p I'm re-downloading it as I type this message. :)
I really hope this gets figured out. :(

(P.S. If anyone has any ideas or suggestions in the meanwhile, I'd really appreciate it! :) )

16th Dec 2002, 14:27
Thief II right?
You didn't mention the patch. Did you patch T2 and Dromed?

There's a problem with the AI without the patch. They don't move...

16th Dec 2002, 16:27
Hi Shadowspawn;
Yes, it is T2, and it is patched. :) The thing is this - about 500 saves ago, AI worked; all I did after that save was finish building, and add objects. That's it. But now AI won't work! :(

16th Dec 2002, 18:00
I just went over my saves, and found that the problem occured between saves # 245 and 246; AI work in 245, but not 246 - and the ONLY change (that I could find, anyways) was that, in Game Mode, the light gem went from dark (as there were no lights, in either save), in 245, to full bright in 246, even though the level is still as dark as 245. I have no idea how it got like that, or if it even has anything to do w/my problem, but, I figured I should post it, anyways, just in case.
Please help!

16th Dec 2002, 18:10
Did you re-compile the pathfinding database, the room database, and the AI room database? Also, do you have any roombrushes placed? If not, try doing the One Big Room Brush that encompasses the entire level as a temporary thing.

17th Dec 2002, 08:39
The "One Big Room Brush" thing sounds nasty. I wouldn't try anything like that, myself.

Did you toggle any of the brush filters? I think I did that once where I turned off room brushes to unclutter the work area, then forgot they were off and portalized/CPD/etc.

17th Dec 2002, 15:54
Thanks everyone - I tried posting in this thread yesterday, but couldn't; Changeling Jane's suggestion was what I needed - thanks everyone!! :)