PDA

View Full Version : Those reflecting mirror things in Tomb of Semerkhet ..



isis
6th Dec 2002, 13:38
In Tomb of Semerkhet, after playing that game (Senet?) if you lose you get to do the longer route out with rope swings and extra secrets but if you win you get a shorter route with a puzzle with some mirror like objects which reflect a beam of light from one to the other down through the floor. Hopefully you are with me? Does anyone know how that beam of light is created? I've looked at the level with FloorEdit and one of Ale's programs (sorry I can never remember the name of it I just call it "Ale's prog":D) and as far as I can see it is a waterfall object (I think it's waterfall1) with 2 in the OCB above the mirror object (animating 2 I think). So I've tried to set it all up the same but the waterfalls in the wad seem like the ordinary shaped waterfalls and they don't produce a "beam" of light, just an ordinary waterfall. Anyone tried this and got it to work?

Piega
6th Dec 2002, 14:35
The beams of light are indeed waterfall objects. Why dont you extract them with TR2wad? With TR2prj you can extract the project from the .tr4 data file and load the wad in it. Then you can see how it is setup. This puzzle is in my game the sanctuary of water, ice and fire. Its in the fire level. :)

isis
6th Dec 2002, 20:47
Thanks Piega - and you have answered my next question which was, can a program extract the prj with all objects and triggers? I did use TRPRJ to get the map but it was an old version and only some static objects were extracted, not the animating ones and the waterfall. I now have the latest version and I'll try again with that. ;)

isis
6th Dec 2002, 21:53
I've extracted the prj and I think all the objects are there but the map is really sick! Everything I do makes it crash - I can view two or three rooms and then it crashes, searching for the objects does the same. I've tried deleting a few rooms but still it crashes. Just changing to 2D view is enough to kill it. I've extracted it again but still the same. I've even run it through TRFix but still no good. I think the room I need to see is room 74 but that seems the most buggy of the lot!

aktrekker
8th Dec 2002, 13:43
I just extracted the project and it seems fine. A few bugs in the textures, but no crashes. Maybe the problem is in your wad. I don't remember where I got my wad from.
The beam that reflects off the mirror is WATERFALL1. There is another beam that seems to shine through the floor, where you use the pushables to trigger the beams, and that is WATERFALL2. The mirrors are ANIMATING2. Both waterfalls use OCB 2 and Invisible. Nothing special in the animating.

GeckoKid
8th Dec 2002, 16:03
what can i do, atrekker, since every level i opened and attempted to save crashes tr2prj? i know it should be my problem but i have no idea about what causes it.

isis
8th Dec 2002, 21:32
Yes it could be the wad, I got it with TR2Wad, I usually find that works OK but if I try to open it with TRWest or Wadmerger I get a lot of error messages. It's OK though, I have managed to extract the items I need with Wadmerger straight from the CD but thanks for your help aktrekker.

cornchild
8th Dec 2002, 21:48
I usually download the wads from leveleditor.com and they seem to work fine. It seems my tr4 cd has a problem you can here the cd speed up in the tray and then it slows down then speeds up. I think maybe its just messed up because there is nto a single scratch.