PDA

View Full Version : WinXp doesn't like C2 movies



Xcom
22nd Nov 2002, 17:35
Tried C2 on my new system. The game itself works great BUT..

movies don't play. DUH!
Apparently, I have newer version of WinXp Home which is bundled with Service Pack1. The problem is that with this stupid service pack MS decided not to include third party video codecs and C2 just so happens to require some Indeo codec to play movies. So, I go to download it and oh joy... it costs 15$. LOL. It is only for XP that it costs money. For other Win versions, it's free. Double LOL.
Good thing that XP doesn't crash, it just pops up a box and gives you the option to skip the "video" part of the movie.
Since WInXP is not officially supported, I pretty much rest my case. Just venting. Tnx for listening. :D

Grey Mouser
22nd Nov 2002, 18:46
Same problem for Thief and Thief II which use the same Indeo codec. Usually an uninstall-reinstall fixes it on my XP Hoser (whoops, I mean XP Home) system w/SP 1 installed.

I'll try monkeying with C2 and see what I get.

Grey Mouser
22nd Nov 2002, 20:16
Hey Xcom,

try downlaoding the Win 98 versions of the Indeo codecs and installing that (v5.11)...reinstalling that periodically keeps the Thief movies playing for me under XP.

Also, just did full install of C2 on XP Home + SP1...movies playing normally for now. Usually a few re-boots or leaving the system on for a few days is what seems to corrupt/disable/remove the codec so my Thief movies quit playing...if and when the C2 movies quit as well, I'll see if I can then get 'em going again.

Xcom
22nd Nov 2002, 21:05
I'll try that. Thanks. (However, ligos website says that indeo for Win98 won't work with XP. That's why I haven't tried it as yet)

Also, please, inform all developers who are working for Eidos to use DivX or something (next time). :p

David
23rd Nov 2002, 00:26
hey guys.i have something important to say about movies in c2 and winxp sp1.
download the patch http://download.microsoft.com/download/whistler/Patch/Q327979/WXP/EN-US/Q327979_WXP_SP2_x86_ENU.exe
or you can read the article as well
--------------------
This update addresses the "Game Stops Responding or Quits Unexpectedly When Introductory Video Clip Is Played" issue in Windows XP, and is discussed in Microsoft Knowledge Base (KB) Article 327979. Download now to resolve the hang during video playback.

If you try to start and play certain games on a Windows Home Edition Service Pack 1 (SP1)-based computer, the game may stop responding (hang) or it may quit unexpectedly when the introductory video clip starts. Additionally, you may receive an error message that is similar to one of the following messages:
Video not available - cannot find 'VIDS:IV50' decompressor
Failed (hr=0x80004002) in pVW-> put_Owner((OAHWND)HWnd)
This behavior occurs if the following conditions are true: The game that you want to play contains video that is compressed with the Indeo video codec and the Indeo codec is not installed on the computer. The Indeo codec is not included in Windows XP Home Edition SP1.

Xcom
23rd Nov 2002, 00:57
I read the article but as a solution it refers to the very same Ligos site where you have to purchase the codec. Where did you find reference to this patch? What does it do anyway?

David
23rd Nov 2002, 01:03
this patch is made by Microsoft,as you saw in download link.the article i coppied from www.warp2search.net

Xcom
23rd Nov 2002, 04:34
Sadly I forgot to mention I have dutch xp version and this patch is for english version. But I managed to locate dutch version of the patch at ms site. Funny actually, MS doesn't include the codec and then they release the patch which supposedly does install the codec.

Anyway, I installed installed non-xp version of the codec. It seems to work. Movie plays. But for how long? :D

David
23rd Nov 2002, 04:42
he he probably till the next service pack :p
MS is kinda strange with all those patches and service packs.maybe they had some sort of bad realationships with "Indeo codec" makers? :confused: