View Full Version : AI problem

Thorin Oakenshield
20th Nov 2002, 13:37
When I go ingame I can pick up live AI and drop them into the floor. This is usually a prob with unloaded scripts but I have both loaded.
Here's a bit of my monolog.txt file

Attempt to update physics on Bob (22), when non physical!
Script modules in mission:
'convict' :confused:

As you can see both scripts are loaded but how has Bob become non phyical?

This happens in both fm's that i'm working on:mad:


21st Nov 2002, 01:02
that sounds like you had the ai set to non physical....if you didnt, open up the properties and set that ai back to normal(because it sounds like its changed one way or another) i think this is under creature type>current pose but dont quote me. if you cant get it back to normal, i would suggest just deleteing the ai and placing a new one..

21st Nov 2002, 01:26
Have you tried unloading and reloading the scripts? It sometimes helps when inexplicable things happen.

Thorin Oakenshield
21st Nov 2002, 09:30
Yes I have a menu in dromed for loading and dropping the scripts. I've worn it out :)

I sent my .gam and a single room test mission to Shadowspawn and it worked fine on his machine:rolleyes: He thinks my gen & convict files could be corrupt somehow:eek:

I'm going to copy them from the T2 cd and overwrite them. Thanks for your input Guys ;) Much appreciated.

28th Nov 2002, 13:51
He he, could be fun to put something like that into an FM on purpose!

28th Nov 2002, 14:48
This has happened to me once or twice before. I can't quite recall how i fixed the problem, but I assure you it wasn't corrupted corrupted files. I just loaded in convict & gen again, portalised, built room database etc...I think I made garrett mortal aswell.

Thorin Oakenshield
28th Nov 2002, 22:50
It was my convict script. It was somehow 19k larger than the original. I copied over both with the ones from the t2 cd and it all works now.
This happened to me before. But that was a case of reloading the scripts.