View Full Version : can't pass through door

18th Nov 2002, 03:00
Hi, i'am at mission "case the joint" in thief 2 and i 've found the secret door in the objectives. I opened it by activating the switch but i can't enter the door because it seems that i'm blocked in the door.

it's the only way to enter the mansion so i have to pass that door but my guy it sticked into it. What can I do ??

I have version 1.18 of the game


18th Nov 2002, 03:37
The first that gets you into the mansion?

Or the secret staircase that you are looking for.

If it is the first, then there should be no problem with a "mantle" into the room. If you are getting stuck here then try closing the program and restarting the mission.

If that does not work then copy your SAVE file or rename it. Then Uninstall and reinstall THIEF.
Then delete the SAVE that THIEF installs and copy the saved one to the THIEF folder, or delete the SAVE and rename the one you renamed to"SAVE" and start to play.

If it is the Staircase, there is usually no problem going in and up the stairs.

If you are in the staircase, there is a secret lever you need to find at the top of the stairs.

18th Nov 2002, 06:07
Sometimes your (that is, Garrett's) feet get stuck *under* a texture. I've had Garrett in many places gets his feet stuck under carpets and runners which prevents him from jumping or walking onto another texture. When you are atop the shed roof on your save reload, check if you can jump up off the roof, then try walking through the door.

18th Nov 2002, 06:19
its the first to enter the mansion

i find my way in but i doesnt work every time. it seems there is a little bug there.

i tried what theBlackman suggest but it didn't work. So I reloaded my game and tried to enter the door a couple of times. I've noticed that when i climb on the shed, i cannot crouch, jump, lean or use my weapon anymore. it's kinda strange... but i walk aroud the top of the shed and suddenly i was able to do all that stuff again... and then i was able to pass the door... really strange bug... I've also change my resolution from 1600x1200 to 800x600 but i retry at 1600x1200 and it worked. so i don't think that's the problem... anyway now i'm in !!:D

thanx for the advice

18th Nov 2002, 06:21
oups... didn't see what Vangard wrote... that seems to be the problem. stuck in a texture.... that's kinda frustating

18th Nov 2002, 06:27
Originally posted by viper911
I've also change my resolution from 1600x1200 to 800x600 but i retry at 1600x1200 and it worked.How in the Maw did you get 1600x1200 in Thief 2?!?

Glad you got your problem figured out, but the patch probably fixes that.

18th Nov 2002, 06:32
i have the latest patch. maybe i'm just unlucky

also, thief 2 works pretty well at 1600x1200 on my t-bird 1.4 Ghz, with a geforce2 gts 64 :-) , in fact, with a lower resolution the graphics are a little bit blurry

Munin the Raven
24th Nov 2002, 01:10
On my first of my several rounds through Thief II, I also had the problem of getting stuck in that doorway. I couldn't jump or mantel when up on the ledge.

I have not played the original Thief II missions in some time, so I can't be sure how I avoided the problem in later playings. I seem to remember it being <i>how</i> and <i>where</i> I manteled onto the shed. I think I had better luck going from the side instead of the front, or vice versa. You'll have to experiment.