PDA

View Full Version : Can't play game cause of error message



monk05
30th Oct 2002, 20:16
I just installed my game and everything but after i click to start the game this error message comes up and says "Direct 3D: Unable to create device. Try chaning resolution or color depth" .........i don't know how to do that and what is the problem? THANKS IF YOU CAN HELP

Catman
30th Oct 2002, 20:44
You'll need to provide a little more information about your system.

The Captain
1st Nov 2002, 04:31
Open your hitman2.ini file in your hitman 2- Silent Assassin directory, and

change
ColorDepth 32
to
ColorDepth 16

This will change the color depth the game runs in, to 16 bit color mode, obviously. Hopefully you just have a card which doesn't support higher color pallettes. If it doesn't fix your problem try the following in the same hitman2.ini file(but leave the changes made to the above as well)

change
DrawDll RenderD3D.dll
to
DrawDll RenderOpenGL.dll

This will change the API which Hitman2 uses to render the graphics from Direct3D, to OpenGL.

PS: Be sure to save before trying again.

livebait
3rd Nov 2002, 00:57
ok so how do you change this from 32 to 16 be a bit more specific please i dont see anyway to access this

The Captain
3rd Nov 2002, 03:23
Just follow my directions, exactly as I gave them to you...

Open your hitman2.ini file in your hitman 2- Silent Assassin directory, and

change
ColorDepth 32
to
ColorDepth 16
In otherwords, go to (on win98)
C:\Program Files\Eidos Interactive\Hitman 2 Silent Assassin\
and look for a file named "hitman2.ini". Open it.

Look through the text in the file for a line which says "ColorDepth 32" and change it so that it says, "ColorDepth 16".

Hope that's more helpful.

livebait
3rd Nov 2002, 21:38
and in windows ME? how do you get to program files?

The Captain
4th Nov 2002, 03:15
Should be exactly the same for Windows ME. Should be for all versions of windows in fact. I haven't used XP enough however.

If you're unsure, go to your start button, Find>Files or Folders...

then simply look for files
Named: hitman2.ini
Containing Text:
Look in: My Computer

You can open, and edit the file directly from the find window.

legionnaire
10th Nov 2002, 21:49
I dont think the problem may be that simple. I've got a Voodoo 3 2000 card in my machine, which runs every thing I can throw at it and i'm getting the same problem thats occuring with the Intel graphics chips in the 828xx family.

To further complicate the issue, the open GL renderer solution is having the same result.

i've been through 3 sets of drivers for the card including some old reference drivers which dont give top performance but are very stable. no dice.

reinstalled the game once, reinstalled direct X 8.1 on the off chance it might have been that, even went back a version on direct x to 8.0 to see if that may have been an issue. Not happening. Have done all the usual disk maintenance and checks to look for anything out of place. it all checks out.

This one has me stuffed, any other suggestions will be gratefully received.

system.
p 533
256 mb ram
o/s win 98 2nd edition
voodoo 3 2000 graphics adapter

cheers.

Lisa
11th Nov 2002, 15:15
To The Captain:

Went into Hitman2 file and changed color depth to 16, per your suggestion, attempted to play and new message came up that color depth must be 32. I have 16 and 24 and my XP, am I out of luck in attempting to play this game?

legionnaire
11th Nov 2002, 20:18
lisa.


What resolution are you trying to run the game in? I still have an old 3d Rage card which can run 32 bit colour but only in lower resolutions. start to turn up the resolution and the colour pallete starts to gray out the higher preformance options. You may also have an older monitior which is not capable of running 32 bit colour.

Lisa
12th Nov 2002, 02:12
Thanks, found solution!

eternalsoul21
15th Nov 2002, 03:26
tell us how you fixed your problem,maybe it can help all of us that are having this problem?thanks

Lisa
15th Nov 2002, 12:10
To correct Direct 3D error:

Edit file using notepad or other text editor-
c:\program files\eidos interactive\hitman 2 silent assassin\hitman2.ini.

Edit the line "DrawDll RendereD3D.Dll" to DrawDll RendererOpenGL.Dll.
Change the line "ColorDepth 32" to ColorDepth 16.
Save and give it a go. I also restarted, but that may not have been necessary.

I had previously attempted to simply change the ColorDepth, which does not work by itself. You must edit the other line also. This information was actually available from EIDOS SUPPORT.

Hope this helps. Now-another problem I have is my Thief games are not working on my new XP. Does anyone know how to fix that? Thanks.

eternalsoul21
15th Nov 2002, 23:10
mine still had the problem so i changed the color depth back to 32 and it works fine now,thanks

centoni
19th Nov 2002, 20:21
I had a voodoo 3 which I was able to fix the 3d error and run the game. The problem is now the hitman and gaurds are either whitish grey or black. Is there anyway to fix this? Does anyone else have this problem?

gatoral65
21st Nov 2002, 21:14
Sadly for you, the reason that the guards are miss colored is because the game is intended for use on a 32 bit graphics card, so when you cut it down to 16 bits, a lot of the color gets lost.... Solution?

Its time to move on from the Voodoo and go get a newer video card, sorry man them the breaks, games are mostly 32 bit now so catch up.

eternalsoul21
22nd Nov 2002, 23:01
[Hope this helps. Now-another problem I have is my Thief games are not working on my new XP. Does anyone know how to fix that? Thanks. [/B][/QUOTE]

i have thief gold but it doesn't give me any problems on windows xp,did u try a search,maybe there is a patch for running the game on xp.or you could try uninstalling and re-install it.sometimes that works.

hitmanpa
30th Nov 2002, 16:21
what if both isn't working?

i dunno what my comp sys is...how can i know what's my comp sys? :confused:

Lisa
7th Dec 2002, 03:25
Planted both my car bombs and killed both the generals, but am unable to finish game. I head for the boat and nothing happens. What's up with that? Thanks for any input.