View Full Version : OK, now I need some help with Stonghold please...

6th Oct 2002, 03:23
I've managed to get as far as the opening to the "Great Forest"? I think...as there are many trees/branches (all very colorful I may add) and I've killed with the help of their fire, two ape men across from me in another tree hole. I can see beyond them is another figure (Mechanist/Hammer Haunt?) can't tell for sure but someone. Sign next to me says particle bridge required? So where am I supposed to go from here? Down to the bottom of this forest..is that where Pagan Village is, etc.? I believe there are four fire elementals in this general area as well and not sure if I have to shoot any of them first or whatever? I have 8 water arrows left after eliminating three of the four spiders in room with statue switches before fourth one turned around and started shooting at me at which time I hightailed it out of there with minimal damage. So please advise me as to what or where I'm supposed to go next? Thank you and Good Hunting! :)

6th Oct 2002, 03:42
If you figure out the statue switches properly, then it opens a door behind a banner on the wall on the top floor of the other building. There is one statue on each floor of the building with the secret door. The order that you see them in (I think starting with the top floor and working your way down, though I'm not sure) is the order that you use on the statue puzzle. After you've gotten it right, just slash the banner in the other building and go through the secret door to the next area. (You can avoid releasing the spiders. If you check the floor in the room with the statue puzzle, there's a pressure plate. Just make sure you don't step on it.)

6th Oct 2002, 04:39
Oops Nightwalker...you didn't read my post correctly dear lady. I did all that already..and I didn't step on the plate but the spiders still dropped down when I clicked on the first statue :( It was programmed that way to do it! What I was asking is after that and I'm upstairs in the small tunnel looking out over this very colorful forest area, etc., etc. So could you please take another look at it and tell me what/where I'm supposed to go or do. Don't know where this particle bridge is supposed to be if in fact to be activated. My map shows an elevator somewhere around this area of play more or less, that would appear to actually be my way up into the entry to get to the Sword eventually...maybe this elevator is near where this character is I see beyond me and the two dead apemen in the tree across from me?

So hopefully you'll spot this again soon so I can continue on :) Thanks Nightie and Good Hunting!

6th Oct 2002, 05:04
Well, the apebeasts shouldn't be dead unless you killed them. Beyond them is the guard. I don't remember any mention of a particle bridge here (from the passage after the banner to the apebeast hollow in the tree, or from the apebeast tree hollow to the next opening up high where there is a guard).

I could not get up to the hollow with the apebeasts without getting spotted, but then I was ghosting. If you're not ghosting and have killed them, you should be able to use rope arrows to get to the large trunks criss-crossing this environ to get over to the apebeast hollow and the same to get to the guard opening.

In the first environ (between passage after banner and the apebeast tree hollow) is a treebeast on the forest floor. If you rope down to there, you'll find the elevator behind the treebeast. If you don't want to leave the treebeast alive, you can sneak behind it and, I believe, a single overhead sword whack from behind when unalerted will kill it. There is no switch to bring the elevator platform up and it starts at the bottom. You should have a slowfall potion. Jump down the elevator and during the fall use the slowfall potion so you don't get damage on the landing. The slowfall potion doesn't last long enough for the entire fall so you have to first fall fast and down the slowfall potion during the fall. You only need to swallow it anytime before hitting the ground.

Do a save before falling down this elevator shaft. The author needs to do some fixing here. It is likely that you will get snagged on the wall where you will stuck permanently. If you get snagged, you'll have to reload and try to fall more in the center of the shaft without sliding against the walls too much.

Whether you take this elevator shaft or rope over to the apebeast tree hollow and then to the guard opening (killing the AIs before getting there), both will end up at a pool where a treebeast roams around. The elevator takes you to a backdoor where you swim up into the pool and use a ladder to get out. Roping to the guard opening and going down the slanted tree trunk takes you to an opening over the pool. It's your choice if you want to fight the treebeast, but I found you can run around while it is alerted (if it doesn't spot you right away and starts hunting away from you) and dash to the huge elevator room before the treebeast knows where you are or can catch you. Otherwise you might want to take the route using ropes to the guard opening to get to the opening above the pool since you'll be in a position to pelt the treebeast with fire arrows. When you come up in the pool, you can't use any weapons when you are in the water or when climbing the ladder.

I don't remember what is in the environ between the apebeast tree hollow and the guard opening down on the forest floor. Maybe nothing and that might be why I remember nothing down there.

6th Oct 2002, 05:24
Yes, I did misread your post Huntress. Sorry! Vanguard has got you going in the right direction, though. :)

6th Oct 2002, 05:49
Thanks a bunch Vanguard...In my first post, I did state that with the help of the apebeasts fire and me (my arrows) they both eventually died :D I have no fire arrows at this point in the game...have I missed some somewhere earlier? As a matter of fact I did go back all the way to the beginning awhile ago to try and make sure I didn't miss anything. The only characters still roaming around behind me are a couple of apebeasts in the caves. I did try on my rerun back to at least try and divert them to another area so I could check the dead body near them but instead they came my direction instead of the direction of the noisemaker where I shot it away from my location and into a another pathway that should have taken them in the opposite direction. I was partly hidden behind a rock wall when I shot it too! So I ran and got away pretty much with some damage, but then I went back with sword in hand to get rid of them since they were seperated now and not together in their little area as I found them. But woe is me...I wasn't able to kill the one that I caught up with and I had to reload and left it at that.

Well like I said the other post...there appears to be fire elementals (four...two on each side of me, two are up high and two are below and if I try roping over to the apebeasts treehouse (jk'g) I'm sure to be spotted cause it's very bright pretty much all around out there. I do have a couple of slowfalls and several speed potions. I did have two invis but used one to get from caves past the group out by the guardhouse and into safety. I managed after a reload (cause I got caught the first attempt) and seeing some of the action to take place, BJ'd the nearest one to me, swollowed my invis, then when I ran over to this hole behind where the fem mage was standing...something happened differently than the first time I got near this whole area. This time all but one Haunt died in the fight :) After a bit I was able to get up to where the other Haunt was on his hilltop and put him out of business :)

But I digress...regarding my present location...I would surmize that because your technically supposed to go down to get to this elevator...your supposed to go down wouldn't you say? Doesn't seem like the logical way would be to take a big jump down the shaft..and you are supposed to be using logic to solve this aren't you??? I sure don't relish the idea of playing tag with a treebeast either :eek: I am however unclear my purpose to doing either one of these regarding the elevator and where I'm supposed to end up at? Is my final destination here to get somewhere on the floor of this forest or up on top after bringing the elevator up to get somewhere else from up there when I've got the elevator platform to stand on once up there? I am a little confused in this regard..so could you please clarify that part of it? And where did you find or I can find those fire arrows, can you recall? Thank you Vanguard and I hope your still here to answer me tonight :D Ta and Good Hunting!

6th Oct 2002, 06:22
In the tunnels before you get to the stronghold, I think there were a couple of apebeasts and a spider. I think there was also a drop shaft into a pool. It's been a long time since I played this FM. If the apebeasts are there, you can ghost past them with only a 1st alert but you have to be very slow, and then quick at the right spot. The spider is completely blind from the front. I remember that there was some loot and a weapon there behind the spider. Wait for the spider to screw itself down the incline. With each turn, the spider goes farther down the incline until the items are in front of it where you can snatch them without getting seen although you are well lit.

I remember that when you get to the last bit of tunnel, a melee breaks out between haunts and Mechanists. I had to replay this melee several time until the setup was just right (don't remember what it was, but I think just 1 haunt was left). I could very slowly crouch and sneak to the door with just 1st alerts from the haunt. When you're against the wall, even when under the light, you are far enough away that if you crouch and creep very slowly then you only get first alerts. I recall doing this to save my inviso potion to get past the mech bot past the banner.

The mech spiders do NOT fall from the ceiling if you touch the statues in the right order. Two of the statues, as I recall, are identical or very similar so you don't know which to touch. Do a save, touch them in one order, and if that doesn't work then reload and touch the similar statues in the other order within the "combination".

I remember ONLY using rope arrows to get down in the forest environs. You can jump and mantle in some places, and in others you can rope down and even manage to retrieve your rope arrow. When you get to the forest floor, land on the grass on the far side of the huge tree away from the treebeast, then just sneak around to avoid a chase. The elevator does NOT come up here; there is no button to bring it up. That's why you need a slowfall potion at this point. Otherwise, I think the fall was too far and you die (i.e., 100% damage).

You don't need to take out the apebeasts and guard at the high spots with fire arrows. Do you have broadheads? Besides, when you get into the apebeast hollow, weren't there some more fire arrows? I'ts been too long since I played this FM. The elevator route takes you to a water tunnel that comes up in a pool. The high route via the apebeast tree hollow and guard opening down the tree slope takes you to the same pool. So it is not absolutely required to take the elevator; both routes take you to the same pool where there is another treebeast. The high route lets you use weapons on the treebeast, if you have any (I think only fire arrows work). Otherwise, you could use an inviso potion here. Maybe you have a flashbomb. I think there are a couple torches here, so you could douse them if you have water arrows to help provide shadows; even if the treebeast gets alerted, you could wait until it turns away and then run to the big elevator. If you used up all your inventory usable against the treebeast, run like hell to the elevator.

As with the elevator in the forest environ that's inside a tree, also do NOT press against the walls for the big room elevator after the pool and treebeast or you'll get permanently snagged on the wall.

6th Oct 2002, 19:01
OK as far as the statues and using the right one first as far as not triggering the spiders...apparently the one I clicked which there were two winged statues the same...I must have used the wrong one first and that's why I got spiders I guess :( but it was too late in my saves to go back and redo...oh well...

I did use broadheads to kill apebeasts in tree...I have not found any fire arrows up to this point that's why I was asking where they were :D I do hope there are some in apebeast tree hole as I will be playing Tarzan to find out :D Right now, their fire is keeping me hid from the guard over on the other side and hopfully will keep doing so when I get over there and then put out a torch that's near him or ???? Haven't figured out how I'm going to get rid of him yet!

So is it necessary for me to get into this pool to get to another area....I still don't understand my direction to end up in? If I'm supposed to end up where this guard is in the tree and the elevator would only take me up to where he is...why should I go down to the forest floor only to get back up again on the elevator? This is why I'm still confused. :(

If I go down to the forest floor...am I to find the Pagan Village down there...is that my purpose for going down there first...and then find my way back up to guard in tree to go elsewhere from up there? Please if you can...give me the info on this part of my journey :) Ta and Good Hunting!

6th Oct 2002, 22:54
Huntress, you don't need to go down to the forest floor. That is only another way to get to the same place you'll end up at if you go across using rope arrows.

You don't actually get to a pagan village in this one, but you do meet a pagan, just not until almost the very end of the mission. :)

7th Oct 2002, 00:45
After getting past the banner and as you stand at the next door, you have 2 choices TO THE SAME DESTINATION. You can go down to the forest floor. Or you can go across to the guard station. Both lead to the same spot - the pool with the treebeast, then onto the big elevator room, and so on. I'm sure you've taken multiple routes to get to the same place. You get a choice here, too.

8th Oct 2002, 17:37
Thank you both very much for unconfusing me LOL Yes, Vanguard I do realize there is more than one way to get around :D it's just that trying to read your explaination tended to make me think I also needed to get down to explore perhaps the Pagan Village area...but now that Nightwalker tells me that you don't really find it afterall, apparently I shall take the chicken route and not mess with the Ent :eek: :)

I decided Saturday to give it a rest and wait for a reply, so I took out my RTS of Pharoah try to get through the final stages of my level...I'm still struggling to try and find the way to get 6000 citizens and provide for them...tough in this level to do! After several hours spent in this level through various times, I did hit 5000 at one point but have lost them due to droughts, etc. not being able to sustain them...this is in the later levels but can't remember which one. I have pyramid built and all other objectives except population and culture rating required...which says I need more dancing girls, LOL only I don't have any space or enough population to build one...yet anyway. So I didn't come up for air all day until about 3am when I gave up and went to bed. Didn't even turn on puter yesterday as I was tired and got interested in some TV instead. Very good programs on PBS including one later on, Navy Seals and then Ken Burn's film on Frank L. Wright...what a tragic life he had that I never knew about before!

So anyway, now that I have a better understanding of my objective in Stronghold at this point, I shall get back to it soon. I just hope those Fire Elementals that are apparently in the area don't see me ;) Ta and Good Hunting!

8th Oct 2002, 18:50
It's been a long time since I played this FM, but I don't remember any fire elementals in it. You sure you aren't thinking the the glow orbs that float around are maybe fire elementals. Are they bluish white and change the lighting as they float around? Fire elementals only exude heat & light when alerted. The glow orbs make a jingle sound as they wander and they never go on alert. Fire elementals are yellow and larger orbs that make a crinkling noise as they wander but switch to a moan and groan noise with a lot louder crackling noise when alerted.

9th Oct 2002, 04:18
Well as a matter of fact they showed a redish color just like an elemental...however after several tries to get it right with the vines/placements/jumps I got over to apebeast tree and did find some fire arrows :) Having put out the fire first from another limb I was standing on nearer to it and in a spot where I figured I wouldn't be seen when I jumped over plus one of my moss arrows to quiet my fall in. It worked and then I shot guard from inside the tree. Dead eye...that's me :D Then again after several tries to shoot Ent from up on the edge where guard was..couldn't do it and eventually decided just to go down that slope and get closer and it worked... and saw another sign where I got down too about that particle bridge required? Anyway I dropped on down, took a swim and got a few more trinkets...then went onto the big elevator.

After going down and through that highly decorated area with the stained glass dome, went near door and took care of the two guards w/lanterns, then I went around after trying to cross bridge unsuccessfully and put out a lot of torches to make it darker, then got to door w/key in hand and got inside with minimal damage. Took care of guard inside and went through rooms plus the guard sleeping in one room where I found servents quarters. Put one torch out at the far end after going down there first and that woke up one servant who ended up in the middle of his bed so left him alone and went around opening chests...waking other servants up but put them back asleep again. Found the two ladders but at first couldn't figure out how to get onto the one in fireplace...so went up the other one, found spiders and hole down that led to a note and said I need to go out the way I'm looking at...only it said I had to go to the very top, etc. So then I decided to go out in front again and this time spotted ladders up to guard tower. Went up there and at first I didn't go up high enough as it turned out and got zapped. So I went back down aways till I thought I could make another attempt, only this time I was going to hurry over and take my damage but with gas arrow ready to shoot as I got over. Ha, ha..instead at that point a haunt appeared and took care of the Hammer...that was a surprise for sure! So I hit the switch and Garrett said, time to get out of here?

Then I went over to the other one just for drill an found a couple more goodies and left Hammer there alone, got back down and back inside to try and climb that other ladder again. This time worked it out and got up .... allll the way up LOL and over to tunnel and this is now where I'm stuck and need help again.

I went down tunnel to opening...dropped down and inside the grated fence where I found another note, telling me that he decided not to leave the second note but would write this one himself instead. The cover inside I opened once to see what was what and spotted a Mechinist below I think and then closed it again. I see the sword down at the other end on the other side of this fenced off area. I cannot get to it. I cannot jump over fence even with using Speed potion. What the devil did I do wrong...how in the heck am I supposed to get this sword? Where was I supposed to go? I have three saves...2 regular and my QS. One regular I think is somewhere while I'm still on ladder part way up this very tall climb...the other for sure is just at the opening after I've jumped in and my QS is down inside this fenced off area looking at the sword down on the other side at the end. I am stumped my friends...!!! I obviously did something not according to hoyle but don't know what or where :(

So please help me out again at this point cause I'm outof ideas. Thank you much and Good Hunting!

9th Oct 2002, 04:40
You're in the right place, from the sound of things, Huntress. You don't need to get over the fence. There should be a hatch in the floor close to where you found the note. Open it then use a slowfall to drop through. The sword is down there. :)

9th Oct 2002, 04:59
Thanks for coming back and replying :) However, somethings not quite right here. The sword is on the same level when I dropped down hole and landed inside this fenced in area...only down on the other side of me as I explained. Are you saying I have to go down this other hole after opening it up and fight/or whatever/ whoever else is down there before I have to find a way back up to where the sword is again? Thanks...

9th Oct 2002, 12:19
Just to make sure we're in the same place, you went put out the fire in a fireplace and the logs moved sideways, then you climbed ladders inside the chimney, right? At the top, you ended up in a little room with a hole in the floor and some slowfall potions sitting beside it. You dropped through the hole and landed in a fenced section with a note and a trap door in the floor. When you look across, you can see a golden child and a red bubbly light thing, in another section, right? The sword is NOT over there. It's on a platform in a room down below you. There are a couple of mechanists and a couple of bots down there. The bots are standing still and fairly easy to get rid of. You have lots of potions and ammo, so just make good use of them. The sword is fairly close to where you drop down and there's a little gold child nearby. He's the swords "familiar" or whatever it's supposed to be. He just follows you around, so ignore him entirely.

Are we at the same place? :)

9th Oct 2002, 12:44
OK...your right of course...I tried to zoom and see what was down there that I kept thinking was the sword...cause it looked like from where I was, it was flaming? So then I took another look later and discovered it wasn't the sword of course and finally made out that it was an AI afterall :D My poor eyes :rolleyes:

So now in actuality I have finally completed the mission and thank goodness. I was starting to get concerned again about whether I needed some additional help..but I kept poking around and dying, etc. and got the thing figured out. That room upstairs almost had me going...then thinking about all the banner bashing ppl did when they played I thought well why not give that a try...couldn't hurt? So I started where I came up and went around till I found the right one and almost didn't understand what to do there but after fiddling around a little...got out :)

I sure had a time for awhile with Bot city though...good lawd, LOL Tried a few things here and there but kept ending with the short end of the stick, so I finally gave that up and made my way down the right hall with the help of moss, gas arrow for one guard, and used invis to get by one and finally crept and BJ'd the last one near the escape door! What a trip! And those crazy teleport rooms...ha ha...I think I musta BJ'd about all of them upstairs and down but did end up killing the first bunch when I got into another room but screwed up getting my water arrow put away in time which still left me lit up some and couldn't hide away, so I started swinging and they kept coming in of course due to the noise...but all ended well for me and off I went.

This was really a pretty good FM and big too! Lots of different challenges and settings. Even though I got confused a little about my destination, I still pretty much enjoyed playing this one and glad I managed to find it again in my computer and decided to test it out to see if I had played it or not. I was surprised to find out I hadn't and this was a good time to rediscover it so I could :) Thanks very much as always for the added help to both of you and now (rather later today) I'll get back to Deus Ex again :) Ta and Good Hunting!