View Full Version : Optimization: WARNING: COULDN'T GRAB COPLANAR CASE! (x3)

29th Sep 2002, 03:13
WARNING! Couldn't grab coplanar case!

This error comes at the very tail of the optimization process and is followed by two or three very quick entries which I have never been able to catch.

Why does it do this?

Is it bad?

- - - - - - - - - - - - - - - - - -

ERROR: remove_poly_edge: edge not in poly list.

This error <small>(Yes to trap, No to exit, Cancel to ignore)</small> crashes DromEd at the beginning of the second DromEd portalization after the DOS optimization window has closed.

I was getting scene complexity errors earlier, so could this be related? I have tried taking the things I just put in out, though.

How can I fix this?

29th Sep 2002, 04:03
ERROR: remove_poly_edge: edge not in poly list.

This error is caused by a certain corner room which was next to a very complicated spiral staircase (compact, torched, gorgeous and my first :D), and started showing up after I enlarged said corner room.

I deleted the room entirely and re-optimized and everything went perfectly except for the WARNING! Didn't grab coplanar case! error.

I am not yet sure what about making the corner room a little longer and a little taller gave DromEd the ****s, and I really don't think I'll ever find out.

- - - - - - - - - - - - - - - -

WARNING! Couldn't grab coplanar case!

This error is caused either by a multibrush or by the combination of a multibrush and a faulty install of DromEd.

The symptoms: it shows up in one of my missions but not the other. Therefore it cannot be a straight "DromEd hates me" error.

But it shows up in older versions of the mission under discussion - versions which before did not produce this error. So it cannot be a straight "DromEd hates this certain multibrush" error.

But I saved my entire mission as a multibrush and loaded it into a brand-new mission file, optimized and got the same error, leading me to believe that it has something to do with a certain combination of brushes in my mission. So it cannot be a straight "my .MISS file is corrupted" error.

So obviously it is a "DromEd is possessed" error.

I will continue to investigate this.

29th Sep 2002, 04:47
Have you snapped all the brushes?

Multibrushing ignores grid settings. As well as other annoyances.

The "Didn't grab coplanar case" error most often happens when a number of brushes aren't snapped to grid. It also usually only shows up when optimizing. You can use area brushes to isolate a part of the mission and that way determine exactly where the error is occuring.

30th Sep 2002, 01:43
that error is probably a solid brush not snapped to grid. i had this problem with my first level dread and could never find the brush that was causing the error. i knew what area it was in but couldnt find it so i said the hell with it....the level plays fine for me although a few people have said that the level crashes when they try to go past the first room. i used grid 11 for that level and since ive been using grid 12 ive never seen the error again. i dont want to say "dont worry about it" definatly try to fix it but if you cant i would say to continue on:)