View Full Version : Big Problems

27th Aug 2002, 06:49
Computer was acting up. Ran latest Norton virus scan. No viri discovered.

Used Start disc to check HDD setups. Lo and behold all three drives showed as "Non-Dos" format.

Start windows runs fine. All drives show as FAT32 while in windows.

Go back to Start disc, refomat Drive 1= C,D,E, drives and attempt to reinstall windows. No luck. Other 2 drives don't show at all in SCAN check.

Fdisk shows three drives but do not show a FAT, all Drives show as Non-Dos.

Don't expect an answer but this is a really strange one.

Tried to reinstall windows a dozen different ways. "Cannot blah blah because of virus protection program blah blah or partition damage.

Start disc and Fdisk still show non-dos partition.

27th Aug 2002, 17:34
Since you've already tried to format, I'd remove the partitions(and everything else, eg logical drives, you want a clean drive), reboot, add the partitions, reboot, format all, install Windows.

Fdisk>3>4 to remove non-dos partitions.

Usually works for "non-dos partition" errors.

27th Aug 2002, 17:39
Thanks Salvage,
Am in the process. The part that has me confused is how it happened that the Fat32 (which read as Fat32 in Properties in windows) became Non-Dos on all three drives, yet Windows continues to function.

The Hiccup that is causing the dropped data is the only reason that I am re-installing.

As I mentioned, in windows all three drives (9 partitions) show the partitions and Fat that they are supposed to.

In Fdisk they show as Three HDD single partition each Non-Dos :confused:

28th Aug 2002, 02:09
Are you using Windows 2000 / XP or 98? In the former, there is no DOS, just a command shell that runs under Windows. In this case, it could still be windows that is confused. Maybe you have too many partitions and the poor OS is just tired of keeping track of them.:) To be more precise, maybe windows has some tables that keep track of partitions that have become corrupt, and the tables interface differently with the command shell than they do with the GUI, so one works and the other doesn't. Just a lame thought. Feel free to reject. Anyway, if it were me, I would not have nearly so many partitions (as we have already discussed).

28th Aug 2002, 22:18
It could be your MBR (Master Boot Record) is screwed up. This record which is the active primary partition on the drive, it contains the partition table, and it probably indicates the type of the partition (since you aren't actually interrogating the partition to determine the OS when you are modifying or interrogating the MBR).

Try running:
<blockquote>FDISK /MBR
</blockquote>This will attempt to "fix" the MBR. If you were deleting partitions, you might as well as reset the MBR, too. However, I had one occasion where this still would not correct problems in the MBR. In particular, the partition table can list the partitions out of order (i.e., the first partition in the table could be for the 2nd partition and the 2nd partition list in the table could be for the 1st partition). Some utilities don't understand that this is possible and will ***** that there is a problem with the partitions (when there is not). In this case, I use Ontrack's Disk Manager but it let me wipe out the MBR, too. I don't have it anymore. It came with a 13GB drive back in the days when LBA (Large Block Addressing) was new in the BIOS on motherboards. The MBR could be screwed up if a boot manager overlay was loaded there, like Ontrack's. Certain boot manager programs also overwrite the MBR (e.g., IBM's Boot Manager and Powerquest's BootManager). If you uninstall them but they omit to restore the MBR, you are left with a master boot program that points to a nonexistent program (to perhaps a nonexistent partition).

Each drive has an MBR so you'll need to fix it on each drive. I don't recall you can enter a drive letter on the command line when executing FDISK, so I don't know if FDISK lets you change the drive after it is running that gets its MBR fixed or if FDISK only fixes the first physical drive's MBR (because that's the only one used even if operating systems in their entirety are on other physical drives). See the following KB articles:
If "FDISK /MBR" doesn't work and you don't have a copy of Ontrack's utility, you could see if Powerquest's PartitionMagic would work to wipe out the MBR and partition table.

29th Aug 2002, 06:01
Thanks Vanguard.

I did not think to try the Fdisk\Mbr. And it probably was the MBR that was fouled up.

I just refomatted C drive and re-installed. I wanted to clean the system up but had planned to do it on my terms. Oh well.

Another interesting thing was that Disk 2 (3 in the chain) was also set as an active partition. Very interesting.

I shall remember the Fdisk\Mbr fix for the future however. I should have thought about it as it was mentioned by Bravus, and you about 2 months ago for Clayman's problems with his crash.

Fortunately, I had nearly everything burned to CD's for backup so except for about 10 DL's of some utilities (which I can easily replace) the situation is annoying but not devastating.