View Full Version : Win tweaker 95-98-nt-Me-2K-XP

5th Aug 2002, 18:26
Go here:


6th Aug 2002, 05:04
One problem I noticed immediately during the install of X-Setup is that it requests to have you let it steal the .xpl file association. It doesn't let you know if it is already assigned to another server (i.e., program). I checked in the registry and .xpl files are associated as a file type supported by RealPlayer (as content type "audio/scpls").

After looking at www.filext.com, it appears the .xpl file is for music, probably specific to KaZaA -- which is known to proliferate spyware (which spyware varies according to the version of KaZaA you install); see http://www.tom-cat.com for information. So I'm not worried about wiping out the .xpl file association, but apparently RealPlayer is capable of playing these music files.

Before installing X-Setup, I would suggest (if you have RealOne Player installed) to open RealPlayer and look under the Media Types associated with it under the Tools -> Preferences menu. Find the "Audio Playlist" media type (for "audio/scpls" and "audio/x-scpls") and uncheck it. Close RealPlayer and then install X-Setup. If you ever need to steal this media type back into RealPlayer, just go here in RealPlayer to check this media type. I don't know if X-Setup has a similar file association setting to let you steal it back once you've stolen it for another program (I haven't gotten X-Setup installed yet to check).


Okay, got X-Setup 6.2 installed and took a quick look around in it. I have found no option or setting where you can tell X-Setup to steal [back] the .xpl and .xwz file associations. This means that if another program later steals this file association, you have no way to conveniently reassociate them to X-Setup. Not smart.

6th Aug 2002, 05:26
I just ran the update within X-Setup and saw the list of plug-ins that it wants to download and install. Everyone of them has the .xpl extension. So you MUST select to associate .xpl files with X-Setup during its install, else its plug-ins won't work.