PDA

View Full Version : Theif 2 problem



Hoo Ha
26th Jul 2002, 20:34
I'm aware there is a "dark engine" for the game, but I can't see anything. I turn my brightness on my moniter all the way up. I turn the gamma all the way up. I try to play at night with no lights (had to do all these to play Thief). But, I still just can't see squat. Are there any patches out there or anything that can help me out?

theBlackman
26th Jul 2002, 20:56
Originally posted by Hoo Ha
I'm aware there is a "dark engine" for the game, but I can't see anything. I turn my brightness on my moniter all the way up. I turn the gamma all the way up. I try to play at night with no lights (had to do all these to play Thief). But, I still just can't see squat. Are there any patches out there or anything that can help me out?

What is your system:
CPU
Video Card
Opsys
ETC.

We might be able to help with additional information.

What version of thief??
What other games do you run that seem to be OK.

Some Vcards, seem to have a problem with the Gamma in Thief.

Grey Mouser
26th Jul 2002, 21:11
Hi there Hoo Ha,

tBM is on the right track asking about your system. This type of behavior usually means that somewhere between the drivers (software) for your video card/device and Thief II, there is a miscommunication.

To find out what vid card/driver version/etc you are running: Start>Run>type in dxdiag>hit OK, and share some of that information here.

Some video cards don't support in-game gamma switching, and if you are unable to adjust the gamma setting in Thief II (under Options>Video) to get a playable gamma setting, you could try adjusting gamma settings on the video card control panel itself, in Windows.

Look under Display Properties (right click somewhere on your desktop - not on an icon- and select Properties>Settings>Advanced>look under some of the tabs for your video card. For example, the machine I am typing at has a tab for 3dfx Color, and under that tab is a selection for Direct3D and Gamma Settings, which affects the brightness/gamma settings for all Direct3D applications....like Thief II.

You can try making gamma adjustments here instead in in-game.

Hoo Ha
27th Jul 2002, 20:52
Pentium 2 400 Mhz
384 MB ram
DirectX 7.0
Hard Drive 9.48GB
Used:8.82GB Free:680MB
STB Velocity 4400
Win 98

I also tried the Advance button, but I could'nt change anything of the such.

Grey Mouser
8th Aug 2002, 17:41
Sorry for the lenghty delay in response, Hoo Ha...I have been out of the office for a number of days.

Since the STB Velocity 4400 is more or less the same as the nVidia TNT 16MB video card (it uses the nVidia TNT video chip), and since STB quit writing new driver software some time ago, I suggest trying a more current nVidia driver, instead of the STB drivers for the card.

However, you probably do NOT want to install the latest nVidia Detonator drivers, which really are optimised for more current hardware and DirectX 8.1.

Try downloading and installing an older nVidia TNT driver would be my best suggestion. You can find a wide variety of them at:

http://www.guru3d.com/files/

Many of them are unofficial releases, and you may get best results by using a WHQL (Microsoft Certified) version, like the "6.67" driver...but "your results may vary".

It is also an excellent idea to make certain you remove all traces of the earlier STB Velocity driver from your system, before installing the nVidia driver.

The same web site has a Guide on How To correctly install an nVidia driver:

http://www.guru3d.com/guide/detonator-install-guide/

After installing nVidia TNT drivers for the STB Velocity 4400, check again to see if the In-Game gamma adjustment now has the desired effect, and if not, try the Display Properties control panel for the TNT, looking for a setting that adjusts Gamma levels for Direct3D.

Peter_Smith
9th Aug 2002, 07:27
The original TNT card is much darker than some other cards. Unless you have a bright monitor to go along with it, a TNT can be terrible. I used a TNT with a bright monitor for a while and it was OK with gamma turned all the way up and some monitor adjustment as well. Then I moved the TNT to my wife's computer which had an older, darker monitor, and Thief was unplayable there, even with monotor adjustments, just like you are experiencing.

Sorry, there is no fix other than different hardware or monitor adjustments. Since you have exhausted the monitor adjustment, then I guess you need a new video card, monitor, or both. I would start with the video card and work up from there. I note the following:

A GeForce card is brighter than a TNT.

More recent nVidia drivers come with a software brightess / gamma adjuster where you can set the card up for different games. Unfortunately, Thief does not honor that setting -- Thief resets the card to the hardware defaults.:(

Thief is just too dark.:( Most players must play it with gamma most of the way to the right. There is not enough latitude for adjustment.

I think LGS blew it with the brightness settings in thief and by restoring the hardware defaults of the video card. That is the only complaint I have about the programming.

Sorry my news is not happier.:)

Grey Mouser
9th Aug 2002, 20:42
It must be that my monitor at the time was in better condition than Hoo Ha's...I distinctly recall playing about half-way through TDP on a TNT-based vid card about a year+ ago.

Yes, it was darker than other comparable vid cards (Voodoo 3, Rage 128) but definately playable, even under bright office flourescent lights.

At any rate Hoo Ha...follow Peter's advice about possibly upgrading/changing your hardware if you want to enjoy Thief.