View Full Version : Stupid ANIMATINGs

9th Jul 2002, 15:50

I built a "private" level. It's ready but I did a few changes to the WAD. I only deleted some weapon anims of Lara (LARA_SIXSHOOTER_ANIM for example) and some ammo items (you don't get these weapons in the level, so it is smaller).

I use the pyramid puzzle of the cleopal WAD in my level. After these WAD changes the top of the pyramid is now animated (some textures of it move), but that's not right of course. So I added this object again from the original cleopal WAD but it is still animated (yes, I output the WAD and converted the level).

What's wrong? Please help!

13th Jul 2002, 14:47
I did some test with WADMerger and StrPix but it still doesn't work.

Come on, you should know something!?

13th Jul 2002, 14:58
Did you try it with the original wad with all the animations still in?

Why would you want to make the size of your wad smaller? It doesn't affect the game or anything, and it's a private level, so I gather it's not for downloading.... :confused:

14th Jul 2002, 09:48
First it worked but then I deleted the animations. I don't know whether it works with the animations because I deleted the old WAD. I could try to add them again.

I deleted the animations and the ammo because of weapon cheats. Yes, you can still use them but the ammo and the animations look really funny if the are not added to the WAD.

14th Jul 2002, 19:41
It's really strange. There are no animated textures in a wad file. And all objects have their own animations so deleting another won't effect this one.

14th Jul 2002, 19:53
It still doesn't work. I added all objects again but the object textures are still animated.

I had that problem with an object from TR5, too. I thought that was because of some incompatibles but I've got no explanation for this stupid bug!

14th Jul 2002, 20:02
Wad files don't have animated textures, but the levels do. If the texture numbers get messed up, an object texture might point to a texture that is in an animation range.
Try deleting all animation ranges in the LE and rebuild the TR file.
Then, if you need animation ranges, add them back again and rebuild.

14th Jul 2002, 20:10
If the texture numbers are messed up, wadmerger should crash when you try to open it. If it doesn't, that's not the problem.

15th Jul 2002, 08:48
This also happened to me.
I converted some TRC Rome objects with TR2Wad, and when I was checking them in my level, the light poles had some of their textures animated like a waterfall object.

15th Jul 2002, 09:11
one of my horizons has blips of other object textures on it :confused:

15th Jul 2002, 13:45
WADMerger doesn't crash when loading the WAD, but I think I'll try aktrekker's idea.

15th Jul 2002, 20:36
I did what aktrekker said, but as TRWad said, it didn't work.

I have no idea what the bug could be :mad: !

16th Jul 2002, 11:13
It would appear that there is a way to make textures animate on objects, but we have only discovered it by creating buggy wad files.
Maybe a little research into these broken wad files or TR4 files would open up some new special effects for us to use.

16th Jul 2002, 12:35
Maybe, but I hate that "special effect"!

20th Jul 2002, 13:53
Ah, now I know!

Only the flipped textures of the pyramid top were animated. So I used StrPix to set unflipped textures and know it works.

I don't now why that bug occured but now it's solved.

Thank you!