View Full Version : BUG: talk to Costache - choose "Do business" - and you're stuck

25th Aug 2016, 12:45
Hi there,
I stumbled upon my first bug in Mankind Divided:

when I talk to merchant Costache and then choose "Do business" the game does nothing. it's not frozen, though. just stuck.

I pressed all the buttons and nothing happens, apart from the menu button. The only option is to load a saved game (at least that works).

choosing "Leave", by the way, works. I also tried leaving and then talking to him again to do business, but no luck...

I so wanted to give him some of my credits :-)

26th Aug 2016, 22:01
Hey! I have the exact same bug on my system. First time i've tried - game is stuck, nothing helps. But after several hours in i've tried again, and after some button mashing i've managed to get to buy/sell screen, and my cursor was selecting items on top left of those under it(like imaging selecting text in these brackets but instead my first sentence gets selected). So i guess it is some sort of UI glitch. I've got 1920*1200, 100% FOV, 369.09 drivers and nvidia 1070. So you are not alone =)

I suggest reducing fov, switching to another resolution and trying windowed mode.

p.s. the guy sits at shop that is named "tech noir" i think.