PDA

View Full Version : Game won't load...still



SithLordWolf
24th Aug 2016, 18:18
I press Play in Steam. The launcher loads and when I press "Play Deus Ex Mankind Divided" it closes. No message, nothing. When I open the launcher, Steam says the game is running next to the game's name in my library but when I press play game in the launcher it goes Syncing then disappears. It's as if the game closed. Is the Play button in the launcher mis-linked to the close button? Skipping the launcher doesn't work either. I have updated my Nvidia and Windows 10. I have used compatibility modes. I have uninstalled and reinstalled the game several times. Restarted Steam several times. Verified game cache several times. Closed all anti-virus and firewall programs. I have changed all graphics settings to low. Every conceivable option I can do I have done.

SithLordWolf
26th Aug 2016, 12:16
UPDATE: I got it to work. I tried to close my third party programs again one by one and I found out it was Iobit Malware Fighter. Once I closed that it worked. Now it can work even with the program on. I guess it was blocking something from installing. Got in game and everything is running on max settings with only a slight fps drop, noticable if I focus. Nvidia Geforce 970 in case people want to know. Yay.