View Full Version : praxis, credits, parts... dlc missing from storage (only weapons there)

23rd Aug 2016, 21:03
pc/steam user, digital deluxe edition

in storage i can only see classic revolver and and elite battle, combat and tranq rifles. i have 0 praxis, 0 weapons parts, 0 credits, etc

according to the digital deluxe edition doco, i seem to be missing:

*(from the assault pack) two packs of regular Battle Rifle ammo, one pack of armor piercing Battle Rifle ammo, 2 Frag Grenades, 2 EMP Grenades, 500 Weapon Parts, and 1 Praxis Kit, using the included Chaff Augmentation

* (from the tactical pack) one pack of tranquilizer ammo, 3 Smoke Grenades, 2 Gas Grenades, 500 Weapon Parts, and 1 Praxis Kit, with the included Micro Assembler Augmentation

* (from the season pass) 4 Praxis Kits, 5000 Credits, 1000 Weapon Parts

i have seen numerous reports of this from other players, on pc and other platforms, on this forum, reddit etc

please could you put it on the known issues list? :-)

23rd Aug 2016, 21:16
I'm experiencing this issue as well.

23rd Aug 2016, 21:18
The kicker is that I don't really want to start a single player game yet because all of these consumable bonuses don't carry over between saves. Thus, I want to redeem everything right at the beginning so I have a save with all the unspent points ready at the beginning.

23rd Aug 2016, 21:22
yeah, me too with the saves

some dude on reddit just suggested (without knowing one way or another) that this dlc might not appear until after the first mission, because some 'event' might occur that strips you of augmentations and maybe other gear. so then it would make sense to withhold that dlc until then (because otherwise it is wasted)

if this is the case then the comms around the consumables dlc has been a bit poor, because there are a bunch of peeps like us twiddling our thumbs 'waiting to start for real' :-) (i.e. after this consumables issue has been resolved)

23rd Aug 2016, 21:25
That doesn't really make sense though, does it? I got a praxis point from Breach and that's just sitting in storage along with the guns when you start the game. I don't think some of the items would work one way for most of the items and another for the praxis and creds.

23rd Aug 2016, 21:32
yeah, your experience pretty much invalidates that dude's proposition :-) good info

23rd Aug 2016, 21:33
What I'm worried about is that this issue isn't a "known" issue yet. Who knows if it's being worked on.

23rd Aug 2016, 21:35
agree... well, apart from making this post (asking for it to be made a known issue) and raising a ticket, all i can do is wait... bum :-)

23rd Aug 2016, 21:39
Where did you open a ticket? I think I'd better open one as well.

23rd Aug 2016, 22:00

23rd Aug 2016, 22:15
i found a solution, which is to link your steam account to square enix. in the game's main menu click on 'square enix' and go from there. after doing that i can see gear in the shop, and my missing consumables in storage. yay! :-)

23rd Aug 2016, 22:28
I found a solution: try uninstalling and reinstalling your DLC. Worked for me.

24th Aug 2016, 03:44
I'm facing the same issue on ps4. At least the Micro Assembler Augmentation is missing.
Has anyone found a solution to this annoying problem on the ps4?