PDA

View Full Version : Email preferences, NetworkError: 403 Forbidden



killergrass85
13th Aug 2016, 15:03
Hello,

All the calls to https://xmail.square-enix.com/unsub/ from the email preferences page, which is used to save email preferences return "NetworkError: 403 Forbidden"

This means email preferences can't be updated and saved.

Regards,

VirtuaSukajan
18th Aug 2016, 07:56
All the calls to https://xmail.square-enix.com/unsub/ from the email preferences page, which is used to save email preferences return "NetworkError: 403 Forbidden"
This means email preferences can't be updated and saved.

Hi killergrass85. Are you still affected by the “NetworkError:403 Forbidden” issue or has it been resolved by the admin already?

At first I wasn’t sure what you were referring to but then I tried to check my own profile settings and managed to find an icon in red labelled “Manage your email subscriptions”. This would take me to a page where I can choose from a list of games I would like to receive or not receive email updates for.

Is this the issue you are reporting on?

Also, in contrast to the URL you posted, my folders looks slightly different:
Yours - https://xmail.square-enix.com/unsub/
Mine - https://xmail.square-enix.com/fe/track/unsub/

Out of curiosity, I googled the error message in order to learn more about it and found some interesting information from a Digital Guide on the following site, explaining the meaning of the different error codes and suggestions on how to solve it. Apparently they are called HTTP Status codes :)
https://www.1and1.com/digitalguide/hosting/technical-matters/the-most-important-http-status-codes-at-a-glance/

For this particular status code “403 Forbidden”, the site says that the code tells us that the “requested data is access-protected” and that our request to access the page is denied due to not having the authority.

So this seems to be an issue that the forum admin will have to remedy. The status code looks to be automatically generated and there is a suggestion on the page that site owners should implement manual notifications instead, so that it is maybe easier for us forum users to know what is wrong or happening :)

Anyway, unless the admins have seen the thread already and put in a fix for you, I would suggest you contact them directly to raise the issue.

killergrass85
18th Aug 2016, 19:03
Hi VirtuaSukajan,

Thanks for taking the time to reply. Yes that is area i was referring too and no, no fix yet :scratch:

In reference to the url being different



Also, in contrast to the URL you posted, my folders looks slightly different:
Yours - https://xmail.square-enix.com/unsub/
Mine - https://xmail.square-enix.com/fe/track/unsub/


The /fe/track/unsub/ url is the url of the “Manage your email subscriptions” page where as the /unsub/ url is the url of the page being called.

You can test this your self go to “Manage your email subscriptions” page and press f12. this will open up the browsers console. now click on the update switches and you will see in the console the error thrown by the update request.

I have raised the issue directly to them and first time i got a response telling me how to get to the “Manage your email subscriptions” page. Not very useful and second time they said they would pass the information on. So now it's a waiting game. I guess if it carries on and as you can't change your email address i will have to block the emails or forward them all to support until they get annoyed and fix it :)

QuickMythril
2nd Sep 2016, 06:49
ah neat, someone who has some technical info on the issue. of course all they respond with is "how to unsubscribe" which we all know doesn't work. perhaps if we all add our voces to one thread they will be heard. this is an ongoing issue for everyone. so far no official word back from them. keep updated with this problem at the following thread: http://forums.eu.square-enix.com/showthread.php?t=190681

alichataq
3rd Sep 2016, 17:40
I know very limited HTML but this looks like lazy webpage design by Square Enix. There is probably a simple fix for this issue but it will not get fixed until their website design team is notified of this issue. Like many of you, I contacted Square Enix support and they replied with the generic instructions on how to unsubscribe. I replied to their email explaining that their "Manage email preferences" webpage is flawed and that changed do not register. I even linked this thread in the email. I hope my email is forwarded to the right people so that they may fix this system wide issue with poor webpage design.

killergrass85
6th Sep 2016, 08:46
Woop they final fixed it!

When you click the tick box it now a 200 response, then refreshing the page returns the new saved preferences .

Hope it's fixed for you all as well!

VirtuaSukajan
6th Sep 2016, 12:40
Woop they final fixed it!

When you click the tick box it now a 200 response, then refreshing the page returns the new saved preferences .

Hope it's fixed for you all as well!

Yeah, tested it myself now and it truly works. My issue was that it did not allow me to turn the feature ON, but now it saves correctly.
Good job raising the issue :)