View Full Version : Did I mess up?

19th Feb 2016, 06:39
Or is there a way out I can not figure?
I am new to this whole type of game, but I thought I would give it a try.
I am presently only in the last 30 minutes or so (Climb the Tower--on the way to get rid of the waves of pain coming my way.) The way I play it may be a couple of hours.
I thought it would be a good idea to fast travel back to a few locations to get my skill points up to a good level, which has worked until tonight. I decided to do the challenge in path of the Deathless area...Challenge completed, however I can not figure out how to get back to a camp site. Killed my self a few times but to no good use, just bruises. I'm in the area of the challenge, but if I take the robe back to the thin path I am not high enough for the campsite, and I cannot figure out how to move back further to get to the previous one.
Please help before I have to restart and do this all again.
Thank you for your assistance.

Figures after I posted this I figured it out...duh

19th Feb 2016, 13:05
lol. i have these moments as well that im stuck for so long, but as soon i post about it; problem solved. makes you wonder at times if the game is playing you. :nut: