View Full Version : I can't open my Prophet's Legacy card pack

28th Dec 2015, 20:50
I finally got around to downloading and installing the Prophet's Legacy DLC pack but when I try opening the card pack (from the gifts tab in the in-game marketplace), I get the following error message:

This pack could not be opened right now because your inventory is full. It can be opened later in the Gifts tab.

Anyone experienced similar? At first I thought I had reached a maximum number of cards (what can I say, I'm a hoarder), then I sold a few duplicates and still no go. I know it's not the case because I could buy two Bronze Packs shortly after that and not get any error message.

What should I do?

28th Dec 2015, 23:57
What should I do?

Raise Hell and boycott CD and Square? :scratch:

Sorry, I couldn't resist :p Hope it gets worked out for you.

30th Dec 2015, 01:05
I don't know how or why, but today after downloading and installing Endurance it opened on my first try. Unsure what would have triggered a full inventory notice but all is well now. :)