View Full Version : Geothermal Valley Fowl Play Challenge Issue

29th Nov 2015, 23:07
Not sure if anyone else has run into this problem. Upon my first visit to the valley I picked up a chicken and the challenge banner appeared but I failed to put the chicken in the pen and continued with the progression of the game. When I was able to revisit the valley, all of the chickens have flown the coop. There is not a single feathery beast visible in the whole valley. Can anyone offer any insight?

12th Dec 2015, 04:50
I got the same problem, it's either night or rain at the place; where I should be able to find the stupid chickens for the fowl play challenge.

I'm at point of no return and don't wanna continue until I finish everything from the back.

Can Square Enix create a patch of this mess, please.

12th Dec 2015, 08:26
Update #2 I think addressed the respawning of animals. Have you guys installed it and tried again?

12th Dec 2015, 17:30
Update #2 I think addressed the respawning of animals. Have you guys installed it and tried again?

Thanks for the reply I'm using 360 not XOne, apparently update 2 is not available for 360 yet. I hope they fix it soon.


1st Jan 2016, 12:32
I have this issue too. I am at point of no return, going all around to get 100%. However wherever I go, there is night. The games looks depressive, and it is so depressing that even the chickens do not re-spawn. How do i get to a day environment again? I love em chickens.

2nd Jan 2016, 23:51
I finally found a solution to this. Don't wait for a patch, just finish the game. After you finish you will still be able to travel and finalize quests and missions. And this time, during a day with loooooots of chicken.
I don't know why the point of no return even exists. Since there are no limits when it comes to continuing the game after the main story line ends. Actually playing the game in night mode is sooo much worse and uglier that I recommend to finish the story line and come back to collectibles and missions after the game ends.