PDA

View Full Version : Email notification doesn't work correctly



Vanguard
29th Jun 2002, 20:01
In my options, I have the following setup:

Email notification by default? = NO (disabled)
(emails you whenever someone replies to a thread that you have participated in)

Enable private messaging? = YES (enabled)
(allows users to send private messages to you)

Send you an email when you receive a private message? = YES (enabled)

Sometimes I might turn on email notification for <b><i>my</i></b> threads (i.e., the ones that <b><i>I</i></b> opened) if I want to find out when someone added a post to it. But I certainly do NOT want an email when a post is added to ANY thread in which I have participated. I don't want that deluge of emails. So I turned that option off. However, if someone sends me a private message (which requires that I login to the Eidos site to look at my User CP page) then I do want to get an email notification.

Yet today I find I have 13 messages about users who have added posts to <b><i>my</i></b> threads. So there seems to be a couple problems:

(1) The "Email notification by default?" option which says it will send an email whenever anyone replies to ANY thread in which I have participated is wrong. It appears it will send email ONLY when replies are posted in threads that I have opened.

(2) Although the "Email notification by default?" option is off, I still get emails when replies were posted to my threads. This did not occurs until I enabled the "Send you an email when you receive a private message?" option. So enabling the email option for private message also enabled getting emails when new posts are added to my threads. Obviously this is not what I wanted nor defined by these options.

I guess I'll have to disable all email notification options until this gets fixed.