View Full Version : Hebrew keyboard and WASD

26th May 2015, 08:50
Hello, since the first chapter I had a minor problem that appeared randomly:
When I started the game, I couldn't move using WASD, and was able to move only with the keyboard arrows. All the other keys (Shift, Space, Ctrl and Esc) worked fine.

I have a Microsoft Digital Pro Media Keyboard (Hebrew version), and I managed to "fix" the bug temporarily by restarting the game a few times. I didn't have that bug at all since then, and it reappeared again during chapter 3, with the photo focus mini-game. The A-D keys didn't work.
I restarted the game, tried a different chapter and saw that I can't move. I entered key-config and changed WASD to the Hebrew variants: 'שדג (W', Aש, Sד, Dג). It works now and I managed to clear the photo mini-game, but sometimes when I start the game the keyboard is on Hebrew, and sometimes it's on English, and it messes up the WASD key-configs.

I guess that the solution is to somehow make the game automatically change keyboard language layouts to English when the game starts.

Microsoft Digital Pro Media Keyboard (Hebrew version)
Windows 8.1 PRO 64-bit.
Intel i7 950
Nvidia Geforce GTX 560

All drivers are up to date, I don't have this problem in other games.

Thank you.