PDA

View Full Version : Steam download stuck at 99%



Prophet968
30th Jul 2014, 23:28
Recently after getting into the Nosgoth Closed Beta, I tried to install it... Sadly, whenever I try this install I can get to 99% in the download, from there it gets hung up and won't download any further.

I've tried all of the suggested fixes, such as rebooting steam, changing download server, deleting client.blob (or something like that), and finally testing on a different internet connection (LAN connection). Even after all of this, the download still won't complete and I cannot play the game. I think this issue isn't steam related, since all of the steam related fixes don't seem to do much of anything.

Details that could help:
Download speed: 120Mbps average
Upload speed: 20Mbps
GPU: GTX 765M
CPU I7-4700HQ
Wireless drivers all up to date

RainaAudron
30th Jul 2014, 23:32
Did you try verifying the integrity of the game cache?

Prophet968
30th Jul 2014, 23:33
It's still downloading, so it doesn't think there's much of a game-cache yet, it verifies one file and states that it passed.

Update: It seems that this game, and Team Fortress 2 actually are receiving an error now, they get "Connection Time Out" after attempting to download/download the update. Though, other games are able to download while these two cannot.

RainaAudron
30th Jul 2014, 23:40
Hmm... seems more people are having this issue with Steam. Pausing and resuming the download doesn´t help? Can you click on the play button? Just throwing ideas out... :/ If nothing else works, you can try to download it on another computer and then copy paste the files to your steam folder on your pc.

Prophet968
30th Jul 2014, 23:43
Thanks for the suggestions, but I've tried that as well... clicking the play button only opens the "Preparing to launch" thing, which shows that it's updating.

I've heard that waiting could work, or switching to a less stressed steam server (since I've only tried two steam servers) I'll report back on the server one, and if I get it fixed tomorrow I'll be sure to mention that.

Update: Server fix did not work, on any U.S. servers.

Hopefully tomorrow I'll find that it was only a steam issue, and is fixed on it's own.

FireWorks_
31st Jul 2014, 09:36
Update: Server fix did not work, on any U.S. servers.

Hopefully tomorrow I'll find that it was only a steam issue, and is fixed on it's own.

The error message would be interesting. This is where you can go look for answers with.


I had an issue on the last game update too.

Restarting the whole PC, instead of only steam itself, helped in the end (around 5mins... )

Prophet968
31st Jul 2014, 14:36
The only error I've gotten is "Connection Time Out". That occurs after waiting at 99% for a few hours.

FireWorks_
31st Jul 2014, 14:47
The best i found in a quick search was this:
http://forums.steampowered.com/forums/showthread.php?t=2510649&page=4
says to install dotNet4.5 but Id consider it voodoo too. Maybe it helps, shouldnt hurt at least.

With your connection Id just download the game again (delete all disk content in the steam library).

If it fails again try it not via WLAN but plug a cable in.

Prophet968
31st Jul 2014, 18:12
The answers slightly awkward, but I did solve the issue. Apparently my router (an Asus RT-AC66R) had a firmware update that enabled a porn filter, which somehow blocked the download/installation of this game. So disabling this filter seems to have fixed the problem...

Yeah, I'm serious.

FireWorks_
31st Jul 2014, 18:50
That is a totally reasonable thing. Blocking specific traffic. Firewalls are there to block traffic :)

Glad you posted the solution here. I bet some people in the future will benefit from it.