View Full Version : Director's Cut Horrible Performance

22nd Apr 2014, 07:09
So I loved the Human Revolution. I loved it enough to buy the missing link and when I realized that it wasn't built into the plot I practiced some google-fu and discovered that in the director's cut it was. So I decided to purchase the Director's Cut. I say this to point out that I have purchased all three titles separately and am hoping that earns me some good will... because I have tried everything I can find online to get DE:HRDC to run smoothly and I am at a loss.

First off, my specs:
CPU: AMD Athlon II x2 @ 2.8 ghz + 8GB RAM
GPU: AMD Radeon HIS 7820 w/ 2GB VRAM
dxdiag (https://app.box.com/s/8o38qdr7qtt62a265hcf)

Second, what's actually happening.

Most of the time the game runs like glass, (constant 60fps) Then I'll enter a new area and everything stops (1 ish fps). Then it'll bounce back and run smooth as ice again. The effect is jarring, and frequent enough to prevent the game from being enjoyable and troublesome enough, especially during combat, to make the game unplayable.

Third, what I've tried.
- Reduced all video settings to minimum = no effect
- Uninstalled and reinstalled on a different hard drive = no effect
- Used regedit to set D3D11_CREATE_DEVICE_PREVENT_INTERNAL_TH*READING_OPTIMIZATIONS to 1 within HKEY_CURRENT_USER\Software\Eidos\Deus Ex: HRDC ... \and/ ... AllowJobStealing to 0 = no, or at least negligible effect.
- Using Borderless window ap to play the game in a window = some improvement but still maddening.
- yelled at the computer and bashed face into keyboard = no effect

So, I'm at a loss. The original game played like glass. Smooth, enjoyable and lots of fun. The director's cut is driving me crazy and I honestly don't know what else to try. So, any help would be just awesome. Thanks so much, cheers.

28th Apr 2014, 23:31
There are no solutions. Nixxes has completely abandoned any support for the PC version. I suggest asking for a refund.

29th Apr 2014, 03:51
I remember this being the case back when I had my Phenom II x2 555 BE.

The issue was rectified when I switched to a Phenom II x4 965 BE.