View Full Version : PS3 R2 Button not working randomly

Unholy Phoenix
26th Feb 2014, 06:58
i cant pick the first lock in the game...it wont let me...it says hit R2 but i do and nothing happens....i reinstalled it like 10000000000 times and still nothing.

27th Feb 2014, 21:00
When you move the lockpick make sure the circles light up grey and then press R2.

2nd Mar 2014, 15:41
I'm having the same issue, no matter where the lockpick is, it will never click the pin.
Unless I can find a solution, I'll be returning the game for another copy, hoping the one I got was sheer bad luck with a fault, and not the store having a faulty batch.

2nd Mar 2014, 20:17
Was it just that disc or is it a problem with the game?

2nd Mar 2014, 20:25
I have not yet returned the game, I intend to do so after college tomorrow, but from what I can tell, it's a relatively isolated problem with some disks having the issue, whereas the others seem to be fine.

2nd Mar 2014, 22:14
I guess its the game. I to am having the same problem on ps3. this is the 3rd disk of thief and still the same.

2nd Mar 2014, 22:19
If it's the game then it's something which Eidos can't afford to ignore, but it seems odd that not everyone is getting this issue. Either way a patch is going to have to be issued very soon or Eidos is looking at a serious loss here.

2nd Mar 2014, 22:24
yeah im pretty mad about forking over 60 bucks just to steal some **** from one room and walk a beam and **** with birds in another. great game guess I beat it

3rd Mar 2014, 01:16
I'm playing it on PS3 and haven't had that problem. I downloaded it, though.

3rd Mar 2014, 20:52
After returning my copy and exchanging it for a new one, I can safely say I'll be getting a refund since the problem persists, I'll pick it up again once this has been patched but for such a severe game breaking bug to get past QA, it makes you wonder.
Eidos need to at least acknowledge this problem or they're going to have some very angry customers on their case.

3rd Mar 2014, 21:05
You're HOLDING R2 in right? Not just pressing it and immediately releasing? You have to hold it in for a second or two.

3rd Mar 2014, 21:08
I am holding in the button, I do not know about everyone else but I have found no way past this.
Even holding the button down for 30 seconds has changed nothing.

4th Mar 2014, 00:20
And you're holding it in where you get a constant vibration from the controller right?

4th Mar 2014, 05:56
Purchased hard copy of game and R2 key will not work for lock picking, reinstalled, worked until today--same issue. Purchased downloadable copy from PSstore, played five hours, and now same issue. Fix this! I didn't pay $60, now $120, to not play the game. And it's not my controller--tried five different ones.

4th Mar 2014, 16:07
Yes, in every possible angle that the controller vibrates and the indicator lights up, but to no avail.

4th Mar 2014, 16:11
Better than the luck I've had, it never worked at all on the lock picking for me, so I've got a refund until such a time that the issue is fixed.

5th Mar 2014, 11:26
Has there been any news on a patch to fix this yet?

5th Mar 2014, 13:30
There has not, but I have contacted Square Enix's support team and at their request, have given them all the information I have in order for them to investigate further.

5th Mar 2014, 17:23
This isn't going to be much help but I randomly tried it again before giving up with it completely and ive managed to pick the lock

5th Mar 2014, 17:45
Uhh... you guys aren't hitting R1, right? Just checking. :scratch:

5th Mar 2014, 18:02
No way in hell.
I'll be honest, when I saw that R2 wasn't working, I did try R1 thinking it might be giving the wrong tip, but no, nothing happened whenever, wherever or however I tried.

5th Mar 2014, 18:06
Well, that sucks. I downloaded it and it works, if you want to try that.

5th Mar 2014, 18:09
As much as I'd like to, I've read elsewhere of someone who downloaded it and got a similar issue to this one, only there's was randomly not working whereas this is constant.
I'll just wait and see what Square Enix says when they get back to me.

6th Mar 2014, 07:21
Are you using a after market controller or an original one? Because I noticed earlier the lockpicking doesnt seem to work with my after market controller only the actual ps pad

6th Mar 2014, 11:43
I've tried with both, neither work.

15th Mar 2014, 18:33
I have the same problem. It's sucks that you wasted $60 just to be stopped by a R2 button...:mad2:

28th Mar 2014, 05:42
I downloaded the game twice, and tested with and without the patch and it still wont work.

28th Mar 2014, 12:00
Such a bizarre problem. You'd think that all downloaded games would be identical. :scratch:

30th Mar 2014, 10:00
Same problem here. Downloaded it twice... Aftermarket and playstation controllers... Pushed R2, held R2, pushed and held every button on the controller. Still not working. And, it appears that this lock must be picked in order to continue. So, yes I bought a game that I could play for about 5 minutes, and have spent hours now trying to figure out what's wrong. At first i thought it was me, but thanks to you guys i can be sure i am not an idiot, the game is broken. If anyone having this problem figures out a solution, please come back and post it, as i have yet to find the answer anywhere else. Thanks.

4th Apr 2014, 05:38
Same problem. Literally just installed it yesterday through PSN. After trying 6 different controllers on 2 different systems, and having a Sony support rep basically call me ignorant after saying she plays it on PC, I demanded a refund. Will repurchase once this bug is fixed

4th Apr 2014, 05:45
Erm are you saying it simply doesnt let you use the r2 to pick locks? as this is a required function during the opening level you can appreciate if it was a bug for everyone then not a single gamer would have been able to get past the opening level.

Could you explain more about what you are trying to do and where.

4th Apr 2014, 11:08
In the Prologue, once you get to the room full of bird cages. After you trigger the switch on the painting with R2, that's it. A few seconds later it doesn't register some players hitting R2 when picking the lock. Some it works at random times.

4th Apr 2014, 11:23
Another thread with more people having the same issue here >>> http://forums.eidosgames.com/showthread.php?t=141728

4th Apr 2014, 11:58
As i said on the other thread. if this was a universal issue then not a single person would be able to actually finish the first level as its a required portion of the prologue, and as we know that many people have finished the game its not happening for the vast majority of gamers.

Also the game went through Sony approval and they would never have let a game ship if you couldnt complete the opening level.

What controllers are you using?

4th Apr 2014, 12:00
Replied to that one too..

as i said we wouldnt have got approval to ship if this was an actual game issue.. there has to be something else causing this.. is the controller a 3rd party one or the official one that came with the console?

4th Apr 2014, 13:56
Personally, I've used 2 aftermarket and 4 official controllers, and installed the game on 2 different systems.

I never said it was a universal issue, I only stated that "the game doesn't register some players hitting R2 while Lockpicking, and some players have it work at random times." From what I've read, only a few PS3 players have actually posted about it

Edit: the aftermarket are Afterglow Wireless controllers

7th Apr 2014, 06:52
Played the dowloadable version of Ps3 Thief and never had this problem at all.
Game now finished, including all alternate jobs.

14th May 2014, 17:03
I am having this problem also. I returned the first game, and still have the same issue with the second disc. We have tried everything, I have looked all over online for a solution, downloaded all the updates, etc. I am completely disappointed. :mad2: $60 get home and can't play the game, twice in a row.

18th May 2014, 02:06
same problem.very mad that i cant play this game and that they want to blame a controller when we are using a play station factory controller..worthless.

20th Aug 2014, 07:49
hold down on the PS button, go to controller settings, switch to controller 2 an there you go

7th Sep 2014, 05:18
So i found it to be every first lock pick after you turn the system off. A (not so simple) work around would be
1. Change your current controller to controller 2
2. Connect another controller, it will automatically be set to 1.
3. Switch Original controller back to 1.
4. Enjoy

Maybe just switching controllers will work but idk.
My original is an afterglow and my second is a broken sony ps3 remote

4th Mar 2015, 02:29
I suggest this, it worked for me: Start a new game deleting your previous save. The picking lock bug should be gone.