PDA

View Full Version : Stereoscopic 3D Bugs/Issues Thread



TsaebehT
2nd Mar 2014, 14:10
1)Add Dynamic Crosshair/Interactive&Waypoint Marker & Fix 2D Dust/Fog(Major/Game-Breaking)
There are 2D 'inconsistencies' with stereoscopic 3D, such as 2D HUD elements (2D crosshair, 2D item interaction prompts, 2D waypoint markers, etc) as well as 2D fog/dust effects, by 2D I mean they are displayed singularly and not 'stereoscopically' at the depth which they are supposed to be perceived. These things literally break the immersion of stereoscopic 3D ... personally I only purchased the game because of the claim of Stereoscopic 3D/3D Vision support and in this state, for me anyway, it's completely unplayable ...

2)Fix Depth Slider Bug(Minor)
There's also bug of sorts with the in-game '3D Separation' when I move the slider to max(which isn't even enough but I'll get to that later) and back out of the menus the setting sticks BUT when/if I 'apply' settings it reverts to a much lower separation (NVIDIA Control Panel Depth Setting perhaps?) even though the menu shows it still being maxed out.

3)Increase Usable Separation/Depth Values to 4000(at the very least)(Major/Game-Breaking)
Which leads me to my next point the 'max' setting doesn't seem to be governed by a monitor size, max on my 65" DLP isn't enough to match my, or even the average, IPD, Interpupillary Distance(Distance between the eyes), which is generally between 2.5" to 3". When set at max on my 65" the separation is only about 2.125" which is just shy of 3.8% of the screen's width ... 3.8% of a 24" monitor is roughly 0.78" (Thanks Dugom for confirming this is actually the case) ... that doesn't even come close to the average 2.5" to 3" IPD and considering the average PC user is playing on a 24"(or 3) they aren't getting nearly the depth/separation they should be getting for convincing stereoscopic 3D. I noticed there is a StereoSeparation registry value, which is set at 1000 at max ... a 24" 3D Vision user would need to be able to set it over 3x, almost 4x, that value.

tommybhoy
3rd Mar 2014, 01:53
AMD 3D doesn't work at all on 290X, stereoscopic option is grayed out, is this going to be addressed in a future patch?

TsaebehT
3rd Mar 2014, 14:39
AMD 3D doesn't work at all on 290X, stereoscopic option is grayed out, is this going to be addressed in a future patch?Have you tried setting the Vsync to a different type? I remember on my setup when the game was first released S3D would only be an option if I chose 'triple buffered' ... and now after the patch (Patch for Thief, v1.1 build 4110.1) it's only an option if I choose 'double buffered' ... which is a pain because I usually turn Vsync off in games and force it on in the control panel and this won't let me enable S3D with the Vsync set to off.

tommybhoy
8th Mar 2014, 02:57
Thanks for the suggestion, but nothing happening.

On further inspection, TR, and SD's 3D option is greyed out, so it's looking like a problem on my end and not the game.

:)

shak
9th Mar 2014, 16:09
Did you start the game on the 3D TV/Monitor ? If you start on a device that does not support stereo 3D, the option will remain grayed out no matter what you do !

shak
12th Mar 2014, 17:38
There's a new nVidia driver that solves some of the stereo 3D issues...not all of them, but the game it's much better with the new driver....