PDA

View Full Version : Game crashes trying to enter Chapter Two - Dust to Dust



Gothik
1st Mar 2014, 22:06
I've hit a problem where Thief will crash every time it tries to load Chapter Two. The first couple of times it just stuck on the loading screen, then it would present me with a black screen with music playing, sometimes it would give me a Windows message saying Thief had stopped working.

The last couple of times it has locked up my PC causing me to do a hard reboot (something I prefer not to do if possible).

Things I have tried: Lowering the resolution (this got it a little further, I could see a cutscene trying to start before it inevitably crashed again), lowering settings, forcing the 32 bit version to run, updating my Catalyst drivers from 13.12 to 14.2 beta and finally swearing at it. :p None of these helped or made any difference.

I'm guessing there is something in the cutscene causing the crash, as the game up til now has been relatively stable with only one other crash when I tried to enter the clocktower (though a reload of the game allowed me to proceed).

Specs:
WIndows 7 Pro x64 SP1
Intel Core2Quad 9450
10GB RAM DDR3
AMD Radeon HD6870 1GB (Catalyst 14.2 v1.3 Beta)

pandemoniker
2nd Mar 2014, 13:27
Did not see your post but a newer one about the same problem http://forums.eidosgames.com/showthread.php?t=142038
Experiencing it aswell, contacted tech support, no answer so far :(

Gothik
2nd Mar 2014, 13:50
Interesting, I checked out the other thread and we all seem to be running Radeon 6800 series. Hmm.

pandemoniker
2nd Mar 2014, 15:05
Try to lower all graphic options and the display resolution. Worked for me to view the intro video. Afterwards I switched back to higher settings and played the level

Gothik
2nd Mar 2014, 17:51
I didn't need to lower resolution, but turning down the settings to very low made the cutscene run. Obviously something in that cutscene is causing machines to choke - and not just PCs, I've read reports of Xbox and Playstation players unable to proceed past this point too - minus the crashing.