View Full Version : Unable to proceed (XBOX 360)

26th Feb 2014, 04:58
So I completed Chapter One and made it to the clocktower. However, when I hit "A" to continue, it just goes back to the beginning of the level. I have completed the level countless times and would love to actually finish it.

Thanks for the assistance.

1st Mar 2014, 20:58
Hey man,

I have the exact same problem but just on pc. I think the only thing to do is wait for a patch :/

2nd Mar 2014, 01:48
I had the same thing too, but got it solved. Well, enough to proceed anyway.

See I had installed the game to the xbox, like it prompted me too. In frustration of being bug-stuck in a chapter 1 loop, I tried everything. Finally I uninstalled the game from the console and rushed through chapter 1 (without even stealing the mask). And then the game let me proceed.

I don't know if it was the uninstalling, the skipping of the mask-theft or just mere coincidence, but it worked. A shame I don't have the mask now, but at least it worked.