View Full Version : DX11 and 3DVision Failure

23rd Feb 2014, 15:31
Going to preface this little rant with me saying that this is one of my favorite games ever.
Now that that is out of the way, I am terribly disappointed with the implementation of DirectX11 and 3DVision.
While in DX11 mode the refresh rates of 60hz and 120hz are unavailable and are replaced with 59 and 119.
Also, after tinkering and getting it to "turn on" Stereoscopic 3D it appears to only render one of the two
frames, not sure if it is left or right, but that is truly unimportant. It is noticeable by attempting to increase
3D strength using the in game options and watching the whole screen shift.
(typically that shift would increase depth by increasing separation)

Put the game into DX9 mode and the refresh rates in question returned as well as allowing NVidia 3D vision to
take control of 3D instead of the in game options. But alas still no 3D at all, though the glasses did finally at least
turn on to acknowledge that it is trying very hard to make me happy. Vanilla Deus Ex :HR had much less problems
getting 3D to work and I loved playing it as such. I fail to understand how the newer version with an extra 18 months
development cycle over the original completely breaks an advertised feature. Yes my drivers, Steam, the game, and Windows are all up to date.

If anyone has had any luck getting this to work using NVidia's 3DVision please let me know if you had to do anything
special or if the magic 3D voodoo gods were just on your side and it worked out of the box.
I love this game and would love to take proper advantage of all this expensive crap we all buy for gaming.

Specs as follows:
AMD Phenox II X6 @ 4ghz
NVidia GTX 580 Hydrocopper
8gb Corsair Dominator Platinum

(game runs amazing otherwise and I have no frame rate issues nor stuttering, very happy about that much)

24th Feb 2014, 22:02
Hey, i'm sorry i don't know how to help you but i was actually hoping you could help me :(

How did you "enable" it for Directx 9? i have DX 11 and one of the possible solutions i've read for my problem is to "disable directx 11" but in half a dozen threads no one actually says how to DO that outside of Steam (i'm not running steam, just trying to run game via the .exe)

I am at a complete loss as to how to get this game to run, every single time i try, it immediately gives me the "Deus Ex: Human Revolution has stopped working" error, no blue or black screen at all, just immediate crash (if you can call it a crash when it never starts in the first place)

I have all the latest updates for both the game and my video drivers, my card is a GTX 650, i've tried running it in administrator mode, i've tried replacing the .exe's and .dll's, Nothing has gotten me any progress at all, everything results in the same instant crash