View Full Version : Director's Cut severe problems

1st Nov 2013, 02:37
Edit: I figured I'd update my post here, though it doesn't seem like the devs are paying much attention here anymore. The recent patch to fix mouse behavior in Windows 8.1 has fixed the fullscreen mouse issues for me. While I still don't understand why I have to disable my integrated graphics device and why I have to edit the registry to get the game to run, it is now in a fully working state for me.

Edit: I have found a "solution". I was wrong about the window in windowed mode not being resizable, the typical "resize" icon was not appearing for the mouse but the borders are indeed dragable. Doing so and maximizing the window I am able to keep DirectX 11 on with no mouse lag at a clean resolution. Not ideal, but playable... I hope things like this (as well as all the other issues I see on this forum) get addressed in a soon to come patch.

There are some really weird things going on with the way this game is rendering and it makes the game unplayable.

When I installed the game and launched it, it just silently crashed. No error or anything. I tried launching it again and again but nothing happened. Through Googling I found that disabling my integrated graphics device would fix this, which is really odd and something I've never had to do before. But I did it and launched the game only to find that everything was low-resolution, pixelated, and stretched. Eventually after fiddling with display settings the game started rendering in windowed mode, stuck in a 640x480 window and looking horribly glitched. I couldn't resize the window or even get the frame to at least render cleanly, it's like it had no idea how to render in a valid resolution.

Eventually I got it to somehow render cleanly in fullscreen at 1920x1080 (I had to muck around with the registry to achieve this), but then I noticed problems with the mouse. The mouse is sluggish and difficult to control, as if the mouse were swimming in a pool of jello and the pool was on a seesaw. If I rapidly moved the mouse horizontally back and forth, it would drift to one side. I figured I'd try turning off vsync, a common setting that interferes with the mouse, but if I do the mouse becomes almost completely unresponsive and just jitters around. Then I looked at the refresh rate and noticed it was on 59Hz. Problem is, it won't let me set it to 60Hz. My monitor is set to 60Hz, so I don't know why the game wouldn't allow it. Later I found that disabling DirectX 11 seems to make the game more cooperative, but not perfect and I'd prefer to play with the enhanced visual settings offered by DirectX 11. I paid for the game and I would expect it to be functional.

I've uninstalled and reinstalled the latest drivers for my graphics card, I've installed the latest Windows updates, I've verified the game files through Steam, and I've reset my computer. I don't know what else to do.

Here are my basic system specs, I can provide a lot more information if need be:

Windows 8.1 Pro 64-bit
Intel Core i5 3570K
8.00GB of DDR3 RAM
NVIDIA GeForce GTX 680

Also, I am aware of the mouse issues with Windows 8.1. I have tried the commonly reported fixes but they have had no effect on this game. Besides, I think the problems I've described are beyond mouse lag.

Edit: Here's a screenshot of what it looked like when I initially got the game to launch