PDA

View Full Version : Crash on options



Sady
6th Mar 2013, 11:06
Hey All,

Just bought the game trough steam, have updated the graphics drivers and installed the 9c of direct x...

But when i start the game i get the "failed to initialize direct3d with current settings" error, so good so far... But then when i try to go into options it crashes with a "Tomb Raider has stopped working" message...

Am running on
- windows 8
- nvidia 555m
- Intel i7
- 8Gb of ram

This is the second game i've bought that doesn't work "out of the box"...
Am waiting verry impatiently for a solution...

Regards Sady.

Sady
6th Mar 2013, 12:27
Ok found solution on steam forum,

Aparently you need to create a registry entry by pasting following ( http://pastebin.com/M2XXcjts) in notepad and saving as Tomb.reg. Then double click file answer yes and it should be added to reg.

This solved the launching and options crash problems but now i onlu can choose my intel onboard graphics card as display....


Aaargh this shouldn't be so hard...

Quarantine
7th Mar 2013, 00:56
Same here, I could get past the options crash, but now only the onboard GPU shows up. If I disable the onboard device, the options don't start at all again. Did anyone post a solution for this yet?

Quarantine
7th Mar 2013, 02:36
Ok, I finally got the game to work and it even seems to be stable despite using the latest NVidia drivers.

Problem A) The options are crashing
I solved that by applying the registry fix above( http://pastebin.com/M2XXcjts). Copy the text into a new file 'Tomb.reg' and run / apply to the windows registry.

Problem B) The options not showing the main GPU, but the onboard / Intel chipset instead
To fix this I had to go into the NVidia control panel to 'Manage 3D settings' and then the 'Program Settings' tab.
There I had to add Tomb Raider as a new application by selecting the executable in the Steam directory. In the options below I had to explicitely select the NVidia GPU. Even the 'default' option, although showing the NVidia GPU, did not do the trick.

Now back to Steam after running the options again it actually showed my NVidia GPU and I could configure everything accordingly. Only the 'exclusive fullscreen' option still crashes.