View Full Version : GAME BREAKING BUG - Keyboard Input Not Working

5th Mar 2013, 23:53
Video Card: ATI Radeon HD 6870
CPU: i7-2600 @ 3.40 Ghz
Graphics Settings: Ultra (TressFX disabled)

Game-Breaking Bug, CANNOT PROGRESS:

When I upgraded my Pry Bar tool to open the bigger salvage boxes, I am unable to open the new boxes that take the upgraded Pry Bar tool to open. I walk up to the box and the tool tip says to press 'E' repeatedly to open it. I then attempt to mash 'E' with ALL THE STAMINA I CAN MUSTER and its to no avail. The progress bar hardly fills at all.

Then when I got to the point immediately after upgrading the Pry Bar tool where you and Whitman both together pull the door open...totally unable to get that door to open, not more than a tiny bit on the progress bar.

Luckily, I have an XBOX game pad controller plugged into my computer. I'm able to progress through the game just fine with it as the input device, but not with keyboard and mouse. As well, if I start opening that door with the gamepad and then switch to keyboard/mouse I am able to get the door to open, but just barely.

I have an Alienware computer with an Alienware keyboard. I looked and cannot find any special software driving my keyboard, and my Windows 7 settings for the keyboard didn't have anything I could change to fix the problem.

I really don't think it's an issue where I'm just too uncoordinated enough in either of my hands that I cannot press the 'E' button fast enough. It's probably possible to crank that door open with my computer/keyboard but I bet less than 10% of people could do it.

I even tried it on Normal difficulty instead of the Hard I've been playing on and it didn't make a difference.

Rape Scene: I was TOTALLY UNABLE to complete this scene after over 20 tries with keyboard inputs. At the point you are asked to press left and right repeatedly, there is no quickness that I can achieve to get the game to believe I was pressing left and right fast enough. With the XBOX controller I was able to pass this scene's sequence FIRST TRY. I immediately escaped out to Main Menu and continued my game back to the rape scene and again tried the keyboard about 10 more tries. Not gonna happen.

I hope I'm the only one having this game-breaking problem with keyboard/mouse inputs. If I didn't have this XBOX controller setting next to me already purchased to play Dark Souls, then I'd be absolutely furious about this issue. Luckily I'm still able to progress the game, but swapping back and forth from game pad to keyboard and mouse is frustrating, as is attempting to pass these scripted scenes 20x with keyboard/mouse before I finally give up and do it first try with a game pad. Console port issue perhaps?

I tried to work through swapping back and forth to a game pad when I couldn't progress, but I can't stomach doing so. I'm done playing this game until this issue is fixed because I want to use keyboard and mouse and am totally unable to do so.

Bug #2: Items in Relic Viewer impossible to see at any Brightness setting

I'm not sure if this would be game breaking eventually or maybe just achievement breaking? However, I cannot see a damn thing when the Relic Viewer opens and a relic is being shown where you can right-click and turn it around. Some relics require turning them about to view extra things about them. On some relics, I can see the faintest outline of the bright spots reflecting on some relics. However, even at extremely high Brightness settings I cannot see the relics at all.

6th Mar 2013, 00:44
Thank you for submitting the bug you are experiencing. This is a concern of ours and it will be looked into.

6th Mar 2013, 03:32
***Sorta Fix/Workaround***

I decided to load up the game once more after dinner and give it one more shot. My save was stuck at a point where my upgraded Pry Tool wasn't able to open the door in front of me.

On a fresh load of my save, the door opened right away like butter. It was super easy.

Now that I remember, when I upgraded my Pry Tool I had backtracked to the first campsite I had saw a crate I was earlier unable to open and I opened that crate directly after upgrading my Pry Tool. So, when I got to the next crate next to the door I had to open with Whitman, the game was bugged out.

Maybe the problem is, after opening something successfully with the 'E' button it bugs out to where the input isn't being read correctly? Maybe its after opening one, or maybe it takes a few times. I'll keep playing and let you know.

Please offer a fix in a patch. :)